Bond Public Beta Link

Below you can find a link to sign up to receive beta versions of the Bond Home mobile app. These beta apps will allow you to upgrade your Bond to beta firmware versions.

We’ll occasionally post notes here about beta releases. If you’re in a position to test out a new feature or a bug fix, we’d love to have your input!

iOS: Testflight
Android: Firebase Note: If your beta app fails to install, make sure you’ve first deleted the Play Store version of the app.

If exploring the Local API is your primary motivation for signing up for Beta, please see the local API docs.


Dumb question: How do we add a Bridge (Z or previously updated to V2 beta firmwares) to the V2 app without resetting?

Not a dumb question! There was a migration of users/bonds to the new backend. By logging in to the V2 app, you should have your Bond(s) automatically populate. Let us know if this was not the case and we’ll look in to it.

Okay. Previously we had to have a new login for the V2 apps.
Used my “original” login (1st time got a 403 error briefly popped up on the bottom, but 2nd attempt worked) in the V2 app, and now have the two Bridges showing up.

Do I need to reset the KM PBB device that is “orphaned” in the “V2 login” account? Or can I ask for it to manually be moved over? Or… ? :grin:

1 Like

Sure, PM me that account or the ID.

@jacob Just making sure I am not misunderstanding the post above, our expectation should be that our existing user account will work with the new V2 app? Currently, I get “User does not exist”

Yes, that’s how it should work. Specifically, V1 accounts with Bonds already on them will migrate the login credentials and Bonds over to become V2 accounts.

If you were set up as above, please PM me the account name and we’ll look into it.

I reset my bond to flashing green status but the new 2.9 results in an error of oops something went wrong when I try to add my bond bridge. This happens in both Android and iOS. iOS I seem to get further and it asks for a pin.

I’ve been testing the API for a while but haven’t been receiving firmware updates. I think it might be because I’m not in the v2 beta?

I’ve downloaded the latest beta Android App (v.2.9.0-beta2). My Bond device is displayed and when selecting it, I’ve confirmed it is the correct Bond ID. Unfortunately, when I select ‘Firmware Update’, it searches for a while and then displays the following error: “There was a communicate issue (error 101)”. Any ideas?

Yes, you are not currently registered for the V2 beta. I’ve added you to the Testflight group. For anyone else who’d like to use the beta V2 app, please see the link in the first post in this thread.

Yes, for Bonds not yet on the V2 platform, you’ll need to be in WiFi setup mode before the V2 app can upgrade the Bond. So hold down the pinhole reset button (next to the power supply) for ~5 seconds, until the Bond’s LEDs go green. At this point you can re-connect it to WiFi and it should successfully upgrade.

We’ll eventually get around to removing this requirement once we get all of the device control and recording features working.

Does the v2 app require a new account? It says I don’t exist. Does this mean I’ll need to reprogram all of my fireplace commands again?

Yes and no, it does require a new account, but the account should be automatically created from your old account when you try to log in.

I’ve been told that the app will tell you this if the password is incorrect… I’ll see if we can get that fixed. If you’re sure that your password is correct, but you still get this message, let me know and I’ll investigate.

No, even if you make a new account now and set the Bond up, your fireplaces should still be present, as they are stored in the Bond’s database.

I got a user does not exist error. I then created a new username with the same email address. When I logged in it showed no bond bridge. When I click to add one it recommends I use the legacy app. When I go to the legacy app I see the bridge already there. So it looks like the accounts didn’t automatically sync up? Perhaps a bug?

Right now this message isn’t very meaningful. For example, it is displayed if the password is incorrect.

It’s not a matter of “syncing”, but rather “migration”. That is, it is a one-time movement from one backend to the other. There are two backends (V1 and V2) and when you attempt to log in, the app checks whether a V2 account of the provided name exists. If so, it attempts to log in. If there is no V2 account, it checks for a V1 account with the same name. Currently, if the password is incorrect, it says something like “User doesn’t exist”. We’ll clarify this in the app.

So now when you attempt to log in, it will always go straight to the new empty V2 account. There’s a simple solution: WiFi reset the Bond by holding down the pinhole reset button until the LEDs start blinking green (and no longer). Set the Bond up on your WiFi with the V2 app. Your fireplace should still be present (as it is in the Bond’s database), and you still should be able to use all the V1 services (as the Bond would still be associated with your V1 account)

1 Like

Worked! I have the new app up and running. I’ll begin testing this weekend.

1 Like

I tried this process but my bond is in orange led state now. Tried multiple times to connect to wifi but it didnt help. I see the devices and bridge in new app, but the bridge itself is not responding and not connecting. Tried rebooting the wifi router but it didn’t help either.

Got it to work somehow, but now the new bond app take forever to load the controls for each fan. Anyone else facing this issue?