BOND App Ver 1.142.2 (1) Firmware V2.7.4 Lights Orange

Hi Joel,

Are you on the full V2 platform?

  • Bond Home app (v2.x)
  • Bond Home Alexa skill (not Bond Bridge)

The new platform has much higher reliability. I see a V2 account for you, but no Bond Bridge there.

In Testflight I have BOND V1.142.2 (1) firmware v2.7.8 beta what should I be using? I have the BOND Home app on my IOS devices, but I am using BOND Bridge. Do I have to reset all devices to install BOND Home?

You can “Green reset” your Bridge, and then set it up on Wi-Fi again with the Bond Home app.

For clarification: use the new Bond Home app from the Apple app store, not Testflight, correct?
And the Green Reset doesn’t remove devices normally, correct?

Correct.

Green reset only erases Wi-Fi credentials, leaves the Bond’s database intact.

https://forum.bondhome.io/t/bond-local-api-public-beta-link/589

This is what I had to put on to get my firmware updated to 2.7.4 as it wouldn’t update from the 1.142.2 app however it won’t update now to the 2.7.8 firmware, it just keeps coming up with a communication issue but the app and Alexa work fine.

Still looks like you’re in Testflight and not the app store, no?

I opened BOND Home clicked the + to add the BOND Bridge and then pressed + then choose the BOND in WiFi but that is as far as the setup goes. It is stuck at the second screen.

Are you by chance using iOS 13? (that, is, the beta version of iOS) If so, this is a known issue that we’re working to resolve.

Yes I am on Beta 13. Also I downloaded BOND Home from the app store as I never found it on Testflight. Another thing my Beta account isn’t working can you provide me my info for that or can I just use my regular account? Thanks.

UPDATE: I installed BOND Home on a iPhone with an older IOS it installed, I was able to add the bridge, but then the problems came.

  1. All fans on that bridge didn’t show up, and had wrong and multiples of the same command.
  2. When I tried to add a fan I got to the last portion where you save it and got error
  3. On the iPhone the image was rendered wrong and offset so no way to save it.
    Below are screen shots.
  4. All fans even ones discovered by BOND Home no longer function with Alexa.

Do I have to uninstall the original BOND app? I ran discovery in Alexa nothing new. All buttons on the app work and activate BOND Bridge. Do I have to remove all BOND related switches in Alexa and try discover again?

This screenshot below shows offset notice dimmer button is on edge and cut off.


This screenshot shows error trying to save the fan

This screen shot shows multiple buttons on fan that did show after BOND was added.

This last screenshot is the view on an iPad.

Joel,

Thanks for the feedback!

“Cloud” device migration is currently not implemented. So any of your devices that live on our cloud will be lost, but should be immediately recoverable with a recording. This “migration” feature should be done sometime next week.

The mobile team is investigating these issues now.

And this is using the new Alexa skill (also named “Bond Home”), right?

We’re working to solve the iOS13 issue as well. We will likely need the app to ask for the location permission to do so.

Yes I am using the BOND Home app and I have the BOND HOME skill enabled. The Alexa discovered the devices and Alexa says OK but BOND doesn’t blink. I had removed all the old BOND skill devices do I have to remove the old BOND app? And I have even tried unplugging the BOND.

Here is a major problem I am having.

  1. Named fan “Office Fan” Location "Office. But when I say “Alexa set office fan to 20%” Alexa responds with there are other items named similar. Rename. I also found many duplicate office fan devices even with them being removed and discovered. The old BOND skill is disabled and the BOND app removed. Below is a screenshot of the problem.

Try “forgetting” all the Office Fans. – That may have been an issue with the Bond Bridge skill, but the Bond Home skill should not create duplicate devices anymore.

If you are referring to Alexa, I did that three times. The only one that has the problem is the Office fan.

  1. BOND Bridge Skill (OFF)
  2. BOND HOME Skill (Enabled)
    Removed all reference to Office Fan and ran discovery again. Same number of duplicates still exist.

Aha, I see there are many “Office Fan” devices on your ZZBL42552 unit. We’re looking into it right now.

Thank you. That will bwe great.

Hey @joel!
Looks like the iOS app has a bug parsing some remotes, so they are on your account but don’t show up in the app. There’s a fix coming soon!

OK, will this fix the duplicate devices in Alexa?

UPDATE: I went into the Alexa app and removed all the devices shown except the first two or newest and now the fan functions perfectly. OK this worked, but it doesn’t solve the root cause. But either way a quick fix until I say Discover my devices.

UPDATE 2: After removing the duplicate devices in Alexa app, it worked, but overnight the additional duplicate devices showed up again.

On 2.7.12 the orange light has returned

@marcio My BOND Will not update to 2.7.4 it is on 2.6.36. I have to ask if there is a BETA version of BOND HOME on TestFlight? I never received the invite for the BOND HOME on TestFlight.