Cannot update firmware

Every time I try to update the firmware I get an error:

Did you update to the new Beta app? I think that looks like the old app.

Also, make sure to note this bullet point:

  • It can’t upgrade a V1 Bond through the backend. To get around this, you could “green reset” your Bond and set it up via the V2 app and it should properly upgrade.

@sebbyg are you intending to upgrade to beta firmware or was this presented to you on a non-beta app?

If you’d like to upgrade to a beta firmware version, you should use the V2 app. You can get signed up on the V2 Testflight or Fabric group by following the links on this post.

If you weren’t trying to update to Beta firmware, please do let me know.


Somehow I missed the V2 beta app -

I was able to download the V2 from test flight it but I could not get the bond installed with the V2 even after a green light reset.

Not sure what I was doing wrong. I would switch the phone to the Bond Connect WiFi but the app would never proceed to the next step.

So I’m back on the regular beta app. Would love to get V2 working if you have some suggestions.


Okay, so while connected to the Bond’s config AP you press the “+”, choose “Bond Bridge”, “ignore” the warning, then “continue”? What happens next?

It prompts me to connect to the Bond connect Wifi network which I do,
But then I cannot advance through the setup process.

The app never gets to the next screen.

(I am running iOS 13 beta - just in case that is an issue).


Wonder if airplane mode but toggling wifi only back on would help? I remember that I used that once for a misbehaving Bridge and it worked (not sure if it was a sugar pill and the timing just worked in my favor, or if it was an actual helpful step)

I’ve heard of one other iOS 13 beta user having this same issue. It could very well be that… do you have another device you could try?

I have tried tried it several times - airplane mode etc… No go.
It is likely iOS 13 if I try it with my wife’s phone will I sill be able to control the bond with my own phone?


Yes, just use the same account on both devices.

For another data point, I am also on the iOS 13 beta and I am stuck in the same exact situation.

I also could not get it to update. Android. Seems to be an issue when trying to setup the WIFI connection. Phone seems to connect to the Bond but then will not reconnect to WIFI.

Investigating the iOS 13 problem, looks like it’s a change in the permissions required for requesting the current SSID. On iOS 13 will be necessary to ask for the location permission.
We will implement a fix before the launch of iOS 13.