V2.6.10-beta release

Hey all,

I just released the BOND Android app v1.142.1 on Beta, all Android local API beta testers should have received some release notes via Crashlytics. iOS will come early next week. Paired with this version of the app is v2.6.10-beta firmware.

If you are not signed up to beta test, but would like to be, please private message me with your email address and whether you’d like to test iOS or Android.

I’ll repeat the release notes here:

  • Fix issue where sometimes device/command/signal creation would be doubled
  • Fix issue where sometimes device/command/signal would be deleted, but the BOND app would report the deletion as a failure
  • Fix issue where sometimes transmissions would be doubled
  • Fix issue where HTTP would occasionally become locked and unresponsive

(the following are for BONDs with serial numbers starting with A or B only)

  • Re-enable the config AP if not connected to the internet a minute after setup (to match behavior of newer BONDs, the intention here is to allow reconfiguring the BOND without “green” resetting it)
  • Add support for hidden networks if BSSID is supplied (currently only available through the local API)

@merck Just installed the latest update from TF. When trying to update firmware to 2.6.10-beta it says “Aww snap! We had trouble upgrading your Bond’s firmware. Error code 0x18100.”

Hey @dxdc - you are already on the 2.6.7 beta, right? Not still on 2.5.1 jacob-ugly-db?

That’s right @residualimages… already on 2.6.7 beta

Sorry, just making sure.
I decided to do the update from 2.6.7 to 2.6.10 via Android since it came out first, and had no issues. I don’t think I’ll rescue reset and re-upgrade via iOS just yet.
So your call out to @merck (or @jacob) is definitely the right avenue. I’ll be quiet now. :smile:

I just got the same error (0x18100)

That’s no good! Okay, I’ll try to reproduce and patch it in the morning. @fracai @dxdc so I can better understand what hardware you’re working with, what’s the first letter of your BOND’s serial number? (should be A, B, or Z)

And here’s some text to fill out the post.


@jacob B


And here’s some text to fill out the post.


Identified the issue, but unfortunately I’ve not yet been able to fix it. I just expired Testflight’s version 1.142.1 (fw 2.6.10). You should be able to use the now most-recent version, 1.141.1 to upgrade to firmware version 2.6.7, and it should work. Let me know if it still doesn’t work! @fracai @dxdc.

P.S. As @residualimages says, the firmware upgrade in Android is stable, so if you have an Android device I can also get you the newest app/firmware that way.

I updated to the new beta and I’m already on 2.6.7, so it’s not trying to update. I eagerly await a fix for 2.6.10!

likewise! … thx

It just occurred to me that the API has a firmware upgrade command. Can you post the URL that we could use to upgrade via the API?

Yes! If you’re already on v2.6.7-beta firmware here’s how you’d upgrade your BOND (with serial number starting with A or B) to v2.6.10-beta:

Disclaimer: if your BOND’s ID starts in Z you’ll need to use a different firmware binary, if there’s interest I can supply this as well.

Kick off the upgrade

curl -H “BOND-Token: <Your BOND Token>” -i http://<IP addr>/v2/sys/upgrade -X PUT -d '{"info": "c43e953d34944c792d536e4265a0fb256574c405759e658664d220f054f8266a:bond-snowbird:v2.6", "host": "s3.amazonaws.com", "path": "/bond-updates/v2/snowbird/beta-snowbird/bond-snowbird.v2.6.10-beta.bin", "http_port": 80, "port": 443, "sig": "", "reboot":1}'

You can check the status of the upgrade with a GET to the same endpoint, as follows. The BOND will reboot when the progress from this endpoint reaches 1000:

curl -H “BOND-Token: <Your BOND Token>” -i http://<IP addr>/v2/sys/upgrade

1 Like

Thanks. I never got a chance to try the progress check. The initial request returned ‘{“progress”: 100", …}’ and the progress check would just return HTTP 204 No Content. But v2/sys/version reports 2.6.10-beta

Thanks much. Is there anything in the beta iOS app that is needed or preferred for interacting with the Bond at this version? Or does it not matter?

Thanks again.

It probably downloaded, wrote, and rebooted before you got a chance to check the progress.

The new version of the iOS app was just a method of delivery of this firmware. There shouldn’t be any difference in its interaction with the BOND otherwise.

We’re working on a more sane firmware delivery method, so app releases aren’t necessary for firmware upgrades. :smiley: Coming soon!

To be honest, sending the API command was pretty seamless for me :slight_smile: All that is missing is a way to get the download URL. Maybe an RSS feed?

Or how about a stable and beta URL that always redirect appropriately, and some great new way to have the target hash and sig returned through a pre-update API call?

1 Like

We have a similar system internally, it’s just a matter of polishing it and making it public.