Need to hold/repeat RF signal for a few seconds

HI,

I just installed my Bond Bridge to control my fireplace via Alexa. I got everything working except that the RF signal that is sent to turn the fireplace on and off is too short. I have to give the command multiple times, as much as 7-8 times, to get the fireplace to come fully on. I did manage to setup Alexa routines to do this for me but Alexa has a minimum of 5 seconds between actions so it takes 30 seconds to get my fireplace on or off. Its clear the on and off buttons are actually up and down buttons. On my handheld remote, I hold the on/hi button down until the fireplace is all the way on. To turn it off, I hold the off button down and its off. I need the Bond Bridge to do the same. I need it to either continuously send the command or repeat the command for a preset number of seconds. Is this possible or can it be added?

Thanks,
Marc

Hi Marc,

Welcome to the Bond Community!

First off, it’s most helpful if you post the FCC ID and a picture of the front/back of your fireplace remote. The FCC ID is not personally identifying, but rather lets us know what RF protocol you are referring to.

Second, did you have to record more than one button? Or did the Bond app find a result in our database?

Good news is, either way, if you are familiar with using an HTTP API, you should be able to modify this yourself.

Navigate to the command(s) you want to modify, and then PATCH devices//commands//signal with {"reps": n} where n is the number of times you want to repeat the command. See docs here: http://docs-local.appbond.com/#tag/Device-Command-Signal/paths/~1v2~1devices~1{device_id}~1commands~1{command_id}~1signal/patch

Trying to accomplish the same thing with my fireplace, send multiple signals to get the flame up. I see how the “patch” would accomplish that but I’m not certain how to apply the patch to the bridge. I know the ip of the bridge. How do I do this? Thanks again

@DaDD @appelm: here’s a quick walkthrough of how to do this:

Thanks for the video. Wasn’t sure where you were doing that and then I noticed curl, and after a search found it was included in Win10. Was able to drill down and find the command I needed and will try to patch the reps to a number higher than 1. My question is once I change the reps do I have to do the last part you mentioned regarding transmit tx…

Tried patching following your video with this error result.
C:\WINDOWS\system32>curl -iH “Bond-Token: xxxxxxxxxxxxxxxx” http://192.168.50.220/v2/devices/d90ffd28/commands/08eb5024/signal -X PATCH -d ‘{“reps”: 20}’
HTTP/1.1 400 Bad Request
Content-Length: 50
Content-Type: application/json; charset=utf-8

{"_error_id":23,"_error_msg":“json parse error”}
curl: (3) [globbing] unmatched close brace/bracket in column 3

curl on Windows doesn’t work with the mixed single and double quotes. Try the same request, but with the following change at the end:

... -d "{\"reps\": 20}"

No, you don’t have to. I was just demonstrating how to perform a quick test transmission while you are there. Immediately after the PATCH, the Bond Home app and integrations will use the updated signal parameters.

Ah this is great Merck. I will have to experiment with all of this. Thanks!

FWIW my fcc ID is K9L 1001. It matched two entries in the database but only the second one seemed to work.

@jacob Thanks to you both for helping me with this. Never heard of curl till today but I now have 3 additional commands programmed for my fireplace, low, medium and high that were not available before. All I had was flame up and flame down. All tested and working. Now to see what I can do with Alexa. Any thoughts?

If you set the appropriate actions and arguments, the Alexa integration should just work!

@joaoricardo does the Alexa percentage controller work on fireplaces?

Alexa sees the fireplace via the Bond skill as a switch with only on/off functions, neither of which work

@merck
Right now, integrations just support on/off on fireplaces.
Adding level control/modes is on the roadmap.

It worked! I just opened terminal on my mac and ran the curl commands as you suggested. A few things to note: The IP address was different. I used the Ping command followed by the bondid.local to get the right IP address. Perhaps that’s just due to my network setup. Also, for some reason I could not initially see my device. I had setup the device using the fireplace shortcut when adding devices. For some reason, when I do that and then click on My Bond Bridge it shows 0 devices associated even though I see the device under My Devices. As a result, when I used curl to find my device it would not appear. I played around with adding and removing my fireplace with no success until finally I added the fireplace as a generic “Device” rather than “Fireplace”. With that, the device was associated with my bond bridge and I could find it when I used Curl.

Alexa works great with it too now… “Alexa, turn on the fireplace” and it goes to full flame!

Thanks.

1 Like