[SOLVED] Bond Hub Won't Find My Wifi (Australian WiFI Channels 12, 13, 14?)

Hi,

I have had my Bond bridge setup and running for some time now, currently running the beta firmware, I’ll track down the version later and update this post.

The other day I needed to turn of my router and restart it, and now I can’t get my Bond bridge to connect to the same wifi network it was previously configured with. If I connect my phone to the config ssid broadcast by the bridge and try to join the bridge to a wifi network it can see other networks from my neighbours, but cannot see mine. My wifi network is up and running and used by a number of other devices, and is setup to allow the bridge to connect.

Any thoughts?

I figured this out in the end, which I think I had read about here somewhere. My wifi was set to automatic in terms of the channel, and was operating on channel 13. I think I had read the bridge may have had some kind of upper limit, perhaps 10. I dropped it to 7 and it connected straight away.

1 Like

Good catch! It’s only looking at channels allowed in the USA (1-11). We need to make this configurable and make the app configure it before setup, now that we’re starting to sell outside the USA.

2 Likes

Yes guys, I had the same issue in AU - wasted two days trying to re-connect and almost threw the Bond from the window.

Glad to hear you persisted…

@jacob any update on this after 7 months the only reason I upgraded from a $60 hub to the bond bridge was because the $60 device didn’t allow special characters in wifi passwords… now I have to have the hassle of picking a specific wifi channel (rather than letting the router decide for me) because you haven’t updated the firmware and/or app?

Sad :frowning:

Secondly what’s the go with 2 services linked to google home one of which as “test” in the API gateway name?

@endy / @natan - are you able to give an update on additional WiFi channels support?

Hey!

Sorry for taking so long to reply.

On the latest firmware and apps, we have added Region info to the Bridge! This is related to the compliance region, changing the operational RF frequencies and Wi-Fi channels.

The available options right now are United States or Australia.
Can you try changing your bridge region to Australia and check if the Wi-Fi works as expected?

Thanks!

2 Likes

Hi @endy

Just set up my Bond Bridge in Australia (with it also selected as that region) and unfortunately the Wi-Fi doesn’t connect unless the 2.4GHz channel is at or below 11. So it looks like the region selection doesn’t work or has no impact to which Wi-Fi channels work with the Bond Bridge.

Any ideas on how to fix or whether an update will fix the issue? Less than ideal to force our routers to use a specific channel as that causes other devices to be impacted.

Hi @MajorDanger

That should work… The region selection affects the Wi-Fi channels and the RF frequencies. Maybe changing it back to US and then back to AU “forces” it to work?

I can check some logs over here, all I need is your agreement and the Bond ID of your bridge, that you can send me in a direct message if you prefer :slight_smile:

Sadly I tried switching to and from US region and unfortunately it still didn’t work.

@endy you have my consent to check my logs. Can’t work out a way to directly message you (I guess it doesn’t allow us users to). Can you message me and I’ll share by Bond Bridge ID?

Endy’s currently out will be back next week. — But it would be hard to us to see much on the logs. We may need to set up an AU-configured AP in our lab (in a faraday cage of course!) and test this out. For now I think we just tell the WiFi chip to use the AU region and “hope for the best”. I don’t see a record that we tested against AU. Maybe some other user could chime in if they are using WiFi ch > 11 with Bond in AU.

1 Like

@alexbk66 @MajorDanger ajorDanger Good news. We found the problem. A bug in our firmware. The latest beta firmware for ZZ and ZP Bridges is v2.22.1-beta, and it includes the Australian channel fix. You can now use the product on channels > 11 when Australian region is selected in Settings.

1 Like

@merck Great but how do we get access to the beta firmware?

“beta channel” firmwares are in the normal production versions of the apps available in their respective stores

1 Like