V3.19.x-beta Firmware for Bridges

Let’s see if I can help out a bit…I have EXACTLY the same router as you, so here are my thoughts:

Do you have different SSIDs for the 2.4 GHz and 5 GHz radios? IF you have the same name for both THAT’S probably the problem! Even worse if you have that “Smart Connect” option enabled. My first guess is the Bond is getting confused there.

I have different SSIDs and I use an older phone dedicated to 2.4 GHz which I used to re-add the Bond and back up my settings yesterday. I also use this phone for adding/updating any other devices which only have a 2.4 GHz radio. I sort of ran into this problem yesterday when I rescue reset my Bond, and couldn’t re-add it with my main tablet which I ONLY connect to my 5 GHz radio. Even though I saw the name of my 2.4 GHz network, I could not re-add my Bond without being connected to it. ONE SSID would REALLY confuse things!

Summing this up, MAKE sure the device you’re using is connected to 2.4 GHz, maybe even create a 2.4 GHz Guest Network dedicated to IOT devices, then try to update. If you wanted to keep the same SSID, I guess you could try temporarily turning off the 5 GHz radio, then try to update.

1 Like

Yes i do. None of my IoT devices have an issue with this config including the Bond Bridge (exempting latest beta)

I have this setting disabled, along with Air Time Fairness.

Looking at my ASUS Wireless Logs, I can see the Bond Bridge MAC is connected to 2.4GHz which would be expected from an IoT device that has a 2.4 GHz radio.

A firmware upgrade should not change this behaviour. I had the original Bond Bridge working in the same config for many years, when there was an issue with upgrading @merck kindly sent me a newer gen model which has worked and can be restored with exception to latest beta.

Thanks, working just fine now :+1: All good!

1 Like

Sorry I didn’t help…seems like you have a pretty rare hardware problem.

So, I am seeing something new a couple of days in, since my last post, & I did capture a video. The device seems to be operating, but the lights internally, about 3 of them are flickering at completely erratic rates. If I reboot it by pulling power it will behave for a while, it seems to be the case that after a few hours I begin to see this light flickering pattern from about 3 of the blue LED’s. Any thoughts? This is still the 3.19.6 Beta.

Actually, let me amend this to say, it does not seem to be taking hours now, the erratic flickering 3 LED’s seem to happen about 3-4 mins in after power cycling the BOND….

Video Link:

1 Like

Thanks for sharing the video of the LED ring misbehavior. My units have started doing the same. Will investigate here.

v3.20.x vs v4.x

We will be releasing a v3.20.x firmware to stable on Wednesday (15 Nov). It has the new motor technologies of the v3.19.6 firmware but without the changes to the “drivers” that have caused all the headaches in this thread, (and without Scenes). This way the “masses” will not be disturbed quite yet, but still get Alpha Motors & other new technologies.

In parallel, we will start releasing v4.x.x-beta firmware where we will be adding Scenes and new integrations and shade types, eventually including Matter.


Understood & phased deployment sounds quite logical given the varying issues…. But please too, if you could, opine on the future Matter support & would the need for the H/Bridge plugin still be necessary / negated when that finally does get deployed?

Also, & yes taboo, I/K, but If I may, I have a collateral question for you, & I do know this is a discontinuity bug on Apple’s side between iOS & HomePod OS (I am of course aware it’s a tvOS variant). But, I wonder if this is impacting your Pro bridge that is HK compatible, is really why I am asking this question & is purely limited to Siri on HomePods, (eg Siri from anywhere else, this will all work fine), & of mention, I do use the H/Bride plugin to shunt the BOND into HK for unofficial support, but with the recent Apple updates, ceiling fan rotation direction commands stopped working, eg “Siri rotate master ceiling fan clockwise / counterclockwise”, she will reply the device does not respond, but only from the HomePods, I have to re-direct the command to the watch or iPhone etc & then it works just fine…

Have you seen this with your HK official pro bridge w/ ceiling fans tied to HomePods that you are aware of?

Just curious, as I do have a dev acct with Apple & am preparing to call in a feedback ticket, but I am trying to gather as much info b4 I do. It’s also impacting the Starling Hub I have with Adrain for Nest items, for the thermostat, & only for mode switches, like heat or cool. He pushed a beta to my Starling hub, but it did not resolve it & I need to get back with him as well, so I am seeing these couple of bugs, on yes “un-official” HK devices being impacted, but only on the HomePod OS, curious since you have official support for HK on the Pro model if ceiling fans are currently being impacted there as well, tied to the HomePods?

Thx & again sorry for a cross topic, but while I have you here, I wanted to float that by you for any input as it would be truly useful ahead of opening a ticket with Apple….



When Matter is introduced, the “official beta HomeKit” support on Bond Bridge Pro will be dropped. Upside is that you get Matter on all Bridges, and it should work better than the old dedicated HomeKit integration.

We’ve got a pretty small team over here, and maintaining many integrations is really a pain point for us. Matter seems to really help on that front.

As for HomeBridge and other community-supported integrations that use our API, I do expect that the need for these will diminish, but (1) we have no plans to break these integrations and (2) there may still be benefits to using our API versus Matter, for example for features of devices that are not (yet) supported by the Matter protocol. Maybe your fan has a “Woosh” mode or something. Sharing open-source integrations will still bring value to power users.

Weird. Nothing’s changed on our API, and as we only support shades via the “official Beta HomeKit integration”, this must refer to the HomeBridge plugin. If there’s been some breakage on the fan direction control that must be between Apple, HomeBridge, and the plugin.


Should we see 3.20.x available through the app now? Or am I jumping the gun? I’m still running 3.19.6-beta.

I updated both my Pro units to 3.20 this morning via the app.

Were you running the beta firmware at the time you did the update?

@sburke781 @jpkeenanjr Here’s the deal:

  • v3.17.x = old stable

  • v3.20.x = new stable (doesn’t have anything beyond the beta)

  • v3.19.x = current beta (includes everything in v3.20, plus some platform changes that caused the difficulties discussed on this thread)

  • v4.xxx = future betas (where we will double down on the new platform changes and start getting some new features out there)

So, if you’re on the v3.19.6-beta, don’t worry, you’ve got the latest-and-greatest firmware. The v3.20 version number may be misleading. We will be moving to the v4.x and releasing a bunch of betas on the v4.x over the coming weeks ahead of general availability. This will be mainly for Scenes at this point.

Due to a technical difficulty, we had to wait for v2.48 apps to be released (coming out today) before we can release firmware with a v4.x version number. Sorry for the confusion… I would have liked to release the v3.19.x-beta labeled as v4.x from the start but we had to resolve the updater challenge in the apps. Appreciate your understanding.


All good, thanks for clarifying those points. Yeah, I wasn’t expecting I was missing out, just wanted raise it in case there was something else that may be affected by this, or if others were concerned.

Found out today that because I use my phone for work (not that I need to), they lock down installation of the beta apk’s :frowning: But security is kind of a big deal for where I work, so completely understand and agree with that approach.

I understand the removal of Homekit was unintentional, but it’s also said in this thread you’re moving to Matter and plan to discontinue the Homekit support.

Does this mean until you get Matter implemented and working in a future update we’re screwed if we’re reliant on Homekit? If so, any sort of timeline on that?

Sincerely, a customer with a pissed off wife because our shades don’t work anymore without a remote :sweat_smile:

No. The idea is that eventually we will replace HomeKit support with Matter support. But for now it stays in.

I am on 3.19.2. I went to see if I could update, and found the Bond is offline. The light is a white ring, and the bridge does not seem to be connecting to wifi.

If I factory reset, can I restore from backup? How do I recover from solid white ring where the bond is unresponsive?

I know the thread has gotten long. — Yes, you can restore from a backup after reset. — In this case, you’ll need the “rescue reset”, which not only wipes all data but also reverts to the original firmware programmed at the factory. Details linked below:

Thank you. The reset button was non-responsive but when I pulled power, held reset, then applied power. After about 3-5 seconds the reset above happened.

1 Like

Hello, I am a new forum user. Was HomeKit added to the non-Pro Bridges at some point during beta and then removed? or is this still a pro-only feature? Thanks!

Still a Pro-only feature.