V3.19.x-beta Firmware for Bridges

We’ve released v3.19.1-beta firmware for Bridges. We plan to send this firmware to stable channel Nov 15th (~2 wks from now). Please share your feedback here during that time.

Although it’s always a good idea, for this update especially, please perform a Backup in Advanced Settings before upgrading.

What’s Changed since v3.17.4

Firmware Platform Upgrade

Although it makes no functional difference to the end-user, it is worth first mentioning for beta testers that this upgrade contains a major upgrade in the underlying operating system and drivers from the vendor of the main chip the the Bridge uses. Specifically, we’ve upgraded from ESP-IDF 3.3 to version 5.1. — This upgrade carries with it higher than usual risk due to this change in the chip’s drivers.

From an embedded systems perspective, this is the largest update we’ve made to the Bridge’s firmware in the 5 years since we’ve been shipping the 2nd-generation Bond Bridge. This upgrade carries with it certain risks, so please let us know if you find any issues with the Bridge’s operation.

Why would we bother to make this change in the platform? Transparently, it is in preparation for bringing Matter support to the Bridges. We could have more easily shipped a 3rd-generation Bridge hardware with Matter built-in, but we are committed to supporting and updating the Bridges you have. Thank you for your understanding if there are any bumps along the road.

We give you, the user, the choice of if and when to make firmware upgrades. And you have the option of performing a backup to protect your data on the device. We hope that we are making the right choice in continuing to evolve the firmware available for the BD-1000 (2nd-gen) and BD-1750.


  • Scenes may contain Devices, Groups, and can have their own Schedules. Support in apps forthcoming, expected by Yuletide if not sooner in a beta app. Currently usable from the WebGUI by going to http://<put-your-bond-bridge-ip-address-here>/scenes in a web browser while on the same network as the Bridge.
  • Scenes currently work with Alexa but not yet in Google Home or local integrations.

Works with Bond

  • Added support for Alpha motors (RMS113). This has been much anticipated. Support includes hembar alignment for Groups when used on Bond Bridge Pro.
  • Added support for Rollease Basic – the new 1-way motors from Rollease Acmeda.
  • Added support for BON Windows motors (RMS125), including their motors with built-in lighting.
  • Added support for GAMA single and multi-channel. (Used in Equinox louvered roof systems).

We’ve gotten more requests for TDBU (top-down bottom-up) shade support lately. While we are working on an awesome UI, we’ve put together basic support for the TDBU products sold at SelectBlinds. These are:

  • Levolor TBDU shades powered by AMP motors
  • HONEYCOMB TDBU powered by Bofu motors
  • MotionBlinds-powered TDBU shades

The TDBU shades will appear as two separate devices in the app and integrations. We are looking at ways of bringing them into a single device in the app. Stay tuned.


  • Devices now have _lock_priority and _lock_expiration fields, which were added for use with an as-yet-unannounced product, but could also be useful in circumstances where an integrator wants to be able to lock out other integrations for a period of time. See API docs.

Bugfixes and Improvements

  • Bridges with many devices, groups, and skeds now start up way faster thanks to a database optimization.
1 Like


I attempted to upgrade firmware and have run into some issues. The update did not seem to complete so after a couple of hours I power cycled the bridge and it wouldn’t get to blue light. I factory reset the bridge with a paper clip and removed devices from app now it won’t connect to my wifi. Is there any tips you can provide?

1 Like

Odd. We did have serious upgrade issue in some alpha versions (v3.18.x and v4.0.x) but they were never released to beta.

Was that the “hold down until ring goes white then release” (so-called “white reset”, which wipes all data but keeps firmware) or the “hold down while plugging in power until ring goes red then release” (so-called “rescue reset” which wipes all data and resets the firmware back to the factory version, but is not recommended except for catastrophic situations)?

First thing to try is setting up via the WebGUI:

If that fails, you can try the “rescue reset” which will put the Bridge back on the original firmware version. However, it can be a pain to get it upgraded again depending on the age of your unit—requiring using the WebGUI because we have trouble with the app updating that original version.

1 Like

Update: telemetry shows some crashes while performing device control while on same network as the Bridge. I believe this is now fixed in v3.19.2-beta. (I have no reason to believe this would be related to @Trial_Master report of update issues.)

I tried the green ring process and the white ring process.

Trying the WebGUI process yields the following which never progresses past connecting then reverts to orange ring again. I will try the red ring process.

@merck thanks for the tip on red reset, this got my device back online. I tried a couple of options through the iPhone app. First reset was beta. Successfully got to 3.17.x but the next update to 3.19.2 ended up in the same orange light issue. Another red reset and I changed to Stable releases and after a couple of updates I’m now back on latest 3.17.4 and have restored by backup.

I’m happy to keep playing around with this now I know how to get it working again, so if you have any betas that might allow me to upgrade I’m happy to test them for ya.

Thanks again, happy to have my unit up and running again on this warm evening.

OK, so it sounds like the Bridge is having trouble getting connected to your WiFi network. Can you share some info?

  • WiFi Access Point make & model
  • encryption type: WEP, WPA, WPA2, WPA3, etc.

With this info we’d have some chance of reproducing on our end.


Thanks. Nothing jumps out at me, but a few ideas:

  • Are you using MAC filtering? (On the theory that the updated firmware is not setting it’s own MAC correctly.)

  • Do you have more than one AP in a mesh configuration?

  • Is there anything showing on the router side? Most routers just show a DHCP client table, which I assume would not have any entry for the Bridge because it’s not getting an IP address, but that’s a very nice router—maybe it has some more insight about devices having trouble getting connected?

Also glad to get on a call with your (or anyone else with beta feedback).

Hi @merck

No to MAC Filtering, and only the ASUS router no other AP’s or Mesh.

Unfortunately the router has no Layer 2 reporting capability. Why would the new beta firmware be the only one causing this issue?

I don’t know of any specific issue, however we did update the WiFi driver in the Bridge (from ESP-IDF v3.3 to v5.1).

What would be really helpful is a capture of the serial logs during the boot and connection attempt. Sadly these are not available via the USB port on the ZZ units (only ZP, Bond Bridge Pro). :thinking:

Hi, I flashed the latest beta firmware on my Bond Bridge and appear to be stuck with a bad flash. I can’t get it beyond repeatedly flashing Blue light - and then white when I let it go. It never comes back with any light, doesn’t appear on WiFi, nor sets up its own AP for web based config. Would love some help getting this back online and either on the stable or beta firmware channel.

Thanks !

Bummer. Sounds like it’s crashing on boot. Something in the Bridge’s database may be triggering it.


To recover (“unbrick”) the Bridge, perform a “rescue reset”:

  • Unplug USB.
  • Use a pokey thing to hold down the little reset button.
  • Plug in USB.
  • LED ring blinks white for ~5 sec then goes solid RED.
  • When RED, release the reset button.

This does require either exceptional dexterity, some books to hold down the Bridge in place, or two people.

Now, the Bridge is back on its original firmware it got in the factory, and all data has been wiped. If you have an older unit, it will be on v2.5.2 firmware, which can be tricky to get connected to Wi-Fi. You may need to use the WebGUI as described above. Once connected to Wi-Fi, it may automatically update to v2.17.xxx and then you can update back to stable.

Finally you can restore from a backup, if you made one.

Helping us Figure it Out

Fastest way would be for you to send us your .bbackup file which is generated when you make a backup from your Bridge. This should allow us to reproduce the issue you’ve experienced. We’d restore the backup to a Bridge on our desks, and hope to see the same failure.

On iOS, the .bbackup file can be found in Files > On my iPhone > Bond > backups.

Also glad to get on a Google Meet at your convenience.

@Krustyjonez One other possibility is that it’s crashing connecting to your Wi-Fi network. In this case we wouldn’t reproduce from the backup file. To eliminate this possibility—if you are willing to try—you can do the rescue reset, and then perform the upgrade to beta again without restoring the backup. See if it can get connected successfully to your WiFi on the beta. Then you can restore the backup, which I expect would cause the boot-loop again.

Again, sorry for the inconvenience. This update is a tough one for us, hence the appeal to our intrepid beta testers :slight_smile:

Yeah, that’s a shame. Ok well let me know if I can test anything for you. Rescue Reset is my friend :grinning:

This worked ! Bummer that I have to repair everything but glad to be up and running. It went to the firmware attached, prompted to go to one firmware and then I selected to go the most recent.

Do you remember, which of these LED sequences you got?

  1. white (boot) → ramping blue → spinning blue → orange
  2. white (boot) → ramping blue → orange

In case of (1), it means we get an IP address but cannot connect to cloud (MQTT/AWS).
In case of (2), it means either we cannot associate to the WiFi network, or that we associate but fail to get assigned an IP address via DHCP.

Thankfully we did reproduce a similar issue here with a Trendnet TEW-711BR that we had in storage. Hopefully has the same root cause as your setup!

I have access to an MQTT broker in Home Assistant. Would that be able to see boot up sequence?

See attached I’m assuming this is Option 2?


Sadly, no, because the WiFi connection is a pre-requisite.

Yes! Ok, so at least it has the same outward symptom as this TRENDnet router we have. Hoping the same resolution will apply to yours. Actively working on this now…

@Trial_Master Good news. I think we’ve solved the problem you were facing! Can you try v3.19.3-beta?

Changes from v3.19.2 to v3.19.3:

  • connect even to insecure networks with WPA, WEP, (or WPA2_PSK??)
  • add 2kB more to HTTP server stack, now 13kB, to fix some crashes during device control
  • send Connection close header on all HTTP connections
  • some crash telemetry improvements that should help debug some issues faster