Bond Bridge v4.6 Firmware Now in Beta

I’m glad to announce that we now have v4 firmware available for Bond Bridge BD-1000. This firmware has been available for BD-1750 (Bond Bridge Pro) in stable for some time, but a bootloader (basically hardware) issue prevented release of v4 for BD-1000 for months now. Thankfully we were able to patch the issue, and some intrepid beta users already have upgraded.

The major new capability that v4 brings for Bond Bridge users is Scene support. But moreover, you can now get regular updates again as we add support for new motor technologies and make other improvements.

The v4 firmware includes a major upgrade of the Wifi driver (ESP-IDF v5.1 versus v3.3), so we expect some resolution of some issues with newer Wifi APs. Why these APs are not backwards compatible with older IoT devices I do not know. But let us know if you experience some change in Wifi performance (for better or for worse).


Note: Due to the way we are patching the issue, you will see two updates. First your Bridge must update to v3.21.3.8 which is a kind of jumping off point for getting into v4+. Once you are on v3.21.3.8, you will have the option to install v4.6 or whatever the latest version is at the time you try.

3 Likes

Hi there…

Randy Massey checking in. I did see this update today, & gave it a quick test. My BD-1000 (ZZDE model), did pull the successive updates, & did successfully go to v4.6 & no weird blinking LED’s like in the prior tests last November. I did get the toggle for HomeKit, activated it & saw the code for input. I disabled my HomeBridge plugin I was otherwise using, & then added it to Apple home. It did add as a bridge, however it transferred no devices (I mainly have ceiling fans & a few cloned RF / IR remotes for various small devices).

So, I deleted the bridge from Apple Home, & was going to try adding it again, however now, the bridge will not show up to re-add. Even if I go all the way to just inputting the # in the additional Apple home setup screen, & no bridge icon showing. I did toggle the HomeKit toggle in the Bond app & I did unplug - re-plug the bridge & also did a quick Airplane Mode toggle on my iPhone to re-load the IP stacks.

I did not go any further than this, as far as resetting the Bond etc… I figured I would check in here as I have done in the past & get some input from you guys.

My best & glad to see it’s plugging along on this track.

Oh & v 2.50.0 of the release app using the Beta channel internal setting. I did see in the blue notes link where you toggle H/Kit, that ceiling fans & fireplaces & other devices are not yet available thru HomeKit, but it references beta 3.8.4 & app v 2.43.0, so I am not sure if this is still the case & why nothing transferred etc…. So wanted to check in…

Randy

My update to 3.21.6.8 beta failed. It seems to have caused connectivity issues to my hub as well as 4 devices on my hub.

@RMM Thanks for checking in. Re: AHK, sadly only supporting shade device type natively, so you will want to stick with HomeBridge. Odd that it did not show up to re-add. Honestly we got over the tips of our skiis with the HomeKit support. Too complex for us to support. Hoping we can bring in Matter for native Apple Home integration in the future, but Matter is—at least right now—also very complex from a development perspective.

@Gtfyo Sorry to hear you have had trouble. The v3.21.6.8 update (as opposed to v4.6) has no change to the Wifi driver so I wouldn’t expect any change in connectivity. I did check on your unit thru our customer service dashboard and I can see that it patched the bootloader successfully but indeed seems to have an unstable network connection. — What I suggest is the following:

  1. make sure that the “beta” firmware channel is selected
  2. do a swipe to refresh on the My Devices dashboard.
  3. wait 60 seconds. (This is to give the app time to download a package with all the latest firmware)
  4. do a “green reset” on the Bond Bridge. (Hold the little button until light goes green, then release). No data will be lost, only network settings.
  5. Go to (+) and add the Bridge to your Wifi again.
  6. During the setup, the app should propose an update to v4.6 firmware which will be delivered directly from the app to the Bridge via the Bond Config Wifi network.

Perhaps with the v4.6 firmware the network connection will be more stable.

Just wanted to report my good 'ol ZZCC bridge performed the two-stage update without incident! The bridge went to 3.21.6.8 beta, then 4.6. I only have four fans, so I can’t take advantage of the new features. I guess I just like to be on the cutting edge of updates…
Kevin

1 Like

Same here another successful upgrade to beta 4.6 ; went very excited to see homekit support on my old bond bridge that also only has 7 fans and a fireplace to move off homebridge. Now excited to matter support to get fan

WARNING: Please do NOT rescue reset your Bridge if you have upgraded to this beta.

We solved the forward-compatibility issue, but apparently created a backwards compatibility issue in the process. :man_facepalming:

How can I restore my bond bridge to the stable firmware channel? I upgraded to this beta and all seemed to work. I love the Apple HomeKit integration! But ever since upgrading the device has been flaky. I have 25 roller shades setup in different groups and since upgrading automations randomly don’t work properly. For example I have 5 shades in the living room and only 3 will close. Trying to close the other two from the app or voice control is completely broken until I use the physical IR remote to control the blinds and then app control starts working again. Needless to say, none of this was happening before on the stable channel so I want to revert to that. Can someone help explain how to do that? Changing to the stable channel in the app doesn’t push any new firmware to the bond bridge. What steps do I need to follow to make this happen?

Hey @JLI , sorry to hear you experienced a regression in control. Would you mind working with us to understand the cause of this problem?

in this case it would be great for us to look at a backup file from your Bridge. You can take a backup and then find the file in the Files app on iOS (or similar on Android) and share it to merck@olibra.io.

If you just want to downgrade, sadly we don’t have a way to do that right now because of how we needed to workaround the issue that had long blocked this update. Worst case in ~1wk there will be a way for you to reset.

But please do NOT do a “rescue reset” right now as noted above.

Thanks for your help. I’ve emailed you the backup files. Hopefully they can help resolve this problem.

@merck Just to help troubleshooting, here is what I’ve found over the last few days of debugging this myself. It seems that it’s only when I enable the Apple HomeKit integration that the problem exists. It’s a shame because I was really enjoying being able to use Siri to control my shades, but I tried it a few times and every time I enable HomeKit, there are a handful of blinds that can’t be controlled through the Bond Bridge (physical remote is the only one that works) but when I disable HomeKit everything works perfectly even with the latest Beta firmware. Interestingly it is always the same set of 3 or 4 blinds that can’t be controlled with HomeKit enabled so not sure what is special about those ones that gets broken by HomeKit.

Hopefully this helps so the problem can be resolved in future updates.

Ooo thanks for the HomeKit context. We’ve enabled extra monitoring on our backend (Memfault). Could you give it a try a few more times (to produce the issue so we can observe it live)? I’m suspecting a crash in the HomeKit driver… but want to be sure.

Or if that’s a hassle we can probably repro it on our end just may take ~1 week.

I tried it this evening (2-4hrs ago). Controlled various blinds through the app with HomeKit disabled - everything worked fine. Then enabled HomeKit and tried again and results were mixed. One observation I made was that when using Siri to control a group of blinds (6 blinds in the group) 5 of them closed normally but one of them seemed to hang with a “Closing…” message in the Apple Home main screen. Switching from Home app to the Bond app, the one blind that was stuck displaying the “Closing…” message was the one that couldn’t be controlled anymore. This happened a couple of times on a few different blinds. In one case I had to power cycle my Bond bridge because it became totally unresponsive. After I was done experimenting I disabled HomeKit and everything went back to working properly. So it may be that it is only when control messages originate from HomeKit commands that it sometimes hangs (drops a packet or is stuck waiting for a confirmation message) and that then prevents any other commands from being sent to the stuck device.

UPDATE: We’ve resolved the issue here. I emailed everyone who is impacted and we [are forcing] a v3.21.6.15-alpha firmware which patches the rescue problem. — Sorry for all this. This mess is a consequence of 6 years producing a product and trying to keep releasing new features and versions even for those old units. Sorry we cannot go back to the A and B “snowbird” units, but at least we are really trying to keep all the Z units still receiving updates to the latest we build. (Though at some point we will need a new generation of Bridge and there will be some feature differences.)

For anyone who has not yet updated to the beta, you’re good. You will get v3.21.6.14-beta followed by v4.x-beta and you are OK.

:relieved:

1 Like

Not to derail this thread but if the Bond team ever wants to hear community input on that theoretical next “BD-1001” or whatever model, could always make a thread here dedicated to hearing the requests. :grin:

For anyone who upgraded AND doesn’t leave their Bond always powered on (like me), the update happened within five hours of me leaving the Bridge powered. Opening the app does not force it, time on is what made it happen. Again, another smooth and quick update back to 4.6-beta.

Thanks for the responsiveness and communication!

1 Like

Any known instances / resolution of a ZZ that was on 4.6beta, and which refuses to go up to 4.6.3beta (uncertain if this one needs to go back to 3.21.6.15-alpha first or not)?

Even with power cycle, abort / re-attempt multiple times, it all seems to fail somewhere between 26% - 31%, but eventually either stalls or goes into Error 109 (communication issue).
The Bond app gets confused if it is Online or Unreachable, often showing the previous 26% - 31% progress circle again if firmware update is clicked, before showing Error 109 again.

I’m still having trouble with my Bond Bridge. HK has been disabled, but the device seems very unstable. Frequently crashes and many times automations don’t run as they previously did. Is there anything I should try to restore the device to its previously reliable state? I’ve restored previous backups but that isn’t helping. Any thoughts on what might be causing this? These troubles all seemed to start when I tried the beta firmware a few weeks ago. I’m back on the stable firmware release channel but these issues continue.

Thanks for the report, @JLI. Checking on our backend, I can see that you’re hitting an issue we’ve been tracking for a few weeks in the Lua stack. It’s impacting a decent number of users, so we’re actively investigating.

1 Like