HomeKit on Beta!

HomeKit at Firmware

I would like to let you all know that the Zermatt Pro latest firmware stable release (v3.3.19) includes the HomeKit feature!
The feature currently support Shade devices only.

This feature is disabled by default and its documentation is available here.


HomeKit at Bond Home iOS app

Today we’ve released a new iOS beta app version (v2.40.2) that allows you to enable/disable and see the Setup Code.

If you are not a beta tester yet, join here.

As the documentation says, the HomeKit info is available in the Bond Settings screen and the Manage Integrations screen. Here are some screenshots:

Bond Settings:


Manage Integrations:

HomeKit List:


Your testing and feedback are extremely valuable!

Feel free to send me a private message or reply to this topic, I’ll try my best to help you.

Thanks in advance and have a good weekend!

1 Like

This is great, but I have questions! :slightly_smiling_face:

  • Will this be coming to the non-Pro bridge?
  • Are there plans to support other devices?
  • I tried to join the TestFlight but it says “This beta isn’t accepting any new testers right now.”

Hey @spercure

About your questions:

  • Will this be coming to the non-Pro bridge?

I can’t give you an answer right now, there is a lot to test and discover yet.

  • Are there plans to support other devices?

Yes! But there is no timeline yet.

  • I tried to join the TestFlight but it says “This beta isn’t accepting any new testers right now.”

Thanks for reporting! It is now working again.


Looking forward to hearing from you again.

Thanks for the information! Since I don’t have a Pro bridge I can’t try it now, but I’ll be happy to test if HomeKit comes to the standard bridge.

1 Like

This is an exciting development I am eager to test! I have a Bond Pro bridge. I’ve updated it to the latest beta firmware. I joined the TestFlight and downloaded the latest beta of the Bond app for iOS. I opened it up and tested it out, it still works with my shades and drapes, cool. Then I went to Settings → Integrations, and enabled HomeKit. I wrote down my setup code.

Then I went to the Home app. Tapped the “+” sign. Tapped “Add Accessory,” then “More Options,” then “My Accessory Isn’t Shown Here” and then “Enter code…” I then entered the code I’d written down, followed by tapping “Continue.” Unfortunately this doesn’t add the bridge or any of the linked shades/drapes. I’m just brought back to the screen that says “Select an Accessory to Add to Home.” And my only option is to tap “My Accessory Isn’t Shown Here” again. If I tap that I’m brought back to the same “Accessory Setup Help” screen with the link to tap to manually “Enter code…” Which doesn’t work the 2nd or 3rd or 4th time I try.

What am I doing wrong, and what else can I try?

EDIT TO ADD: I unplugged and replugged the Bond Pro to reboot it, waited a bit… and now I was able to add it as a HomeKit accessory. I’m leaving my post here to help anyone else out with the same question in the future. Now I’m off to play around with this new HomeKit compatibility! Thanks for adding it!

2 Likes

I’m glad to know that you got it working!!

Thanks for a so detailed description of your issue, I’ll try to reproduce it over here and add a fix to the next version.

For anyone else facing similar issues:

The "My Accessory Isn't Shown Here" button doesn’t help…
If your accessory isn’t shown, check if you are in the same network your Bond is configured.

Thanks again and hope you have a good time testing HomeKit! :slightly_smiling_face:

So far this is working out pretty well, I’m happy to have native HomeKit integration with my Somfy shades! Makes me happy I chose the Bond Pro bridge :slight_smile: That said I’m having an issue with my “Door Shades” button, this is the command that opens two shades at once. But I can’t choose a percentage like I can with other buttons, I can only choose 0%, or 100%. Even the “Window Shades” button, which also sends a command that opens two shades at once, works fine, I can choose any percentage. I just can’t with the Door Shades button, and I’m not sure why. Is this a bug?

So good to read that!

Can you please confirm that your “Door Shades” do support the slider in the Bond Home app?

The HomeKit controls should mirror the Bond Home ones, so if your device does not support the slider in the Bond Home app, HomeKit will only allow you to choose 0% or 100%.

One possibility is that the slider is not enabled or you didn’t calibrate the device in the Bond Home app.
Please, go to the “Door Shades” settings screen, select Edit Controller and confirm that Set position is enabled. Also in the “Door Shades” settings screen, select Calibrate your Device and follow the steps.

I can debug deeper but would need your approval and your Bond ID… Send me a private message if you want me to do it :slight_smile:

Thank you!

Thanks for the quick reply. Set position was enabled, but going through the Calibration steps is what ultimately got the slider enabled for that button, in the Bond Home app. I waited a bit to see if the change would sync to HomeKit on its own, and then when I got impatient I disabled the HomeKit integration, re-enabled it, and that got everything working as expected. Now I have sliders for all buttons.

This is great, really appreciate the upgrade. Will we be able to extend shade groups from the Bond Home app to HomeKit too?

1 Like

Good to know that you had to disable and re-enabled it, will look into if we can make it better.

About groups from the Bond Home app to HomeKit, it is not planned.
Have you tried grouping inside the HomeKit?

Wow this sounds amazing. My Acmeda RollEase Pulse 2 bridge has been very unreliable. Shades randomly go offline in HomeKit daily. (Or even offline in the native pulse 2 app) I have TWO repeaters even. The remote controls work perfectly every time though so I’m hoping a Bond Bridge pro setup will be very reliable. I’ll be giving this a shot next week. Looking forward to a working shade automation setup.

Also, I think it’s safe to assume HomeKit will be brought to the ceiling fans eventually as well. I tried setting up a homebridge with the bond plug-in, but it won’t see more than one of my 9 ceilings fans for some reason. At least Siri Shortcuts works with Bond ceiling fans for now but prefer full HomeKit of course.

I’m glad I spent the extra money for the Bond Bridge Pro!

1 Like

Wow Works great!!!

I just setup all 15 of my my rollease acmeda shades. (most windows are dual motor one sheer, one blackout)

Response times are quick. The HomeKit Home app status for each device is accurate. When I leave the home app for a bit and come back to to check out the shades, it does say no response occasionally (on the icon) but when I touch it, the actual status is updated right away. Also, Using Siri to open and close one or all shades is very responsive now.

I just deleted the OEM acmedia pulse 2 hub bridge from HomeKit and will be using bond pro exclusively. This is the best HomeKit upgrade in awhile for my smart home. It’s been a frustrating year when some of my shades didn’t respond or home shows the device as “no response” (and touching it does. I thing times out tryin). I was close to biting the bullet and looking at upgrading some or all to Hunter Douglas, (my skylight shades are Hunter Douglas, and they always work flawlessly) I think my shade nightmare is finally over!

Until Bind ceiling fan HomeKit support is added I’m using Siri Shortcuts via Bond for now. My “Good Morning” Siri shortcut runs a HomeKit scene and then runs a few ceiling fan shortcuts. It actually works finally.
Before today’s upgrade, Siri would always complain about some other devices are not responding or taking too long and then the shade may or may not open after a long delay.

Great work on this, bond pro is worth every penny and prefer the Ethernet connection it has. Looking forward to future updates.



2 Likes

Today the assigned rooms for over half of my shades moved around to the wrong room on their own. Here are a few examples. I successfully move them back to the correct rooms after these screen shots. Not sure what would have caused them the assign rooms to move. seems like a potential bug.


Edit:
I forgot to mention I first noticed something was wrong when I used a new shortcut to close half of my two patio blinds. (And the wrong shades responded) You’ll notice in the screenshot the two accessories are wrong.

PS the assigned devices for shades, were all wrong in my various Scenes as well.

EDIT: it’s the next day now and everything is still good, no further Room changes. Todays “Good Morning” ran perfectly without any problems.

Edit (4 days later) everything is still working perfectly. I’m very happy with the stability and over all performance now.

Edit (7 days later) :100: :+1::tada::palm_tree::sun_with_face:

1 Like

Hi,
I’m very excited about this, and managed to add my Bond Bridge Pro with 19 Rollease Acmeda Shades to HomeKit. However, they all show up as “No Response” and don’t move. Any ideas?

The shades work great (including the slider) in the Bond Bridge app

I’m running the latest firmware v3.5.2-beta and the latest Bond App v2.40.2-beta

Thanks,
Hendrik

Somehow HomeKit reports it as Firmware 3.4, but the Bond App confirms it as v3.5.2-beta

Feel free to look into my logs if you want. @endy

They might say no response, but do they still work via home app?
What about when you assign them to a scene?
Sometimes when I view the shades in the home app, it doesn’t show the status, but as soon as you touch it the status updates. My good morning and good night scenes have been 100% responsive and great for weeks now they’ll

Nope, they don’t respond to controls in the home app, and neither when I add them to a scene. I’ve tried rebooting the bond bridge as well

Looks like I am on an older beta firmware. I think I’ll hold off updating until I confirm there’s not a problem.