Can't upgrade to 2.7.8

I’m on 2.7.6. It says I have an upgrade to 2.7.8 available but whenever I try to do it through the iOS v2 app it goes to 10% then says there is an error 107 (the error has a typo, it says coulnd’t). However, I don’t believe there is a communication issue. The API works, alexa works, the app works to control my device. Just upgrading the firmware fails.

There’s an issue on some V2 Bonds with serials starting in A or B where, after 5-10 minutes, they become un-upgradeable. This issue appeared in v2.6.41 and was patched in v2.7.8. So, my suggestion is to power cycle your Bond, and upgrade it when it reconnects to WiFi, then the upgrade will be more stable going forward.

1 Like

Are we all mapped to get 2.6.7 / 2.7.8?

My iOS device (on iOS 12) shows up to date for both BB (2.6.42) and ZZ (2.6.36) Bridges. Bond Home app from App store, version 2.10.0.

My Android device (on Android P) shows up to date for both BB (2.6.42) and ZZ (2.6.36) Bridges. Bond app from Play store, version 2.10.0.

Rebooted the BB in case it was having issues as you described.

The App/Play store (“public”) versions track a different version of firmware than the Testflight/Fabric-distributed (“beta”) apps, the two versions you listed are up-to-date for the public release.

The current beta firmware is v2.7.12 for all Bonds. This version was just released a few hours ago.

That worked, after rebooting the hub and doing it in 5 mins I’m on 2.7.12

After going back to Testflight (2.10.0) and Beta/Crashlytics (2.9.0-beta2) versions, I was able to successfully update to 2.7.12-beta, including on the BB unit with the reboot and update immediately trick (although it took much longer on BB than ZZ unit).

similar issue. on 2.6.42. Says 2.7.13 available. Can’t update Goes to 10% and then fails…

This is almost definitely due to an issue that was introduced in v2.6.42 and patched in v2.7.8. A/B-prefixed Bonds become un-upgradeable 5-10 minutes after boot. To get to v2.7.8, you should power cycle your Bond then upgrade.

hi Jacob, reboot worked


1 Like

Same here on Android . Rebooted Bond and it upgraded the firmware. Now to test the Somfy integration