Firmware Upgrade Failure - Error 0x18100

This happens every time I try to upgrade. I don’t know if it’s connected, but I’m also getting unpredictable latency. Sometimes Bond doesn’t issue an Alexa-generated command until the next day or in the middle of the night. Having the lights turn on while you’re sleeping gets old pretty fast. I have a “B” unit running v2.6.7-beta.

Hi @takedownca

We have had some delay reported in the past days, and we are working to solve that. Yesterday was deployed a critical patch to improve the command’s performance.
Please, let me know if you experience that again.



Yeah this is a known issue with my recent beta release. You could try out the V2 app — Bond Home on the Play/App store. We’ll be making beta releases via that V2 app very soon (next week or the week after) and this upgrade process should be much more stable.

So I should uninstall the beta app that was installed via TestFlight and install Bond Home instead?

Actually, now that I think about it, if you used the Bond Home app right now, you’d need to set up your devices from scratch, signal-by-signal. If that sounds acceptable and you just want to test it out, go ahead. For most users, it’s probably preferable to just delete the Beta app and download the current stable app from the app store (the V1 app is called Bond Bridge now, by the way).

Sometime in the next couple weeks we’ll make a Beta release of the V2 app with full support for your device. I’ll announce that here when it’s ready.

Ok, sounds like I’ll wait to install the v2 app and just reinstall the Bond Bridge (v1) app. But will the v1 app work with the beta firmware that is currently on my Bridge? If not, can I use the v1 app to replace the beta firmware with stable v1 firmware?

Yes, it should. All current releases of V2 firmware have a compatibility layer to work with the V1 app.

You could do this as well. though it shouldn’t be necessary.

getting the same error on the V1 beta

Will try and setup the device on the v2 App from the iOS store

rest the controller to factory and i was able to load the new firmware… still unable to see my fans in SmartThings

Still can’t downgrade firmware from 2.6.7-beta to 1.138.1. No errors. It just times out. What is the next step?

Getting an error when I try the firmware upgrade.

Can control all devices. Just not perform a firmware upgrade
Am on the 2.6-21 beta firmware

Sorry, reading my response above and I’m not sure what I meant at the time: downgrade from V2 to V1 is not supported, except via rescue reset, which will cause the erasure of all local devices. You can do this by holding down the pinhole reset button while plugging in the Bond, and continue holding down the button for ~5 seconds, at which point you should see the LEDs flash.

Is there anything that the V2 firmware is doing that is preventing you from normal use?

Thanks. I’ll try the reset button.

To answer your question, the V2 beta firmware has been buggy. Bond does not respond to Alexa commands as well as it used to. Often the command is either ignored or is not processed for hours. It’s pretty annoying being woken up in the middle of the night by a fan light randomly turning on. I know I don’t have latest beta firmware, but I couldn’t upgrade to a newer one using the beta app :man_shrugging:t2:

I believe we identified and patched this issue, it should work now. Let me know if it still doesn’t work!

hi Jacob,

Thanks for helping with addressing the update errors.

I can now see the firmware update in the app to v2.6.36

When i go to apply the update, circle gets to 100% and then i get an error 108 (communication issue),

tried rebooting the hub, still fails

After a few reboots/ retries/ failure messages, now the hub says ver 2.6.36, but when i click on the Firmware update now, i get current version

Please let me know if you need any additional details

So looks like your upgrade was successful! The app just had a communication issue (#108) with the Bond in the middle of the process. Probably just a timeout issue. We’ll look further into what may have caused that.

1 Like

Jacob, I’ve been unsuccessful flashing the firmware via several methods. I reset (5s) and couldn’t flash firmware via either old app or beta app. I did a full reset (10s) with the same results.

Right now I’m stuck with an older unstable beta firmware with no way to flash either v1 or newer v2 firmware. At this point would it be fair to request a newer Z unit as a replacement? Thanks.

Rescue reset procedure:

  1. Unplug the Bond
  2. Hold down the pinhole button
  3. While holding down the button, plug in the Bond
  4. Hold for ~5 seconds, until the Bond’s LEDs flash

Based on your description, you are missing the unplug/plug-in parts, right? This will restore the version of the firmware that you had when you opened the Bond. At that point, you could resume using the V1 app.

Unfortunately, this was nearly everyone’s experience with the Bond a few weeks ago, independent of V1 or V2 firmware. We’ve made significant changes to our backend, and we’re confident that we’ve eliminated this issue. Apologies for that obviously very annoying bug.

For the most part, that version of the firmware is stable. There have been some bug fixes here and there, but the issues you’ve described are related to the backend, not the firmware. At the start of next week, a version of the V2 app will be released with support for your device — I encourage you to try that out, as the upgrade is more reliable.

See this post for more info on beta testing the V2 app.

It took a couple months, but the reset worked. I was able to update firmware to 2.8.3. I had to re-add all 7 of my devices, button by button, but that was expected. It’s probably why I procrastinated for 2 months :slight_smile:

1 Like