V2.6.7-beta release

I just released iOS version 1.141.1, and at the end of last week, I released the same version for Android.

These two apps will upgrade your BONDs to the newest version of the Beta firmware: v2.6.7. The following only applies to BONDs with IDs starting A or B:

There are lots of fixes here:

  • The process of connecting the BOND to your WiFi should be much more stable
  • You should be able to more reliably reach the BOND via mDNS (the <BOND ID>.local name)
  • Various RF fixes. If your BOND’s device wasn’t properly controlling your appliance, give it another try now

And, what I want to make most visible:

  • The BOND is now upgradeable

The jacob-uglydb version had an issue where it almost always would fail to upgrade. v2.6.7 will properly upgrade, but if you’re on the jacob-uglydb version you will need to rescue reset! To do so, hold down the reset button with the power cable unplugged, plug in power and continue to hold the button down for ~5 seconds. Unfortunately you’ll lose your saved devices, however, they may still appear in-app but be unusable. You can delete them and then re-add them.

If you’d like to beta test, please private message me with the email you’d like to use, and whether you use iOS, Android, or both

1 Like

when i run

curl -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands

where xxxxx is my token id

i’m not getting the list of commands but instead:

{"":“59261dab”,“0000003e”:{"":“8facf8c5”},“00000040”:{"":“1104bbd4”},“00000042”:{"":“603d608f”},“00000044”:{"":“bbcaf174”},“0000004e”:{"":“cfd4ac7e”}}

is there something i’m doing wrong

The BOND API responds with only a single “layer” of its API at once. What you got is a list of the command IDs (and a bunch of hashes, which tell you if anything has changed). You could then follow this up with:

Get info about a command. It’s name, the action it performs, etc.
curl -H "BOND-Token: xxxxx" -i http://10.0.0.17/v2/devices/00000006/commands/0000003e

Get the signal associated with the command
curl -H "BOND-Token: xxxxx" -i http://10.0.0.17/v2/devices/00000006/commands/0000003e/signal

Transmit the signal associated with the command
curl -X PUT -H "BOND-Token: xxxxx" -i http://10.0.0.17/v2/devices/00000006/commands/0000003e/tx -d {}

EDIT: Jacob already handled it. Thanks, @jacob!

If you do these commands, what do you see?
curl -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands/0000003e
curl -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands/00000040
curl -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands/00000042
curl -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands/00000044
curl -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands/0000004e

I have a feeling you will see that those values you got already are actual commands, and their details look something like this (not this one specifically, but this format):
{“name”:“Speed 4”,“action”:“SetSpeed”,“argument”:4,“icon”:“button_speed_4”,"":“3830659a”,“signal”:{"":“6c285511”},“tx”:{"_":“163b0b24”}}

To test the command is being sent, choose one of those (after seeing what the name is so you know what to expect the fan to do in the real world) and PUT the TX:
curl -i -H “BOND-Token: xxxxx” -i http://10.0.0.17/v2/devices/00000006/commands/0000003e/tx -X PUT -d {}

thanks for the response! i tried sending the commands for all of them and i get:

HTTP/1.1 204 No Content
Content-Length: 18
Content-Type: application/json; charset=utf-8

any ideas what i’m doing wrong?

Nothing wrong, that’s all it should return. :slight_smile:
(I get a content length of 0 instead with cURL, but you should get a 204 No Content / Success message, and it looks like you are)
You should, however, see something happening with your fan / lights.

sorry my mistake, i was toggling the wrong fan for a room i wasn’t in. thank you again!

1 Like

Glad you found the right one! :confetti_ball: