Select Blinds - Classic Roman Shades [Bofu BF-305] has a lot of different types of remotes–some Wifi and some are RF only. Even among the RF blinds, it seems they have two or three systems!

I ended up purchasing Classic Roman Shades which comes with only a 5 channel RF remote. And supposedly it doesn’t pair with more than 5 blinds total.

I’m trying to figure out what my chances are that it would be compatible with Bond. Is there any way to know ahead of time?

Sadly, there’s no surefire way to tell without equipment more expensive than a Bond :slight_smile: . This is because these protocols are not standardized and every manufacturer does it differently (even sometimes between production runs on their products :scream:).

But, if you take a picture of the front and back of the remote control and upload it, we can tell you if it will surely not work (if the frequency is out of range). You could even do it yourself: google the “FCC ID” from the back of the remote. If it is in the range 300-450MHz, it might work with Bond Bridge.

You can always return the product if it doesn’t work. But if it does, let us know!

I have Select Blinds in one room and Somfy in 2. Bond works like a charm on the Somfy, but doesnt seem to work on the select blinds.

Here are some facts and observations:

  1. The Select Blinds use a 433.92MHz frequency
  2. The Select Blinds remote is model: BF-305
  3. The Bond seems to learn the code from the remote (light turns the appropriate color) but doesnt seem to respond when I press the button in the app to test the new button.
  4. I have used the advanced configuration to set the RF frequency to 433.92 after several failed attempts. It still does not control them.

Anyone who can provide assistance or insight here would be appreciated.

I think that corresponds to

@jacob / @merck - does this sound like a rolling code and/or complicated encryption or protocol?

1 Like

Being very new here (got my Bond yesterday), does this help at all? Looks like an arduino project using this remote looks like it may have some info in it.

Do you think I have to enter a pairing mode or something?

We do have a similar-looking remote in our lab (but unfortunately the one we have arrived without model/fcc info labeled). We need to double check if it can be “raw recorded”, but we were unable to get it in our database for “one-click” setup due to technical difficulties with the protocol.

I did not see this. So thank you for reply. Does this mean it wont work with Bond? Or that it just wont work right now? Do you think it needs to be in some pairing mode like with the Somfy?

It may also be worth noting that the Broadlink Hub was able to learn the commands - I just cant get it to work in my Home Assistant set-up as well as the Bond Hub. So I am really hoping to be able to teach the Bond Hub this remote, so it can control all of my shades.

the Broadlink Hub was able to learn the commands

That’s a useful piece of information. AFAIK, Broadlink uses only a “raw recording” approach, which Bond Bridge should support.

Thanks for the model info (BF-305), but is there an “FCC ID” code on the back of the remote too? Possibly under battery cover?


I don’t see one on the back or in the battery tray. Is there somewhere else to look?

Here is a manual I found that has an exact illustration of the remote.

Sorry for all the replies but Is this it?

Odd thing happened this morning. I tried setting up again, after you said that it should work. And I tried a few times, and then entered the advanced settings (which I had done before) and all of a sudden I got it to work.

I think the issue on these shades (or the hub?) is that the bond hub blinked really quickly, and you have to be pretty immediate. Once I got the speed down it worked.

1 Like

I would like to jump onto this thread with my experience:

I installed SelectBlinds motorized cellular blinds that use the same remote mentioned above. The instructions say to press the up/down for 2 seconds to command a raise/lower (a 1 sec press does a pulse “fine-tune” up or down, why anyone would use that is beyond me)

When I program it into the hub, the Bond app. sends the “pulse” – is there a way instruct the hub to lengthen the press interval?

Yes, but not built into the app.

Here’s a tutorial that’s doable if you’re familiar with a command line:

[EDIT: What I neglect to say in the video is that the raw buffer is 0.6sec recording. So reps=10 would be a 6 second transmission. Usually you’d only need reps=2 or reps=3]

1 Like

@wiseacre but wait! I think we just fixed this in today’s v2.15.1 firmware release!

Pse upgrade, delete/re-add the shade (or just hit the “reload” button inside device settings), and let us know how it goes!

1 Like

I tried the patch commands (I used 3 as the operand) and it does 3 short movements. So … good news: that works, bad news: it changed the reps and not the duration of the rep.

I upgraded the F/W and I do not have a “reload” function in the bridge settings, I’ll reprogram the shades and retry

A recapture of the remote yields the same behavior - short pulses for open and OK operation for close.

Huh, ok. What’s happening is that there’s some gap of zeros in the data field which the shade is interpreting as a pause between button presses. — You could fix that problem by editing the data field to remove the excessive trailing zeros.

I know… ideally you shouldn’t have to mess with this. We should add this remote to our database. Can you post the FCC ID and picture of front/back? @guyz can take a look and we’ll get this added in an upcoming firmware if at all possible.

There is no FCC code on the remote or the box it came in. I’m not going to pry it open, or my wife will evict me and then it becomes a moot point.

The box is labeled CS5138W Simplicity all purpose remote, White

I gave Sophia the pictures in support ticket 43619, let me know if you need closeups

I have the same BF-305 remote and SelectBlinds motor as Wiseacre, and I’m having similar issues when attempting to use the Bond Hub. In my case, I had the Bond Hub learn the commands, and I got the Bond Hub (through the app) to open and close the shade, but not reliably. Sometimes it opens or closes immediately, and sometimes it takes several tries to get it to work, but it will eventually open or close after several attempts.

I suspect I’m having the same issues as Lawsuitup------the signal sent by the Bond Hub is too short and is sometimes not properly received by the SelectBlinds motor.

I have the latest app version. I have not yet figured out how to access the command line to make any changes as Merck has indicated earlier in this thread. I’ve taken my remote apart, and I cannot find anything that appears to be an FCC ID in this remote.

Any updates on progress to make this remote work with the Bond Hub?