Mobile Apps v2.12.0 — Somfy shades and better bridge support

We just made a release of v2.12.0 of the Bond Home app to the App and Play stores, with an accompanying release of v2.7.13 Bond Bridge firmware. This version supports creating remotes for Somfy motorized shades! If you have some Somfy shades, try it out! There’s no need to “record” a remote, the Bond will generate one for you and guide you through pairing the remote with your shades.

If you’re coming from our V1 app (now named Bond Bridge): you’ll need to “WiFi reset” your Bond Bridge to get set up in the V2 app (name Bond Home). To do so, hold down the pinhole button next to the power supply until the lights go green, then set up your Bond Bridge in the V2 app. We will streamline this process soon.

This version is still in BETA for Bond Bridges, but the support is greatly improved, it’s mostly stable and we’re close to taking the BETA tag off. That said, we know there are still some issues with the V1->V2 transition, so please let us know if you have any trouble with setup so we can debug.

so you are saying, i can control my Somfy RF curtains with the bond APP now ?

Have 3 Glydea Motorized tracks in our family room

Will try it soon.

Edit: Success… now i can control my Curtain tracks with Bond app… Only wish there was a way to chose a different icon to represent curtains rather than shades…

1 Like

Yes, the Bond will create a “remote” for you which you can then pair with the curtains.

Let us know how it goes!

hi @jacob i edited my post above… it worked

only issue was the first time i paired the motor, it only created the down and MY buttons and nothing worked.
Deleted and paired again and all 3 buttons showed up

1 Like

Ah, I’ve seen this before, it’s a syncing issue. We’ll look into fixing this.

By the way, for Google home you could say: “Open/Close {name}”, for Alexa you could say “Turn On/Off {name}”. We’ll get the “preset position” functionality into integrations soon.

Good feedback, thanks!

Worked for me - thanks for adding this! I did need to figure out the process to have both my shades controlled at once. I selected the first shade with the remote, pressed the programming button, paired it in the app, then rather than selecting “Done” on the app I chose Pair again, chose the second shade with the physical remote, pressed the programming button again, then paired. At this point both shades are paired and seem to work well.

2 Likes

will the shades also get exposed over the API and in SmartThings ? I currently only see my 2 fans in ST…

The shades are exposed over the local API, so when we get around to fixing SmartThings, they’ll be there as well.

First question is, do I need to be on the “official” or the beta App/ firmware for this to work? I’m currently using App 2.9.0 beta2 and firmware 2.7.15-beta and I’m not able to figure out how to add my somfy stuff.
I clicked on Add Remote and selected Shades and pressed Continue… then it shows me a blank screen saying “Choose a Command” but no other option. If I X out of it it adds an icon to the main screen which has an “Edit Command” option on it but again nothing under it

You’ll need v2.12.0. I’ll look into why you didn’t receive this version when I’m at a computer, but for now you could just get the Play/App store version, it is the same version at the moment, so it supports Somfy.

1 Like

After transitioning to the new app I can’t control my devices through IFTTT. Is there a workaround to get them to work?

That worked perfectly. Thanks

It appears that a couple of your commands changed IDs, so IFTTT is still trying to use the old IDs. You should be able to set the same triggers back up, and they should work.

I’m looking into the root cause of why exactly the IDs changed, that wasn’t expected.

@jacob Can you please update the API docs to include the new ms device type

http://docs-local.appbond.com/#tag/Devices/paths/~1v2~1devices/get

I’m assuming this is for motorised shades and not a specific somfy device type.

Looks like it has actions for OPEN, CLOSE and STOP among other things.

Given the stability of the app at its present stage we are going to release our Control4 driver out to the wild next week or two before i head off to CEDIA Expo.

I opened and resaved the applets up but no luck. Tried signing back in to bond on IFTTT but that didn’t help either. What is odd is if I rename the device on bond it doesn’t propagate to IFTTT.

That’s right, MS is used for any motorized shades, I’ll add it to the docs. To know that the device you’re looking at is specifically a Somfy RTS-controlled device, you could look at the devices/{id}/properties endpoint. This endpoint can hold arbitrary JSON — for Somfy RTS it has a key "branding_profile" with value "Somfy".

Somfy RTS specifically has Open, Close, Pair, Hold, Preset.

The stateless actions are detailed here.

Note that Stop is present on any device, and it merely stops any currently in-progress transmission. For the “stop moving” action, we’ve gone with the name Hold so as not to clash with Stop.

Hold is the same as Preset for this setup, it acts as the Somfy RTS “my” button that either stops the motor if it’s currently in motion, or moves to a preset position if it’s not currently in motion.