HunterDouglas PowerRise 2.0 with Platinum Technology

Headline says it all. Does anyone know if the Bond works with HunterDouglas’ older PowerRise 2.0 technology? The remote is both RF & IR.

I don’t have those shades, but if the FCC ID on the remote is WS4U it looks like the RF component of control is 2.433-2.471 GHz - which is outside the range of Bond Bridges.

The IR piece seems more potentially useful, but I’m seeing it called out in the Platinum 2.0/2.1 manuals that IR-compatible shades may be individually controlled via IR. Seems the groups of blinds are only the RF?

Thank you for this, after reading your response I decided to dive right in and ordered a Bond Bridge. It has now arrived, and I was able to set it up and update to f/w 2.28.0

As you said, the HunterDouglas remote’s ( RF is out of range, so I was hoping to use the IR instead. When I tried to add the IR “instruction” to the Bond Bridge, nothing happened. The ring continued to flash blue for the full 30s regardless of how many times I pressed and held the up or down button the HunterDouglas remote.

I verified that my remote’s IR is functioning both by pointing at a blind and operating and by looking at with a webcam.

What are the steps to troubleshoot this? I’m assuming all IR is within “range”?

Happy to have you join us in the community experimenting with what is possible!

As far as this goes, it remains to be seen if this will work for you.

From Bond’s official “Supported Devices” page, there is this comment:
IR devices that use 38kHz OOK modulation

I did find a document on Hunter Douglas’s site which, on the last page, specifies IR: 40 kHz (no mention of modulation).
@merck - this isn’t a case where 38 kHz is “close enough” to 40 kHz or a nominal labeling thing, I am guessing? 40 kHz is unsupported at the IR hardware level?

@rr_russ found and recently shared there is an official Hunter Douglas network-based (or even RS-232 based) API - but sounds like you need a PowerView hub of theirs to make this work.

For the Bridge to record the remote, our receiver is centered at 38kHz or 40kHz depending on mfg batch, however the filter is wide enough that it accepts either frequency just fine.

For Bridge transmit to the IR device, the Bridge transmits with 39kHz always (if starting with Z serial, otherwise 40kHz). 39kHz was chosen to be able to hit both 40kHz and 38kHz receivers.

So, it’s a good sign if the manufacturer advertises “40kHz”, but it doesn’t guarantee anything.

1 Like

I just bought a set of used Hunter Douglas shades that just happened to fit my bedroom windows so that I could experiment with this before making the commitment of full custom shades in other rooms. I also found a used Gen 1 Powerview Hub to bridge the shades to my vintage automation gear via the API @residualimages mentioned.

I’ll keep the forum posted on the results after I get the hub. It should basically do the same job that Bond would do… if Bond supported 2.4GHz.

EDIT: Apologies @Juggler - I just realized that you said PowerRise, and what I have is PowerView. It looks like PowerRise was discontinued, and a search on Hunter Douglas’ website came up with this comment:

The new PowerView Components use a different communication method from previous Platinum™ Technology platform and cannot be used to control older shading products.

So, the PowerView hub and related open API won’t help you with your shades.

1 Like

This is a long shot - but I’ve done a lot with IR in the past, and have used this technique with a troublesome device.

Perhaps you can learn the shade’s IR commands with another 3rd party IR remote. Then use that IR remote to teach the commands to the Bond hub?

The 3rd party remote may recognize something about the IR signal, repeat pattern, etc, that the Bond device isn’t seeing. After learning it, the 3rd party remote may transmit an equivalent signal that Bond can learn and re-transmit successfully.

Thanks, @rr_russ - I missed that detail.

Sorry for the misleading / inaccurate posts, then, @Juggler. :slightly_frowning_face:

Wonder if we community members could slowly, via API, build out a device and each commands with you, @Juggler

Unless @merck you think of a way that Bond staff could ingest this data and make an IR template?

That’s assuming this is all correct:

That being said, I read elsewhere that in the earlier days of PowerRise when it was first going to dual mode IR/RF, that the IR commands were found to not reliably work because the Hunter Douglas remote sent a short RF burst to “wake up” the battery-powered PowerRise controller/receiver to then “listen” to the IR commands.

Thank you all for the replies and suggestions – amazing to see such an active community! I will give it a try and report back here. I was able to briefly get a green light when I added a device and through the advanced option selected IR only. Unfortunately, work called, so I couldn’t go any further.

1 Like

If you don’t mind @rr_russ - where did you find the used PowerView Hub for sale?

Just had HD blinds installed and was disappointed to find* they didn’t work with my Bond bridge, so now think I’ll get the PowerView hub. But there seems to be practically no one selling them online, and certainly not used/ at a lower price than the HD reseller would offer…

*I did know that ahead of time after I investigated the frequency (with thanks to @residualimages). But the Somfy blinds in my previous apartment were allegedly out of range too, and worked perfectly. So, I had a glimmer of hope that the HD ones, too, would be compatible

@Mahhhky, They do seem to be rare on the used market, but I found 2. I’ve sent you a PM with the contact details for the person I didn’t buy from. He has a gen1 and gen2 hub available.

I tried again a little more thoroughly this time. I added the remote, went to advanced and selected IR. I then tried with and without searching the db. When I searched the db, the app suggested “Dooya DC1602, DC1600T”. Trying this, it did not work. I then tried without searching the db. After getting the green circle, I tried executing the command, but nothing. In both cases, the app showed a carrier frequency 0.038 MHz.

Is there anything else I can try?

In one of the forums I linked above, it seemed like someone was able to verify that, at least for battery powered shades, the shade needed “woken up” with an RF command first, then the IR would be listening. It was an undocumented feature and automatic on the part of the remote; the user didn’t have to do anything to make this happen and the user would also have no reason to assume it wasn’t working fully via solely IR.

Is it possible to use the remote while it is in IR mode in your pocket (or otherwise concealed) to send a different command right before you send the test IR command from the Bond Bridge?

I’m not sure if that is correct. When using the IR on the remote, you simply need to point the remote and hit either the up/down button and the shades start to work.

I thought I would try the following:

  1. Start the learning mode (IR only) of the Bond Home.
  2. Cover the IR emitter on the remote, press the down/up button and hold.
  3. Uncover the IR emitter while pointing at the Bond Home.
  4. Release the button on the remote.

The result was that the Bond Home never went “green”. The only way it learned a signal was when the full sequence (press button, release button) occurred while the IR emitter was pointed at the Bond Home.

Is there any way to manually enter the IR “codes”? Would be great if I could copy/past the HEX codes from the RemoteCentral site linked above.

If you were willing to try and you had a computer with which you wanted to experiment with cURL, you could POST a new Command to your existing test Device you’ve made from scanning attempts, and then PUT a new Signal, with something like this as the payload (this is ‘Open1’ from the site I linked above):

"freq": 38,
"modulation": "OOK",
"data": "000000630000009c00700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a004e",
"encoding": "hex",
"bps": 4000,
"reps": 1,

Thank you for your continued help. I was able to create a new command and attempted to store a new signal, but received the following error:

HTTP/1.1 400 Bad Request
Content-Length: 72
Content-Type: application/json; charset=utf-8

{"_error_id":43,"_error_msg":"data does not match specified encoding"}

I tried with both a bps of 4000 as you suggested and 40000 as per the API docs this is the limit for Hex encoding.

For completeness, here is the command I entered:

curl -i -X PUT -H "BOND-Token: MYTOKEN" -H "Content-Type: application/json" \
-d '{"freq": 38,"modulation": "OOK","data": "000000630000009c00700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a0070002a002a002a007000700070002a002a002a004e","encoding": "hex","bps": 40000,"reps": 1}' \

I hate to continue bothering you, but am learning as quickly as I can. The error appears to indicate there is an error in the data field. Is there any way to get more details than that?

Thanks for being patient with me - it’s always a little extra time consuming to figure things out the first time but I do enjoy it, personally.

ah, thanks for catching the typo - my intention was to match the API docs.

Not of which I am aware. More plugging and chugging trying to find out what it wants, I suppose?

I have only ever used “cq” encoding when PUT’ing a new Signal, but I have seen “hex” on some of my raw-recorded devices. Those all have the hex characters in caps - not that it should make a difference, but it may?

curl -i -X PUT -H "BOND-Token: MYTOKEN" -H "Content-Type: application/json" \
-d '{"freq": 38,"modulation": "OOK","data": "000000630000009C00700070002A002A002A0070002A002A002A007000700070002A002A002A0070002A002A002A007000700070002A002A002A0070002A002A002A007000700070002A002A002A0070002A002A002A007000700070002A002A002A0070002A002A002A007000700070002A002A002A0070002A002A002A007000700070002A002A002A0070002A002A002A007000700070002A002A002A004E","encoding": "hex","bps": 40000,"reps": 1}' \

Below was one of my “cq” encoded PUT commands that worked for me (Windows command line format) - not that this would do anything for your device, but you could use it to make sure a known ‘good’ call doesn’t error out.
I also have some “hex” encoded Signals I can test myself PUT’ing on a new command tomorrow.

curl -H "BOND-Token: xxxxxxxxxxxxxxxx" http://nnn.nnn.nnn.nnn/v2/devices/DEVICEID/commands/COMMANDID/signal -X PUT -d "{\"freq\":433930,\"data\":\"1001011001011011011011001011001001011011011001011001001011001011001011001000000000000000000000000000000000\",\"encoding\":\"cq\",\"bps\":2494,\"reps\":12}"

You stumble across the solution: the data must be in ALL-CAPS!

I was able to upload the IR command, but still no dice. Doing some more reading, it appears these stupid shades need to receive an RF signal to “wake up” and only then will read IR commands.

Thank you for all your help on this. I’m hoping the BondHome developers will figure out how to allow integration of the RF signals from this remote.

Sorry to hear we’ve hit a dead end, @Juggler.

Since the hardware itself across all currently available Bridge devices doesn’t support the 2.4 GHz RF band, it isn’t something that can be added via future software enhancements to the current Bridge product. :face_with_diagonal_mouth: