Proflame 2 Fireplace Remote

Hello,

I just received my Bond Bridge yesterday and had no trouble at all connecting my 2 ceiling fans. The bridge found the appropriate remote immediately and it works flawlessly.

I also have a gas fireplace with a Proflame 2 remote (FCC ID: T99058402300) which is supported according to the Bond Supported Devices website, but I am not able to get it to work correctly. It will turn on the fireplace . . . occasionally, but will not turn it off. I was surprised when programming that it didn’t find the remote in the database since it is a supported remote, so any assistance would be greatly appreciated. This was one of the main reasons I purchased the Bond Bridge so it would be a huge disappointment if it didn’t work.

Please let me know if any additional information is needed to provide assistance.

I do not have any fireplaces with remotes.
However, I’ve seen a few recurring themes with them.
Often, removing the batteries out of the original remote helps, once you’ve got Bond set up (apparently original remotes sometimes send state packets on some recurring interval).

You can also record each button press without using the Bond’s remote database (I am a little unclear if that’s what you did already or not) if the remote matches from the database are not working.

Finally, this forum is great and extremely helpful, but don’t forget Bond has official Support options on their website to get more real-time assistance. Most of us are just enthusiasts, and the Bond staff that get a chance to wander in here from time to time are not always able to respond to each forum post in a timely fashion.

Thanks for the reply!

I did try programming without using the database and was able to get it to turn on. I also removed the batteries as well and unfortunately no luck!

I appreciate the feedback and will try to get in touch with someone under the support section as well.

Thanks again!

1 Like

Any luck with this? I have a client with a couple of these and I was hoping to be able to use Bond to integrate them.

I ended up contacting Bond Support and was able to get it work. Below is what support sent me and these instructions worked, with a few caveats:

Can you try the steps below?

Please turn the fireplace ON before programming

It is important that you or the remote is next to the Bond when programming

  • In the BOND application select the + (plus) sign.
  • Select Remote Control then choose your bond
  • Select Fireplace and set the location and device name and click Continue.
  • Select power OFF
  • Select Advanced Settings
  • Select Signal type and click Radio Frequency (RF)
  • Enter 315 into the frequency rectangle and select done. If there is existing data, please delete it first.
  • Turn OFF “Search Remote Database” and click save
  • Select “Start” and continue with the pairing process
  • When the system displays the test with just the button, test if it works. If so, click yes or this is my remote.
  • Click Done.

If it doesn’t record, please try steps again but this time repeatedly press and release the button.

I was able to get the remote to program using this and I did not have to remove the batteries from the remote to keep it working. I’m integrating mine with SmartThings and what I ended up doing was creating a virtual switch in SmartThings. I created an automation that turns the fireplace on when the virtual switch is switched on and then an automation that uses an Ecobee Sensor in the room to act as a “thermostat” for the fireplace. If the temperature of the sensor goes above the set point, the fireplace turns off, but the virtual switch stays on. When the temperature drops below a different set point, the fireplace turns back on.

I’m sure there are many different ways to do this, but by using the virtual switch my temperature automations that turn the fireplace on and off only worked when the virtual switch is on so that the fireplace wasn’t turning on and off all hours of the day. The other advantage of this method was that I could keep the batteries in the Proflame 2 Remote and use that instead if I wanted. That way, if I have guests over or someone who isn’t aware of the automation, the fireplace status and Bond didn’t get out of sync. When I first got the Bond working with the remote, I had the most problems when the Bond and the Proflame 2 Remote were out of sync. If I turned the fireplace on through the Bond app, but the Proflame 2 Remote was off, after a short period of time, the remote would turn off the fireplace. The opposite was true as well, if the Proflame 2 Remote was on, and I turned off the fireplace through the Bond app, after a short period of time, the remote would turn the fireplace back on. Since implementing this virtual switch, I have had no such issues.

Also, with Alexa, my voice commands turn off and on the virtual switch instead of the device Bond creates within Alexa. If the voice command turns the Bond create fireplace device on, I had the same issue I was describing above. Haven’t had a single issue it since changing the voice commands to turn on and off the virtual switch.

Hope this helps! Let me know if there are any questions.

1 Like

@eboline Thank you very much for the steps. We are looking to do something similar and I see that the remote will eventually sync up and turn on/off the fireplace. Could you clarify the below

“I created an automation that turns the fireplace on when the virtual switch is switched on and then an automation that uses an Ecobee Sensor in the room to act as a “thermostat” for the fireplace. If the temperature of the sensor goes above the set point, the fireplace turns off, but the virtual switch stays on. When the temperature drops below a different set point, the fireplace turns back on.”

So…
You Created virtual switch. When it turned on it sent the On command to the Bond.
An Ecobee Sensor monitors the temperature in the room.
If Temp goes above set Temp in the room, the fireplace turns off.

Wouldn’t that still be an issue if the proflame 2 remote control would be in the On State?

That’s an excellent point, and I think you are correct. I haven’t tested it, but my assumption is it would be a problem if the Proflame 2 remote was in the On State.

However, I use the virtual switch to because otherwise the automation would run whether I was in the room or not. I suppose I could write an automation that had a bunch of conditions and if I had any motion sensors (which I don’t at the moment), those could be used to say, “Hey, no one is in the room so don’t turn the fire place on and off.” The Ecobee sensors do act as “occupancy” sensors so I could use that as a condition so that it only operated during set times and if there was occupancy in the room, but the Ecobee sensors do take some time to switch from showing occupancy to no occupancy so this was a simple way to solve that.

I think there is a much more elegant way the automation could be written as to not require the virtual switch, I just haven’t spent much time coming up with a better solution yet. I’d love to hear how you ultimately implemented this for your customer.