Difficulty adding AMP blinds

Have several new AMP motors, which I have fully paired using the shade/awning->pair step. In all cases, I got the proper blind to jog and initiate the default pairing beeps.

However, once paired, some of the blinds still don’t operate. Some do, but some don’t (3/5 are working). I tried deleting the non-working ones, and repairing, and although the pairing completed they don’t operate.

I’m wondering if this is due to the number of Rf repetitions being sent – I found out when grouping two of the working shades for example – that oftentimes I will only get one of them to move.

It seems like the reps property is no longer located in the /v2/devices/deviceId/commands/commandId/signal endpoint when initiated with the pairing operation. Any tips or advice on what to modify to get these working?

Question: did you test the grouping of the amp shades on a single channel on the remote?

The remote works perfectly. There are also 3 grouped channels on the remote.

  • 0 (“all” channels)
  • 6 (groups channels 1 & 2)
  • 7 (groups channels 3, 4, 5)

I paired individual channels to Bond (1, 2, 3, 4, 5) and was using the built-in Bond groups, but nevertheless:

  1. Bond cannot control all of the channels (despite deleting/re-adding)
  2. For the channels that do work, when combining them to a group within Bond, they will not all fire necessarily. I think maybe there is some Rf interference or not enough spacing between the Rf signals.

I think you should only load the group channels into Bond. I have 5 blinds with 2 groups
defined on the remote and then use only loading the group channels and everything works exactly as if it runs from the remote setting to respective channel. This reduces the RF traffic that the Bond hub needs to process and makes the shades operate simultaneously.

Thanks @Joachim47 – I tried that also.

  1. It had the same pairing issue as I described earlier. As in, I could hear all the motors pairing, but it only operates one of them.

  2. This makes it easy to lose state if you want individual control over the blinds. If you add the blind “group” and then the individual ones also, there is no synchronization between the “group” state and the individual state. If you use Bond’s built in grouping, then state is preserved.

@merck are you aware of any issues with AMP blinds or any commands I can try to execute on the API side to figure out why this is a problem? I can also go with standard programming of the remote control vs. the blind pairing, if AMP blinds support that, but not sure why some of the blinds won’t operate after successful pairing. I think repeating the Rf commands and/or changing the spacing between the repetitions could help potentially.

I am gathering that Bond gets confused. The case of channel 6 you described seems to chain together channel 5 (already defined as group for blinds 1&2) with channel 3 and 4 related blinds.
Have you confidence that the grouping on the remote level is actually working outside Bond?

Sorry for the confusion, I had a typo in the channel write up, fixed now. :slight_smile:

Yes, every button on the remote works perfectly.

Do I understand the issue correctly by stating
the grouping at the remote level works as expected
the translation into Bond fails.

Yes, and even more so:

  • Remote control works perfectly for individual or grouped controls

  • Pairing individual (or grouped) channels into Bond works partially. 3 blinds succeeded, 2 failed (even though pairing step completes successfully, blinds are not operable for those).

  • Using groups in Bond (for the blinds that are operable) seems to only trigger one of the blinds in the group to move. Triggering the group again will sometimes get the other blind to move also. I think this is due to Rf interference or insufficient repetitions, perhaps.

This is very surprising.
Since a remote based grouping should appear for Bond as 1 device and resulting only in 1 set of control codes which is completely equivalent to an individual blind being paired with Bond. Since the same code will trigger all blinds assigned to this code everything should operate in the same group in concert as they do on the respective remote channel. So I can’t see an issue with RF signal overload on the Bond bridge.

Glad we’re on the same page :slight_smile:

Controlling them one at a time should work fine, which it does in 3/5 cases. That’s why I suspect two issues – 1) a pairing issue of some kind for 2/5 of the blinds; and 2) a Rf overload for the Bond groups issue. The strange thing is that the pairing process completes successfully along with the “success” beeps from the motor, so I think Bond may be sending out the wrong Rf commands for those.

Glad I finally caught up with you.
The 1st thing to try is to remove all blinds from the Bond and eliminate bond grouping for now and instead use grouping at the remote level with the 3 blinds you found working with Bond individually. Use the group channel to pair with Bond. This should be without any problem if the pairing succeeds. There shouldn’t be any failure within the group operated by Bond.

try is to remove all blinds from the Bond

Why would this step matter? I want individual control of the blinds.

instead use grouping at the remote level with the 3 blinds you found working with Bond individually. Use the group channel to pair with Bond

There isn’t such a channel on the remote. The blinds which are pairing successfully and working independently are channel 1, 2, and 5. Channels 1 & 2 belong to the first blind group, and 3, 4, 5 belong to the second.

I tried pairing channel 7 (the second blind group) and it only controlled the same channel – 5 – after pairing.

I understand your point, I can probably pair channel 6 and have it work, but that doesn’t fix my problem with the other set of blinds and it ends up being highly pointless if Bond can’t operate all of the blinds properly.

My suggestion aims for unlayering the problem you have.
For your intension to have individual control, I got the impression that this part was working while the main focus was to get the grouping function to work either within or outside Bond. In case that premise doesn’t hold, there is a more basic issue to what degree the AMP motors are same generation & firmware which could pose a different challenge for Bond to handle.
The 1st proving point will be that you can setup the grouping operation successfully outside Bond. Once that is established you have to deal with the Bond initiating by single command one group operation at a time by pairing remote based group channel with the Bond. There is no conceivable reason why under these conditions not all blinds in the prior defined group would not respond to a Bond command in same way unless you have a signal communication issue caused by distance or interference.

I appreciate your effort to help troubleshoot.

Agreed, this is what I think too. Especially because the unit is less than 15 feet from all the blinds and I have even tried repositioning the Bond device.

So in case of 2 blinds not working in Bond after pairing under any conditions indicates a compatibility issue with Bond hence they need a different setup.
The grouping issue has to be seen as a different problem which can be solved outside of Bond within Alexa or equivalent automation process you are using for integration.


This needs to be solved in Bond as well. Bond is issuing the Rf commands, and as such needs to moderate the time between signals. I understand it can be possible to create any number of hacky workarounds with delays and such, but this is not a sustainable solution for a number of reasons.

There is still no clear understanding what causes the mishandling of RF signals at the Bond hub level if that is really the problem. I could also see a scenario that the signal are not accurately represented by bond so that the wave form is not matching the AMP requirement exactly and hence the motor doesn’t recognized the instructions. A collision of signals at the bond level is rather strange since subsequent instructions should be controlled by a scheduler build into the Bond firmware. On the receiving side subsequent instructions should go to different motors not the same motor so I can’t see an overload at that end either.

We just released a new beta for 2nd-generation Bridges and Bond Bridge Pro, v3.3.15, which should fix a communication issue with recent motors. We would love to know if this fixes the problems you are observing with recent AMP motors. @dxdc

thanks for the reply @merck! updated and no dice. can I provide any other details helpful for troubleshooting? Do I need to remove the existing devices and re-add? I didn’t do that yet.

I only have 2 more weeks on the return window, and trying to learn the remotes manually didn’t work either. The pairing works fine, but I suspect some issue with the algorithm perhaps which isn’t sending out the correct signal.