Bond Bridge will not complete setup

Hello Bond Brigade,

I have a Bond Bridge that was successfully setup at a previous location. I moved it to my current residence and did a factory reset (white ring) to start with a clean slate. Now it simply will not complete the setup on the Android app. I tried doing the factory reset several more times, to no avail. Bond bridge flashes green, the app finds and recognizes the bridge, and successfully connects, but will not go any further than the ‘Add new device’ screen, with the Bond bridge correctly identified, but the circle in the middle of the page just keeps on spinning and then every 60 seconds or so I get an error message, “There was a problem communicating with the device, please, try again later”. The bridge never stops flashing green, but my phone stays connected to the Bond bridge wifi, while my phone has a good connection to my 5G network. I’m stumped, it worked flawlessly at my old location before I did the first factory reset. Any suggestions? Thanks!

1 Like

I’m curious if your phone is losing connection with the Bridge, or if the Bridge is losing connection with the WiFi.

Some of us in the community have noticed the WiFi channels your router is using are often involved in unreliable connections or setup issues.

But since you mention the phone is a 5 GHz connection, and Bridges only use 2.4 GHz, I’ve seen some Android devices have trouble with various smart home devices bridging across the mixed mode networks (even if they’re on the same WiFi network & the channels for 2.4 and 5 GHz are named the same SSID) - never a Bond Bridge in my case, but it’s worth considering.

In the Bond app, if you are NOT in a device setup screen, scroll to the Bridge, tap it, then tap Advanced to expand additional information. Then tap the Network Info section and see if if says:
Connection Type - WiFi
Status - Connected to Cloud
IP Address - x.x.x.x

If you see all that, you can try typing in the IP address into a browser on the phone or a computer (on the same network), and see if you get a screen asking for either the Bond 4-character setup PIN or the 16-character Account code.

Don’t forget there are options for official support in the app (under Help) or via email ( which may lead to faster answers if we in the community can’t point you in the correct direction.

1 Like


Thanks for the response. :+1:

Pretty sure that the phone (Samsung S21) is losing connection to the Bridge, as we never get far enough along in the setup process to even choose a home wifi network. And thus the Bond bridge never gets established in the Bond app. We are perpetually stuck at the Setup/flashing green light phase.

And as I mentioned before, this Bond worked perfectly before, with the SAME router and also the same service provider. Strange.

1 Like

The IP address browser method will let you assign to your Bond account and do minimal checking to see if it is connected to your WiFi.
If not connected to your home WiFi, you should be able to find a “Bond” open WiFi signal from your phone or computer when the Bridge is in setup mode, and you can try to connect directly to that SSID to investigate / attempt setup.

1 Like

If the router is in AUTO mode for WiFi channels, the thread I mentioned shows that it can be the source of problems and the solution as well, even if it’s the same router and service provider (and even in the same location, or in a new location).

Thanks again for all the replies.

Problem fixed…worked with tech support, they had me try the setup using a different Android device, and that was successful. Upon connection to the new phone it immediately loaded a firmware update, then rebooted, and then completed the setup. It looks like perhaps it was a firmware problem, but what if I didn’t have another device (in this case, my wife’s S21)? In any case we are back up and running and I have one less headache to deal with. :laughing:


Sorry for taking so long to see this thread.
Glad you got it working!

We have been facing some issues with connectivity in Android devices depending on the OS version… That may be one of the differences between your device and your wife’s?

We worked on a fix for it and it was released July 6. Hope it doesn’t affect you in a future setup anymore :pray:

Thank you!


I had the same EXACT issue! I even have the same Android phone - Samsung S21 Plus. For me, what fixed it was updating the app! My phone usually automatically updates the apps (I thought), and if I try to launch an app that I haven’tused in a long time that was put into “deep sleep” or whatever they call it, it usually says an update is available and you have to update it before you can use it. Not the case with this app. I went to the Google Play store and saw that the “update” option was available. I updated the app, launched it, and it found and conne ted to my Bond Brodge immediately with no issues! Hope this helps someone else!

1 Like