Firmware 4.4.4 beta

Whatever you do, do NOT download this firmware. I did that earlier today and my Bond Bridge Pro completely stopped working. It kept turning off and on again no matter what I did. Finally after many attempts I was able to put on the “Stable” firmware but now of course the Homekit Integration is spotty. Finally with 4.4.3 everything seemed to be perfect. Should NOT have gotten greedy and installed 4.4.4 beta!

After having the issue above I did a factory reset on the Bond Bridge Pro and installed the stable firmware. No more issues with the unit constantly going offline and online every 30 seconds. Yesterday I installed firmware 4.4.4-beta to see if my issue was a fluke. So far … working fine without issues! Fingers crossed it keeps working.

Ok, glad it’s working better, but we are also seeing some issues with HomeKit stability on v4.4.4 and have not gotten to the bottom of it yet… will definitely update here when we have some clear signal that we’ve improved it.

1 Like

NOTE: No relevent change in v4.4.6. Changes related to other integrations onyl.

Should I install it or hold off?

There is no need to update.

Should I install 4.5.4 beta?

Yes. It should now support Troy + HomeKit better, though honestly there are still some issues in the HomeKit implementation that we have yet to get to the bottom of.

I installed beta 4.5.6. Seems to be working fairly well. Occasional (rare) glitches and slowness but overall better. Oddly, I checked firmware upgrades and it’s showing current as 4.5.6 and latest upgrade as and offering me to “upgrade” to what seems like an earlier version.

1 Like

We ended up releasing to stable a version (v4.4.7.1) that is behind the last beta (v4.5.x), because of some stability issues. However, for your case, you should stay on the v4.5.x. — We are trying to balance different use-cases and get them to all play on the same firmware. It’s getting tricky, but we are not giving up yet… just still will take more testing to get the v4.5.x branch out to everyone.

Ok. Thanks for letting me know. Also let me know if you guys make any progress on the RC300 fireplace remote.


About an hour ago all my shades suddenly opened half way and now my Bond Bridge keeps turning on and off again. I’ve tried everything!

Hey David, we could support more via customer service, but I can say that we see a request from Alexa for setting all shades to 50% around the time you indicated.

How do I get customer service? Nobody on the app knows anything about these issues. Currently every time I try to pair my Bond Bridge with HomeKit the Bond shuts off and restarts and gives an error message. How e

Nobody on the App Chat is answering. How do I resolve this? Every time I try to connect Bond Bridge Pro to Homekit the Bond turns off and restarts and fails to integrate to Homekit.

I see you updated the firmware on the Bridge again? Was there a reason to move off the v4.5.6 firmware that was working well? (You can go back by using the Beta Firmware Channel in the app.)

To clarify, the specific combination of TRO.Y + HomeKit is something that is not working in the stable firmware (v4.4.7.1). It’s only working in the beta (v4.5.6-beta).

This morning around 7AM PST my Bond Bridge stopped working. It kept rebooting itself and would not control any of the shades or devices connected. Kept shutting off, turning orange, then blue, then repeat. Furthermore, it crashed my Tro.y system, even things not integrated to Bond. ONLY way to get this cycle to stop was to disable HomeKit Integration on the Bond app. Then the Tro.y would work perfectly. I put on the stable Firmware because I thought that would help. Problem is that now I can’t enable the HomeKit Integration anymore. The steps I use are:

  1. Enable Homekit integration on Bond app.
  2. Go to HOMEkit app and add device, enter the HomeKit Code.
  3. HomeKit shows “Connecting,” then “Adding to Home.” A few seconds into the “Adding to Home” part the light on the Bond shuts off, then turns orange, then blue, and the HomeKit errors out stating unable to add device.
  4. I have tried this multiple times, reset the phone, reset the Bond, reset Internet, etc……

If someone wants to call me to figure this out I am available.

I’ll see if we can get this reproduced in our lab tomorrow. We did recently get some more SI hardware to make that happen.

The system crashed with 4.5.6 and Tro.y/Homekit. So I ultimately had to do a factory reset of the Bond Bridge Pro and setup everything again from scratch. Took several hours so hopefully this doesn’t happen too often.