Unable to Upgrade from v2.5.1-beta Firmware (Snowbird unit)

I’m having an impossible time transitioning to the new app.

The new app forces me to update firmware - it always failed. So I did the wifi reset. I can’t get either app to process the WiFi setup now. Can’t get updated firmware (I was on the original beta group with old app for local API access - using firmware ver 2.5.1-44)

Now I can’t get wifi setup and neither app works at all since it’s not online.

How do I update? My bond serial is bd version.

@larsentim - have you tried a “green reset” of your BD device, connecting (within less than 10 minutes) via the official (non-Beta) Bond Home app from the iOS App Store or Google Play Store yet?

I did do a WiFi reset (green). I have not tried it with the official app version tho. I’ll try that now.

Actually I just realized I was using the official bond home app. I’m trying the beta now

Ok I tried. I did a green reset, loaded the beta app (because I tried the standard v2 app many times already) and I get the same result. Says communication issue - error 107. sometimes its error 101 but thats usually when I try to update firmware and its blinking green…

No matter what variation I try, I can’t get the old or new app to update firmware…

Hey Tim, it sounds like the issue here has to do with bugs in that early beta firmware. Here’s how you can move forward:

Do a “rescue reset”, which will bring the firmware on your unit back to the factory default:

  1. Remote USB cable.
  2. Hold down the reset button with a pin.
  3. Plug in the USB cable whilst continuing to hold the reset button.
  4. Wait 10 seconds.
  5. Release the pin.

Your unit should now be on v1.109.5 firmware (factory default for the BD… series).

Now you can set up in the V2 Bond Home app.

1 Like

I did those steps. However in the new app (and old) it shows the old device/bridge and remote. No new ones. The led is blue like it should be. And the app said it wasn’t sure if the firmware update completed. To give it two minutes and if it shows up it works.

It did not. Unsure what to do now.

Actually it looks like it worked. I had to quit and reload the app but it shows it as online now!