BD Firmware v2.14.9.2 (Android 2.27.1) Fails to Setup

By BD bond bridge was not connecting to my Wifi today (perhaps channel related in hindsight), so I did a Wifi reset, to no avail. I then did a full reset (held reset button for ~30 seconds). After connecting to the Bond’s wifi network, I receive a prompt to update the Firmware to “-” (i.e. nothing). If I hit the “update” button, I get a “communication issue (error -1)”. See attached screenshots.

There does not appear to be any way around the prompted firmware update.

Anyone have any thoughts on a path forward?

Just tried the rescue reset outlined here.

I still get the same error. It must be an issue with the Android App, as it does not provide a valid firmware version for updating to. I will try to move over to the Beta Android App and try again.

@The_Barnacle: what version of the Android app are you on? And which version of the Android OS?
(@endy)

Hello,

The Android App version is listed in the Post Title (v. 2.27.1), running on Android OS 8.0.

I worked around this issue by uninstalling the current Play Store version, and downloading the latest version of the Android app through the Beta program (v 2.28.0).

Not sure what the issue is / was. Will stay on Beta App for a bit, as it seems stable.