Select Blinds - Classic Roman Shades [Bofu BF-305]

v2.20.11-beta firmware is available now. Please let us know how it works for you. You will need to tap on the “BOFU” or “BF-305” options when you have a choice of several detected protocols.

Can you please advise the setup steps. I’m not getting an option under Shades once I go through the remote pairing step.

| merck Olibra
July 8 |

  • | - |

v2.20.11-beta firmware is available now. Please let us know how it works for you. You will need to tap on the “BOFU” or “BF-305” options when you have a choice of several detected protocols.

First, upgrade Bond Bridge to v2.20.11 or higher firmware.

Now add the shade:

  • (+) button
  • Remote Control
  • select your Bridge
  • Shades
  • Other
  • Set location & name > Continue
  • choose a command > pick any one
  • now record your BF-305 remote
  • You will get a few options, select the “BF-305” one (See image below)
  • confirm that it works at the test screen
  • Success! You now have the new device added.

@merck , Thanks for all the great work. It is almost there but needs a bit more. Here are my results.

BY-305 :

  • Channel #1 : I have (2) older roller shades on this channel. Adding this channel went as planned using the new remote in the database Both shades works well and synchronized.
  • Channel #5 : The same procedure was followed but for some reasons Channel #1 was being controlled again. Switched to manual set-up and with a few trial and errors got it to work.
  • Channel #2 : Same thing as previous.
  • Channel #4 : Same as previous. I have (2) shades on this channel. Its hit and miss for synchronization. Sometime one roller will react sometime both.
  • Channel #3 : I gave-up on this one as it just would not work.

I moved on to my last shade working on Channel #1 of a BF-305. Used the automated set-up and surprise surprise it is controlling Channel #3 of the BY-305 that I had given-up.

So I’m not too sure why it is not fully working. If you look at the data from the server end, I have named the device as ex.: BY-305/1.

Let me know if you need more info.

Confirmed. Working on all three blinds.

Any guidance on double clicking STOP for the favorite setting? That is the only function not working on BF-305.

1 Like

Yes! We were just working with @mv1707 and he reported similar issue. — We’ve got a fix available now under the version number v2.20.12-beta. (The problem was, in an attempt to make the control as reliable as possible, we were sending 28 packets instead of the 7 that the factory remote sends. However, sadly there’s no different code in this protocol for Halt (stop) versus Preset (favorite position), and, the shades interpret a long string of the same code as a second button press. So, our solution is just to reduce the packet reps down to 14, which seems to be below the threshold for being detected as a second press of the button, but still more reliable than 7 presses.)

Also, we learned that this remote is often detected at the wrong frequency, which can cause issues. You may want to set the frequency manually to 433.92 MHz by using the “Advanced” option during device set up.

Just to follow up in public here: the problem here seems to be a combination of the Bridge detecting the wrong frequency, recording noise, and the backend caching the previous result. — We can clean up at least the backend caching issue as soon as we find the root cause. — Workaround is, as we discussed, to set frequency to 433.92 MHz in Advanced option during device creation.

Okay, so the new beta has been working reliably for me, too, so thanks a bunch!

I do have a small issue, though ---- I previously had programmed the “open” button on the Bond Hub to the “stop” button on the actual BF-305 remote. This mapping button approach allowed me to open the shade to the preset position, and further, with Amazon Alexa integration to say, “Alexa, open the shades” and the shade would open to the preset position. Of course, opening was unreliable and sometimes took several tries to make it happen.

Since I can no longer change the button mapping, and Alexa doesn’t recognize the “stop” command, I can’t figure out how to open the shade to the preset position using Alexa.

Am I missing something? Is there any way to change the button mapping so that the “open” button opens the shade to the preset position?

Thanks again for all of the great work done with this remote.

Rob

OK, it’s an issue on our side. We implemented this template with just the Open and Hold features, neglecting the Preset feature.

We just pushed out another beta (v2.20.14-beta) with the Preset feature exposed. But in order to make it take effect, you will need to either re-program the device.

TECH NOTE: Instead of reprogramming the remote, you could use a command line to send a PUT request the v2/devices/{}/reload endpoint (curl -H "Bond-Token: xxxxx" http://bondip/v2/devices/xxxxx/reload -X PUT -d '{}' or similar). I know that’s annoying but it’s an artifact of our system where you can delete commands from template devices and have the deletion persist. The side effect is that new commands we add in a fw update are seen by the bond as previously deleted, so thus the need for reload. It’s something we may fix when we refactor the templating system.

Please let us know how this works. If all looks good, we will get this out to everyone through the stable channel on Monday. (We don’t release to all users on Fridays :slight_smile: ).

1 Like

Okay, Merck, I’ve updated to the latest beta and reprogrammed the remote. All is good with the app----the preset feature works fine when pressing the “stop” button on the app.

My only problem is the integration with Alexa. When I say, “Alexa, stop the shades”, the response is “Shades doesn’t support that”. Alexa works fine with opening and closing, but I can’t seem to figure out the command that will work to raise the shade to the preset setting. As I mentioned before, when I previously had to manually program each button in the app, I just programmed the “open” button on the app using the “stop” button on the remote, which made the “Alexis, Open the Shades” command open the shade to the preset position, at least when the command worked, which often required multiple tries. Now that the remote is in the database, I can’t “remap” the buttons to the app.

Is this something you have to change for Alexis integration, or is there some other way to deal with this?

Thanks yet again for the excellent work!

Rob

the command that will work to raise the shade to the preset setting

Sorry, I should have given some examples. You can say:

Set [device name] to favorite position.
Set [device name] to preset mode.

It also may be available through the Alexa app as “Preset”.

“Alexa, stop the shades”

Sadly that is not a supported command by Alexa smart home skill, AFAIK. We can only add different “modes” controlled by utterances of the form Alexa, set DEVICE to MODE_NAME (mode), where the word “mode” is optional.

Okay, Merck, that works beautifully. I’m very happy to get this all working reliably, and you and the team have greatly helped with the WAF (wife acceptance factor), which was difficult to achieve when it took several tries to get the shades to move.

Thanks again!

Rob

2 Likes

Hi,

Installed the .14-beta this AM and re-learned (8) roller shades on (6) Channels spread on (2) remotes. Tried some of the scheduling with Open, Close and Preset. All seems to work like a charm.

This is not a show stopper but since you are looking for beta feedback, I noticed that while you are at the “Test screen”, the “Open” and “Tilt open” button did not seem to produce any result when briefly tested. However, once the remote saved, these features works. I’ll retry, paying more attention later on.

I really must mention the exceptional efforts and support that @merck and @guy have thrown in to make this work.

Many thanks.

Michel.

2 Likes

After further testing, this problem is only encountered on the (2) older shades I have, built in 2015. The other (6), built in 2021, are working as expected when pressing Open or Tilt open on the testing screen. Again! once saved, all is working good so I don’t think it worth putting any effort on this.

Michel.

I’ve used this thread to add my blinds.com shades and couldn’t be happier. I remember finding this thread months ago and nothing seemed on the horizon but I really appreciate @merck, the other users and the work that went into getting this going.

I know this isn’t really the focus of this thread but I utilize Google Home and haven’t been able to find a command to set my blinds to the one preset position I have. On the Bond app, I don’t have any options for this either…

Other
Close Next | Open Next

Shades
Open | Close | Stop

The command, ‘Hey Google, Open/Close the shade’ works as expected but the command ‘Hey Google, stop the shade’ does not work it just proceeds to close the shade instead of stopping the motion.

Oddly enough, I just noticed that the command ‘Hey Google, Open/Close Next the shade’ does work appropriately but obviously this is more cumbersome than just stating a desired preset.

I use the Amazon Echo (Alexa) devices for home automation, so I’m not sure this works with Google Home, but I use the command “Alexa, shades to favorite” and they raise to the preset position. “Alexa, close the shades” closes them, and “Alexa, open the shades” raises them fully open.

During previous testing, I found that I could use several different, but similar commands to open the shades to the preset level by using the words “preset” and “favorite” in different shade commands. So, my suggestion is to experiment with the command wording to see what will work for Google Home.

Good luck!

1 Like

I just recently bought a Bond and have went through this thread and I really appreciate everyone’s testing and work on this. However ( :smiling_face_with_tear: ), I purchased my select blinds with the 16 channel remote as I have 8 blinds and unfortunately no option to manuallt choose a remote that I can tell and ones that come up are a dooya and allen & roth and those aren’t reliable. Any ideas?

Thge remote looks like this , but I see it probably is the same as the BF-305 just it supports 16 channels. I’d like to be able to just select that remote. Manual programming isn’t reliable either.

Any help from my previous post?

Hey @stcbus - I am sorry that I don’t have any blinds and cannot really help you troubleshoot that much, more than the steps you’ve already completed (auto matching doesn’t seem to be correct, and manually recording doesn’t seem reliable either). If you’ve tried auto matching several times from various distances of remote to Bond Bridge, and are still only getting matched with remote choices that are not accurate, it might be time to get some more official help.

Have you tried reaching out to Bond support chat in the Bond app, or emailing customerservice@olibra.io?
The Bond staff do get a chance to drop by the forums from time to time, but those official support channels are a good option if you need timely help.

I have several (12) Simplicity shades that are programmed to either BF-305 or BY-305 remotes. The BF-305 remote linked up with Bond very easily but I can’t get it to recognize the BY-305. Is there anyway to choose the template for BF-305?