Mobile Apps v2.12.0 — Somfy shades and better bridge support

We added this functionality. For Alexa, it’s “Set to favorite position” or “Set to preset mode”. For Google Home, it’s just “Set to favorite position”.

The Bond’s “virtual remote” is paired with whatever Somfy RTS receivers are currently in pairing mode, so I’d guess what happened here is that you pressed the pair button on your remote when it was addressing the whole group.

If you want individual control, I suggest you hold the pair button on the physical remote when it’s addressing the shade you want to control. Check that only that shade responds, now create and pair a new Bond remote with the shades. It should only be paired with the one target shade!

1 Like

Jacob is there a limit to how many RTS groups / shades you have in Bond Bridge?

There’s no real definite limit, probably on the order of hundreds.

4 posts were split to a new topic: Unable to Upgrade from v2.5.1-beta Firmware (Snowbird unit)

Thanks Jacob. I have individual shade control working as suggested. I cannot however find a command syntax that Google Assistant recognises for favourite position. “Hey Google set [device name] to favourite position” and “Hey Google [Device name] Set to favourite position” both fail - not recognised or I don’t know how to help with that etc.

Okay, thanks for the report, we’ll look into it here. @joaoricardo

Hello - new here. I just tried "set [device name] to favourite position” through Google Assistant. For my 2 blinds:

  • intially worked fine with both of them
  • I opened the second blind a little further, and tried again, expecting it to close down to favourite position. Google responded “OK setting…” etc but nothing happened. I then tried that again, and it worked

So it seems to work ‘ok’, but is a little janky maybe.

Curiously, now (since this week’s app updates I think), when I open/ close the second blind “bedroom”, it says “opening/ closing 2 things”. I just checked the app and only one blind is listed in the bedroom. I have a ceiling fan and the bridge itself registered in that room

There are some issues with stability in controlling multiple shades in the publicly-released versions of the Bond firmware. There’s a fix already released to beta which I hope to get public next week.

Can you check how the Google Home app groups them up? Google handles all the mapping between voice command and device, so this might give you some insight into what’s going on. Let me know if everything looks as expected there and we’ll dig deeper.

Hi jacob, thanks for your response.

You’re right that the problem lies with Google home. I have a third virtual blind set up in Bond “all binds” which controls my two real ones simultaneously. In the Bond app, that’s not assigned to any room, but in Google home it’s in the bedroom along with the bedroom blind.

So when I asked Google to open the bedroom blind, it was reporting it twice. I moved "all blinds’ into a different room and now it’s fine.

A couple of other things:

My two blinds have, in different weeks, each lost their connection to the bond, and I’ve had to re-program them. I assumed that maybe they were getting out of sync with Somfy’s rolling code, but is this maybe due to the 2 blind issue you reference?

Last night, my ceiling fan turned itself off in the middle of the night. This hasn’t happened before. It does have an auto-shutoff feature, but that isn’t programmed into the Bond (the app couldn’t successfully auto-program itself, so I had to configure each key manually) and I didn’t go anywhere near the actual fan remote. Is there any way to see logging so I can understand what happened?

Thank you!

This is exactly what I expect from the bug in firmware v2.7.15, it should be fixed for versions >v2.7.19. the current beta version is v2.8.1, and I’m aiming to release this to the public apps on Monday or Tuesday if testing goes well. If you want, you could get yourself a beta app that upgrades your Bond to beta firmware here.

What’s the FCC ID of this remote? I don’t see any transmissions coming from your Bond around that time.

I’m surprised/ shocked/ impressed that you managed to isolate my individual Bond from my profile on here… linked email address, I guess? Could you perhaps look then to see what the last few fan-related transmissions were on Friday 13 then? It might not be that it sent an off command in the middle of the night, so much as a “switch off in 8 hours” command earlier in the evening.

I actually haven’t been able to figure out the FCC ID; the numbers printed on the back don’t correspond to one, and it isn’t listed on the product page either (

In fact your support team tell me that it operates in an unsupported frequency range (50-60Hz), but here we are - it’s worked perfectly besides this mystery switch off (which I accept could have been a fat finger on the remote)

I have a problem which might (?) be related to this topic.
I have 4 Somfy shades (same room) on Bond. Lets call them 1, 2, 3, & 4.
If my Bond loses power for any reason, 2, 3, and 4 cannot be controlled by the app any more. The Bond flashes when I touch the up or down button but the shades do not respond. 1 works fine.
I need to delete and re-pair the affected shades. Then all is OK until the next power interrupt.
This has been consistent - same results every time.

This is exactly the buggy behavior I expect, it is patched in the version I’ll release tomorrow.

I just deployed v2.8.1 firmware to the Play/App store mobile apps, please try it out: just delete the old shades and create new ones. They should no longer stop functioning after reboot. Please let me know if you experience further issues! @Mahhhky @pjmcnally

thanks @jacob

I updated the firmware, removed the blinds and re-paired them. Re-synched with Google Home and so far so good, will report back if I experience any issues.

One oddity when removing the blinds: for my bedroom blind I just had ‘remove device’, but for my living room blind I also had ‘unpair’. When I tried to remove the device, I was prompted to unpair first, which meant jogging the blind etc.

Now that I have re-paired both blinds, both of them have the ‘unpair’ feature. Just curious as to why this is even necessary?

The “unpair” is necessary because it is possible for a shade receiver to become “saturated”, and not pair with any more remotes until one is unpaired. This typically occurs at 12 pairings.

The “unpair” disappeared on your remote for the same reason that it lost its ability to control your shades: some of the remote’s stored properties were lost and the shade wouldn’t have been able to unpair.

I am in the process of getting some Somfy blinds installed and have two questions. I have been able to successfully pair my blind to the app but have been unable to use the app to get it to return to the favorite permissiom however, the button does work to stop it when going up or down. On the remote, I know you just hold it but that doesn’t seem to work in from the app. Am I missing something?

All that being said, is there any reason to have the Somfy MyLink and Bond? I am trying to figure out if I tell them to take the MyLink back. I ultimately want SmartThings control which I understand is coming but I am willing to wait rather than have yet another interface box.


The expected behavior is: tap the “my” button when moving makes the motor stop, tap the “my” button when not moving, the motor moves to the preset position, no holding required. Is this not working correctly for you? If not, please PM me an email or Bond serial and I’ll look into what’s happening behind the scenes.

FYI SmartThings control is available for shades now, but just as a simple switch.

Quick related question:
For the Bond Home app on Android, are we using the crashlytics version or the Playstore beta version?