K9L1001 remote for Realfyre G31 variable flame burner

Over the past few days I’ve tried to add this remote to my Bond, but am running into problems.

  1. Starting from scratch, the bridge finds two K9L1001 remotes in the database, one with (ON, OFF) and one with (ON, HI, LOW, OFF). I have a four button remote with (ON, HI, LOW, OFF), so I selected the second one, but end up with only three buttons on the Bond remote (OFF, LOW, HI). What happened to ON? The OFF button works, but I don’t think either LOW or HI work. And there’s no way of turning the fireplace on with the Bond!

  2. If I choose the first one, I end up with two buttons – an ON and an OFF – and I can turn the fireplace off, but the ON button doesn’t work.

  3. I then tried to train the four buttons individually, ending up with a four button remote of which the OFF, HI, and LOW buttons work, but I only got the ON button to work once (I think by clicking it repeatedly).

Are there any other G31 users with a K9L1001 remote that have had more success?

I am having the exact same issue. Please let me know if you find anything. This is a popular fireplace kit.

I fixed it using the information found here:

I defined only two commands in Bond for the K9L101: On and Off
and then used the video to patch both commands changing the reps from 1 to 10.

hope this helps

1 Like