iOS Widget Stopped Working

I have been using the iOS Widget for a while now with no issues but in the last few days it has stopped working on both my iPhone and iPad. Any button press brings up the moving blue line for that room above the buttons but then the line shows solid red and nothing happens. Everything works correctly in the Bond app.

I’ve tried disabling and re-enabling the widget but it still does not work. I was going to try reinstalling the Bond app but I thought I would report the issue first.

Hey @markg61326

Sorry for the late reply! My name is Endy and I’m one of the developers of the iOS Widget.
Can you confirm it is still happening? I tried to reproduce it on my end, but I couldn’t.

Thank you for reporting the issue.

Hi Endy,

The issue has resolved after rebooting the Bond. It appears the widget does not operate using the same method as the buttons in the app and needs to communicate with Bond servers? I had no problem operating my lights and fans in the Bond Home app but the widget stopped working and I was seeing the Bond Config Wi-Fi each time I went to the Wi-Fi settings on my phone. I read on the forum that Bond Config should only show when the Bond is unable to communicate to the Bond servers. So I rebooted the Bond and the widget started working again and also my Smartthings integrations, which kept showing offline, started working.


1 Like

Hi Mark,

So good to read that!
Yes, you’re right, the Widgets, Siri Shortcuts and other integrations run on our servers, while the app can communicate with the Bond in the local network.
If you tried the app on a mobile network or a different network (when at the office or other places) the app would fail too.

Feel free to create a new topic or contact me directly if you have any future issues.

Thank you,