IncreaseSpeed Not Working

curl -H “BOND-Token: a67ff25ca797820d” -i -X PUT -d “{“argument”: 1}”
HTTP/1.1 204 No Content
Content-Length: 0

i x’d out some of my personal stuff but that’s the error i’m getting, what am I doing wrong?

“204 No Content” is the expected “success” status. Do you see your Bond Bridge transmit something? (i.e. do the lights blink?) Or, if you’re already at the max speed, the expectation is that it won’t do anything.

speed is currently set to 1 (of 3). When I run the command, i don’t see the bond blink or anything.

Okay, I’m pretty sure this is an issue that’s fixed in the most recent beta firmware. If you want to try it out now, you could get signed up tor beta here: Bond Public Beta Link.

I’ll also be releasing this publicly in a week or two, if you’d rather wait.

so the beta firmware definitely fixed this. i can’t for the life of me figure out why my webcore integration won’t work. i think it has to do with the argument parameter, is there an example that shows how to build out webcore for an action that uses an argument?

Here’s an example I’ve come across before:

You’ll just need to add the argument along with the token. I assume it’d look like a const String with value {'\{"_token": "xyz", "argument": 1\}'}, though I have to admit I don’t fully understand this syntax.

that fixed it.

‘{"_token": “a67ff25ca797xxxx”, “argument”: 1}’

so I set up bond to integrate with my fan switches and a virtual switch, it’s a bit complicated but the end result is perfect. When the fan is off double tapping my switch turns it on and sets the speed to 1. While the fan is on, double tap up increases the speed by 1. Double tap down shuts it off and single tap up and down controls the lights for the fan.

Thank you so much!


I have the same problem. Can you ping this thread when fix is rolled out please?