Help with altering reps

I recently added a second Bond hub to improve coverage in my house. The old one could not get to two fans at opposite ends of the house no matter where I put it.

I placed the second hub closer to a group of rollerhouse blinds that I have installed on the old hub. The old hub is running v2.29.7-beta. I changed the reps for the commands to 5 on this version and have never upgraded as it worked almost all of the time.

On the new hub I am running the latest version of the firmware - v3.8.4. I added the blinds. Performance was about 1 in 10 times. So I went through the process of changing the reps on this hub and either I did something wrong or the process is different now as I broke the commands. I get the error message "There was a problem communicating with the device. Please, try again later.

Here is the command I am sending:

curl -H “BOND-Token: b18cacf8b742ca7d” -i -X PATCH -d “{"reps": 5}”

And I get back:


Which looks like it worked.

So I tried resetting it to reps:1 but the command still didn’t work. So obviously I broke something. Thanks for the help.

Bump on this - Am I posting in the wrong place?

When you get the

I assume that means when you try to tap the command in the BOND app, and/or use a voice assistant command?
(Since your original PATCH command seemed to have been accepted, as you got back the full “signal” node with its ‘reps’ set to the 5 you intended).

For your first hub which works with these blinds, what is the output of the “signal” node with a cURL GET command (no -X PATCH, no -d {“reps”:5} in the command)?

Thanks for the reply. I ended up deleting all of the shades and re-learning them. This time it matched them to a Dooya shade and so far the performance has been good. I also moved the hub right next to the windows, which may have had something to do with it.

1 Like