Fireplace GreenSmart Remote

I have a GreenSmart remote for my gas fireplace insert that I would love to get to work with the Bond bridge, but I’m having some difficulties. When I first setup the Bond device with the GreenSmart remote, Bond immediately recognized the command from the remote and the learning circle changed to green. But, when I tested the command with Bond it would not execute on the fireplace. The Bond device flashes and I assume it is blasting out the command but it’s like the fireplace is not receiving it.

I have tried it several times with different commands but to no avail. My GreenSmart remote does not have a FCC ID number listed on it. It just has a label that says it complies with FCC rules, etc…

Does anyone have any suggestions?

Curious if I have found the FCC of the device - does this user manual look accurate?

RF fireplaces / inserts are extra fun from what I’ve seen on here from other home automation enthusiasts (I don’t have one myself)- it depends on a number of things such as RF modulation (not all RF signal types are supported by Bond Bridge, even if in correct frequency range) and whether or not the fireplace / insert needs “pairing” with remotes or otherwise maintains a ‘keep alive’ signal.

Since your issue of no control happens at the time of testing, I sort of wonder if the RF modulation is the kind that the Bond Bridge doesn’t support.
Another random thing to try is to use the original physical remote to get the insert into the opposite power state as you’re about to try on the Bond app (as in, if you’ve “recorded” ‘On’, then use the remote to turn off the fireplace insert before testing the Bond app’s ‘On’ in the app setup step).
I don’t really think this has a high chance of making a difference but just spitballing here.

Bond staff are able to come through these forums from time to time, but do take advantage of the official support options if you want a more timely response.
(https://olibra.zendesk.com/ or customerservice@olibra.io)

Hi Matt, and thanks for taking time to respond to my issue.

No, that is not at all like my remote. I could not locate any documentation on my remote anywhere. All I could find is a photo of what it looks like (below), but it doesn’t show any details about it. My remote is not mounted to the wall. It is portable so I can set it wherever I want, which I prefer.

But, the good news is tonight I decided to try it again after I had programmed the Bond device earlier this morning, and it worked…somewhat. I was sitting in my chair tonight watching TV, and I opened the Bond app and hit the power on button in the Fireplace device and a few seconds later the fireplace lit up. But, all attempts to turn it off were futile. It would not turn off no matter what I tried. But at least it shows promise of working. I haven’t tried programming any other commands yet. I’ll keep tweaking it from time to time to try and get it working with some of the other commands.

108402.jpg

How interesting! Thanks for the update; hoping you will find some sort of pattern for what works and what doesn’t under which circumstances.

Hi! I have had the same issue with my fireplace too, I’ve found that separating the on/off toggle into two separate commands on the bond app can fix the weird issue of it not turning off or turning on randomly. This is the same problem with my TV and separating it out fixed the issue.