Can't reset Bond Hub ‎BD-1000

I purchased the bond hub ‎BD-1000 last summer to control my ceiling fan. It’s worked great since then, until I had to recently reset my home router. This, for whatever reason, made the hub non-functional. This is also the same router (Google Nest WiFi Router) that I’ve had since long before the purchase of the bond hub.

At first I just tried resetting it but that failed. Then I did 10 second pinhole press per this page and every time I reset it, I get the same behavior documented below. I also tried another method of pressing the pinhole, THEN plugging in the power cable, waiting 10 seconds.

Each time, I’m able to re-add the hub no problem, except for the following:

  1. I use the latest iOS app (even tried re-installing it) and wait for the ring to flash green. The app always finds it.
  2. I switch WiFi to the bond, configure my WiFi name and password. The bond switches to blue after a while.
  3. The app then tells me a sync failed after a few seconds, so I reload the app and wait for the hub to show Synced.
  4. Now if I try to update the firmware, I get “There was a communication issue (error 101)” or Error 105 or Error 107.
  5. Whenever I exit out from that prompt it shows the status of “Syncing…” for 30 or more seconds before returning to “Online” status with a green icon.
  6. “Name” and “Location” fields are both empty. While “Online”, tapping either one of them results in a red message at the top of the app “We couldn’t communicate with your Bond. Make sure it is powered up and connected to Wi-Fi.” The status then changes to “Unreachable”. Note that both the hub and my router are within 6 feet of each other.
  7. “Firmware Update” shows v.2.5.2 (1)" with the (1) indicating there’s an update. It starts, and gets a certain % along, but always fails with the dreaded “communication issue”.
  8. Also odd, after resetting it shows current version is 2.5.2 and the latest version is (an older) 2.28.0. Super confused by this because I thought the 10 second pinhole throwdown was supposed to reset it to its original firmware version.

I’ve tried resetting this hockey puck over a dozen times now. I’m about to chuck it out the window… please help! Maybe it’s toast? I purchased it Jun 29, 2021 from Amazon, it’s never moved from its location… maybe if it’s still under warranty they can replace it?

Check what channel the wifi on your router is configured as. I had an issue where my channel was changed to one outside the range of what Bond supported. Things may have changed since, but it may be worth a look.

It may have been more relevant for me in Aus, but here’s the thread anyway

Also note that you can get more realtime assistance from the Bond team through Help → Chat in the Bond app, or by emailing to open a ticket.

These forums are more community driven, though Bond staff are able to come through from time to time and help us out.

1 Like

This morning I went into the Google Home app for my Google Nest Router and enabled a privacy setting called “Nest Wifi cloud services”. I don’t see how this would have helped, but it did. I just left the hub plugged in overnight and didn’t change anything else.

However, when I went to the bond app this morning, it updated the firmware quickly and without errors. It went to 2.28.0 not the 2.5.2 I referenced earlier. Odd, but it’s working and that’s all I care about.

I doubt that privacy setting made any difference… so maybe it was just time?

Glad to hear that whatever the combination of things was, or one of them in isolation, got your Bridge back up and running.

There is an in-app backup option now that you may want to take advantage of to have a snapshot of the device(s) and their config in case you ever need it.

Thank you! I didn’t know about that! I found it and made a backup to save me time next time it happens. So far so good though.