Bond Release v2.17.4

I just saw an update for my bond bridge to 2.17.4. Anyone know whats in it?

v2.17.4.1 HOTFIX


APPLIES TO: Units starting ZZ (Zermatt and BBP).

Changes since v2.17.4

  • hotfix for bug where units initially set up on V1 App would have flashing green light after upgrade and require repeating Wi-Fi setup



APPLIES TO: Units starting Z (Zermatt and BBP). Does not apply to Snowbird. We have outstanding issues on Snowbird which will be addressed in a follow-up in a few weeks.

Changes since v2.15.8

  • fix bug where Bond Config network would appear when it shouldn’t (#1028, #1052)
  • fix issue with schedules timing in certain international timezones (#1048)
  • Add Support for Wi-Fi Channels 12,13 in Australia (#1006)
  • spinning blue light ring indicates connecting to cloud (#999)
  • fix IR support in Bridges (broken in recent fw) (#1064, #1067)
  • fix unreliable/slow firmware upgrades for Bridges (only helps with subsequent upgrades) (#1068)

Newly Supported Remotes

  • RCF217: Home Decorators fan with CCT (FCC ID A25-TX028)
  • RMS49: Auvent Awnings (Dooya 434MHz OOK remote)
  • RCF361, RCF362, RCF363, RCF364: 360 Fans (#994)

API Changes

  • support PATCH on sys/wifi/sta, sys/eth (#1007)
  • move compliance_region to new sys/locale endpoint (#1021)

Having an issue upgrading firmware from v2.15.8.1-beta. I run the Firmware update in the iOS app (BondBeta iOS app), it runs the normal cycle, reboots, and then says “Current Version: v2.17.4-2”. However, if I go back to the Bond Settings pane, it says v2.15.8.1-beta still.

And, if I force quit the app, and go back in to Bond Settings – it will prompt me to upgrade the Firmware again – as if it never received an update at all.

That’s odd. First, just try it again a few times. If that fails, you could contact support and ask them to upgrade the unit for you. (We now have this capability via our backend, with your consent).

1 Like

Thanks @merck! It seems reaching out to you fixed my issue :wink:

I’ve actually tried it a number of times over the past 2 weeks (maybe 10x), without success. Strangely, it just worked and I see the correct data in Bond Settings. I think it was stuck on “Sync”… not sure if that’s relevant.

The magic “I talked to @merck” button strikes again! :stuck_out_tongue_winking_eye: