Bond Bridge disconencts from wifi, then requires reboot

Hi there! tl;dr: Are there any known wifi AP settings that would cause a Bond Bridge to regularly disconnect from the network, and stay disconnected until rebooted? I’ve tried searching the forum for previous threads, but haven’t quite found anything that fits or fixes the issue.

My Bond Bridge will, after a few days, lose its connection to my router and then refuse to reconnect until I reboot either the Bridge or the router. Whenever this happens, I see this in my router’s logs:

Apr 22 08:53:27 wlceventd: wlceventd_proc_event(662): eth6: Disassoc F4:4E:38:1C:3F:50, status: 0, reason: Disassociated because sending station is leaving (or has left) BSS (8), rssi:0
Apr 22 08:53:31 wlceventd: wlceventd_proc_event(685): eth6: Auth F4:4E:38:1C:3F:50, status: Successful (0), rssi:0
Apr 22 08:53:31 wlceventd: wlceventd_proc_event(722): eth6: Assoc F4:4E:38:1C:3F:50, status: Successful (0), rssi:-28
Apr 22 08:53:46 wlceventd: wlceventd_proc_event(645): eth6: Deauth_ind F4:4E:38:1C:3F:50, status: 0, reason: Disassociated due to inactivity (4), rssi:-34
Apr 22 08:53:46 wlceventd: wlceventd_proc_event(645): eth6: Deauth_ind F4:4E:38:1C:3F:50, status: 0, reason: Previous authentication no longer valid (2), rssi:-34

Email support suggested enabling a guest network and connecting my Bridge to that AP instead to see if that fixed the issue—and that worked! But I don’t really love it as a long-term solution, and now I’m trying to figure out what settings on my usual 2.4GHz network might be causing the issue.

Some hopefully helpful facts:

  • The router is an ASUS RT-AX86U.
  • No other devices on my network have this issue.
  • The Bond Bridge is sitting a few feet away from my router, in line of sight.
  • I can’t say after exactly how many days/hours the issue happens, but it’s weekly.
  • Unfortunately, the Asus router doesn’t expose the guest networks’ settings, so I can’t compare it to my usual 2.4Ghz AP.

Would appreciate any help or insight people might have. Thanks!

All I can say is, we’ve heard this quite a bit around ASUS routers. I think that other ESP32-based IoT products are impacted as well.

Howdy, @bagels !

Sounds like you did all the normal troubleshooting pretty comprehensively.

Two questions:

  1. what firmware version is your Bond Bridge?
  2. if you have the Bluelight / LED brightness set to anything higher than 0, what are the LEDs doing on the Bridge whenever it has fallen offline?

Fair enough! Honestly, I can live with knowing it’s likely an ASUS specific issue. I spent a bunch of time researching the router log messages before posting, and saw others had reported seeing similar messages/issues with other devices—so I didn’t think it was the Bond, but hoped maybe there was a setting that wasn’t playing nice I could narrow things down to. Thanks!

@residualimages Hey! I’m on, but FWIW I’ve seen this behaviour on previous versions too. The LEDs go solid orange, then it attempts to reconnect/pulses blue—and then back to orange again, on repeat.

I must keep getting lucky – I use an ASUS GT-BE98 Pro, a GT-AX11000, and RT-AX92Us (and previously a couple other ASUS models).
Over the years, I’ve not noticed strongly recurring ESP-32 / Bond disconnect issues.
Probably so many variables that play into any environment / device experience though.

I shouldn’t sound like I’m putting down ASUS here. Just saying that we had reports of issues with ASUS Blue Cave (similar to Reddit - Dive into anything) and a few other reports through customer service. The Wifi compatibility is kind of a black box for us. We use drivers from Espressif unmodified and I believe they are Wifi certified. I can say that it is far and away improved from the early days when we used a Linux SoC with questionable drivers.

1 Like