Alexa not able to find BOND after skill is learned

Hoping for some help!
Just purchased BOND Bridge from Amazon and cannot get the Alexa app to integrate with it.

The BOND app from my iPhone works fine for turning the fan on and off. No problem there. Through the app, I can adjust the fan speed, turn lights on, etc. Works perfect.

But I cannot Alexa to pair with the device. I’ve installed/uninstalled both versions of the BOND Alexa skill, and tried all the combinations of one or the other. Account is linked. But the BOND has never once been discovered.

Bond Bridge firmware is at 2.9.5.

Are you using the new app? It’s called “Bond Home” in the app and play store. Using only the old app (now named “Bond Bridge”) will cause syncing issues.

Yep - I am an iPhone user.
In the App store, I downloaded “Bond Home” and have the fan working correctly in that app.
In the Alexa app, I have the Bond Home skill learned. and not the Bond Bridge.
Screen shots below -

Imgur
Imgur

Just tried again, and Alexa could not find any discoverable devices after learning the Bond Home skill.

Hi @zachymac,

I would like to help you solve this problem and discover the issue.
I messaged you so we can gather information about the problem.

I am having a similar problem. However Alexa finds the fan but when i instruct her to control the fan in any way nothing happens. Alexa makes the sound like everything worked as it is supposed to however the Bond Bridge never responds and the fan doesn’t respond. If I open the Bond Home app i can control the fan perfectly fine.

Any help would be much appreciated

Hi @Pcc87,

Sorry to hear that.
Having in mind that you are using the bond Home app, can you confirm if you are using the new Alexa skill too?
Also, can you confirm if you can control your devices using the Alexa app?

Thanks in advance!

The number for my bridge is AJ14052

Update from my initial post…

So I found that the BOND works (somehow) with my fan and light. However, I never actually successfully paired it with the Alexa app on my phone.
So the Alexa app has the skill “learned”, but I was never able to successfully pair the two? (if that makes sense).
However, when I say “Alexa, turn the fan to 2” it works?

I don’t know - It works?? But I have no idea how it is.

@endy I am having the same problem as @Pcc87. Has been working fine for a few years and just stopped.

Can control the fan and lights fine with the mobile app, but when using Alexa nothing happens. Alexa makes the sound to confirm that it worked, but nothing changes on the fan.

Have tried disabling and reinstalling the Alexa skill but no luck. Can you help?

1 Like

Solved my own problem. Had to reset the device, delete the old apps and reset up on new apps.

Kind of a pain for existing users where everything has just worked for a while

I was about to ask you to power cycle your device, it looks like it helps.
Great to know that your problem is solved @smn!

I also had a similar issue, where using a routine answered like everything is ok, but asking a command like “Turn on Kitchen Fan” gives a complete answer, saying to disable and re-enable the skill. In my case, disabling and re-enabling it brings everything back to normal.
We’re working to improve the integrations and fix this kind of issue.

Feel free to contact us here or in the support (Help Center on the Bond Home app) if you face any other issue or have any feedback.

Glad you got everything working again. However, you shouldn’t have to lose your devices! Just a “WiFi Reset” and setting up on WiFi via the new app should be enough. In that case, all your programmed devices should migrate over, insofar as they are stored locally on the Bond.