Alexa cannot find Bond controller

Hello all,

My Alexa devices/account is not able to find the bond controller. I can control everthing through the app just fine but just not through alexa.

I was also looking to integrate with home assistant but the API doesn’t seem to match the documentation.

curl -H “BOND-Token: xxxxxxxxxxx” -i http://10.0.20.203/v2/devices
HTTP/1.1 200 OK
Content-Length: 46
Content-Type: application/json; charset=utf-8

{"":“xxxxx”,“7xxxxx”:{"":“xxxxx”}}

I only seem to get one device even though I have paired two CFs.

I am looking to resolve this soon if not I plan to return it back to amazon.

Thanks

Hi! Welcome! Great to hear that the API is a selling point. Do keep in mind that we have not fully fleshed out the API yet. Here’s the two limitations you’re hitting:

  1. some devices are stored in the Bond Cloud rather than on the local device database, due to historical architecture reasons. It will be a while before we get the more complex protocols functioning offline.

In the meantime, you can try “raw recording” the missing device by rejecting the database result when it is presented in the app. You will need to record each button.

  1. The currently released firmware does not support actions. However, we could probably get you a development firmware version to unblock your integration work. @jacob may be able to help there with a curl command. (I assume your unit’s Bond ID starts with Z?)

As for why Alexa is not working, that shouldn’t be an issue. If you PM me your BOND ID and PIN I’ll take a quick look tomorrow at your account and try to give you some pointers. But you might get faster support from our regular customer support team. They are available until midnight eastern time daily.

Hi Merck,

In regards to #1 - I was under the assumption that an active internet connection is not required for local control but I guess for devices i.e. CFs will have to wait. I dont mean to be demanding but do you happen to know where it is on the roadmap? My remote ID is KUJCE9201

for #2, I am having trouble raw recording it - It never seems to work. I will keep trying but I do want to play around with the dev firmware.

I will PM my bond-id and pin in a few.

Thanks

Thanks

Hey there,

The following request will update your BOND to v2.6.21, which exposes actions and state for ceiling fans. Compared with the Commands API, this API should be a more natural fit for building an integration.

EDIT: I’ll just PM it to you.

I dont mean to be demanding but do you happen to know where it is on the roadmap?

Porting these remotes to work locally on the Bond is the next big priority after cleaning up a few bugs in the V2 firmware and polishing the above Actions API.

Hi Jacob,

Quick question before I change the firmware. I am having trouble pairing other fan remotes in my house. The weird thing is, I currently have KUJCE9603 model fan controller already paired but when I try to pair other remotes of the same model, it is failing to search the database. Do you know if the new firmware resolves such an issue?

I am pretty frustrated at this point where out of 5 fans - I have been able to pair only two out of which, only one is sorta working with the API; I am honestly considering returning it.

Thanks

The Bond does support this fan, not sure why you’re having issues with it. We could take a look at the signal you’re recording to diagnose the problem, but here are some quicker steps: make sure the batteries are at a good level, try using “Advanced Options” when you’re recording and setting the scan frequency to 304.3 MHz (the frequency of your remote)

@ndng28: Our server logs indicate that your Bond is picking up noise at a frequency of ~299 MHz which it is mistaking for your remote control. This causes the scan to complete prematurely before your real remote (at 304.3 MHz) is picked up.

Jacob’s suggestion of using Advanced Settings to manually fix the RF scan frequency should get you out of the woods!

Hi all,

Good news, I moved the bond controller to a new location and it picked up all the fan remote frequencies just fine. I will test out the API and report back soon.

Thanks

1 Like

Turns out I had to set it to 303 MHz. It picked up the signal rightaway too once I set the right frequency. Pretty cool hardware you guys have built. I will start integrating it with Home assistant and node red to see how far I can take this. Will keep you guys posted.

Cheers

Some of the curl commands seem to be failing…

curl -H "BOND-Token: xxxxxxxxxxxxxxxx" -i http://10.0.xx.xxx/v2/devices/xxxxxxx/actions/TurnOn -X PUT -d '{}'
HTTP/1.1 400 Bad Request
Content-Length: 54
Content-Type: application/json; charset=utf-8
{"_error_id":61,"_error_msg":"action not supported"}

Any ideas?

Hmm… what commands are present on your device? Is TurnOn visible in GET actions? Here’s the cURL for that:

curl -H “BOND-Token: xxxxxxxxxxxxxxxx” -i http://10.0.xx.xxx/v2/devices/xxxxxxx/actions

Sent you a PM. Let me know.

Hi @ndng28! Saw your post re: home assistant. Are you working on a component or exploiting the the rest_command? I did the latter for quick prototyping of my “cloud only” remote recorded locally for now. My post has sample configs that worked for me.