Alexa and Google Routine Problem

Since updating my hub to V 2.10.8, existing and also new routines for turning On and Off my five Harbor Breeze fans are now buggy. Only two of the three seem to respond now. Voice commands work fine for both Alexa and Google home.

Hey Den, do you recall your previous FW version? And can you DM me your Bond ID? (So I can take a closer look, and check which build of firmware your unit uses.)

The likely reason for this is, that all your fans are (I’m assuming) on the same RF frequency. When the Bond Bridge has several transmissions on the same frequency in its queue, we inject a gap of ~300ms between transmissions so that the fan receivers have time to “recover” and be ready to hear the next transmission which may be for them. This need for a “recovery” period is an unfortunate feature of many receivers.

I’m suspecting that, between firmware versions, there’s been an effective decrease in that gap. Perhaps the gap was actually greater than 300ms, but recent performance improvements brought it closer to 300ms while your receivers expect something greater.

As suggested, I added a 5 second Wait command between fan activations, which did not help. I solved my problem by deleting my 5 fans from my Alexa app, disabling the Bond Home skill, then enabling it and then remaking my fan routines. Next, I need to work on my Google Home routines.

Ah, it sounds like an issue where both Alexa skills are enabled. (Or even that the fold skill is disabled, but there’s some phantom devices on the Alexa side.)

Do let us know how/when you get it sorted out.

I’m trying to add fan control to one of my existing Alexa routines, but I’m having trouble with it. Can you walk me through how you created your fan routine?

Nevermind, I figured it out. Don’t know why it wasn’t working the first time I tried yesterday, but it’s working today. :slight_smile: