[SOLVED] Suddenly No Longer Working All The Time

So we just purchased a Hampton Bay ceiling fan from HD a couple weeks ago which was bundled with the BOND Home device. Setup was remarkably easy and had it integrated with Google Home for voice control in no time at all. We have an older Hampton Bay in the living room that it works on as well.

But now, without any changes, it no longer works reliably on our new fan in the master bedroom (the one we just purchased). The voice controls don’t work, and when I use the BOND app directly it will sometimes work, often after hitting the buttons several times. Same with the fan control. Each time I hit it I can see the blue light flash on the BOND Home device but then nothing will happen.

And here’s the catch… The remote control that came with the fan works 100% of the time, and the BOND app still controls our older ceiling fan in the living room flawlessly.

So the problem is with the BOND Home device, right?

Thanks in advance.
Casey G.

Hey Casey, glad to have you join the forums.

Official BOND support may be faster than the community here, but I kind of wonder about a couple things we can try to clear up.

  1. you say every time you use the app or the voice commands with Google that you see the BOND Bridge blink blue - I’m assuming you mean with both the new fan in the bedroom and the older living room fan?
    If there are sometimes blinks and sometimes not, it may be that the trust state is being respected on the BOND Bridge but that the original fan remote is sometimes being used and the trust state gets out of sync. (BOND Bridges do not ‘listen’ for original fan remote presses and depending on what fans / lights are being controlled, the device may only have toggle commands vs discrete on and off commands).
    If it always blinks but the fan/light doesn’t consistently respond, then I’d say we move on to #2.

  2. Where is the BOND Bridge in relation to the master bedroom? If you move it into the master bedroom (assuming it’s not there already), does it behave more consistently?
    I did have trouble in my previous house with RF signals reaching one of the fans in one room; I ended up solving by having one BOND Bridge in the middle of the house that reached all but the troublesome room, and another BOND Bridge specifically in that one room.

Thank you for your reply.

The BOND Home device always blinks when I issue a command (both through Google and the BOND app). And as I mentioned, it worked flawlessly for light and fan control for a week or two now. Just starting the last day or two it’s stopped. Both forms of control still work 100% of the time with the older ceiling fan/light in the living room.

The BOND Home device is located in the master bedroom along with the ceiling fan/light combo that doesn’t seem to work.

I was really hoping to narrow down who to contact first, BOND or Hampton Bay… but I presume that if the handheld remote works every time it must be on BOND’s end. It’s like it’s sending signals but the format isn’t being accepted by by the ceiling unit.

Next bit of troubleshooting:

Will you try to add a new device (don’t delete the existing bedroom fan) to BOND using the bedroom fan remote - call it Test Bedroom or something?
For this first level of troubleshooting / since it was previously working. we’ll let the database match the remote.

Does Test Bedroom respond any better in the app?

@CaseyG Welcome! First off, Residual Images has given you very good pointers.

I understand:

  1. Bond Bridge works fine with Living Room Fan
  2. Bond Bridge works only intermittently with Bedroom Fan
  3. Bedroom Fan works fine with the factory remote
  4. Bond Bridge is already located in the Bedroom

#1 suggests that the Bond Bridge hardware is OK.
#2 suggests there’s a problem with the Bond’s signal strength or contents
#3 shows there’s nothing wrong with your fan/receiver combo.
#4 actually does not rule out a range problem

My top suggestions:

(A) Exactly what Residual said: Try creating a new device called “Test Bedroom”, and re-record your bedroom remote. You might try recording with the remote control farther from the Bond Bridge, or with it closer. This changes the quality of signal the Bond records and can effect control reliability.

(B) You could try moving the Bond Bridge into a different room. It might be too close to the bedroom fan actually. (Though usually this isn’t an issue.)

Don’t worry about testing via Alexa vs App – they do the same thing from an RF perspective, so it’s probably easier to just use the app for test purposes here.

If you get stuck, our Customer Support team is here to help, just use the Support section of the app our our website.


Thank you both for your replies.

After I got home last night I went to go try the things you recommended (residualimages), but first I got an itch to go ahead and check to make sure the BOND Home device didn’t have any pending updates. Surely enough it did and I loaded it up. Everthing seems above board now.

Hopefully it was just an issue with the OS or database that has now been rectified.

Thanks again for the assistance, it is a wonderful bit of tech to have around the house and I’m glad to have it working again.