Smartthings (Samsung Connect)

@Bsqrd or others - do any devices in SmartThings have an up/down appearance? My understanding was that SmartThings integrations used On/Off switches whenever there wasn’t an appropriate mapped device type out of the options that SmartThings makes available to integrators.

1 Like

Yeah, I’d like to see simple switch names configurable: on/off -> open/close, up/down or summer/winter etc. But this is all on SmartThings side. I’ve just emailed them requesting this feature.

1 Like

Does the bond bridge work with samsung smartthings?

Yes, here’s my little demo of how to get started: SmartThings demo

Or, if you’re already a SmartThings user: you’ll need to use the “new” SmartThings app to add “Bond Home”. At that point you could use this new app, or the classic SmartThings app in a limited way.

(Also, make sure you’re on the new “Bond Home” app before you try this)

Hi Jacob, thanks for the video. I have linked my bond home (bond bridge) to SmartThings. I can see all of my devices. They are added. But then smart things can’t connect to them. Can you assist in resolving this issue? All buttons yield this same issue.

Looking into it now!

Any reason the options in Bond aren’t reflected in SmartThings? Since I can’t program the buttons in Bond to repeat (this is how we turn off our fireplace, turn it down until it turns off), I’m hoping to get the “Down” option exposed in ST so I can create a webCoRE piston to do this. Also, trying to use the “Power” button doesn’t do anything. Just says “A network or server error occurred. Try again later.”

We really could use the ability to customize these buttons in Bond as well.

(I can only post one image as a new user, but I have the options in Bond for “On,” “Up,” “Down,” “Low Flame,” and “High Flame.”)

ST requires there to be an appropriate template on their side. Perhaps they have one for fireplaces we could try. But it’s not terribly flexible.

That lack of flexibility on integrations is actually why we’ve been hesitant to add customization of the commands on the device in Bond Home. If you could create arbitrary commands and rename things, how do we automatically create a sensible export to ST, GH, etc?

Nonetheless, we are looking at allowing customizing commands via app (it’s already on the api), we just need to make it clear the impact on integrations).

Makes sense. My ultimate goal is to expose a customized “button” to Alexa. However I need to get it there is fine with me. Since I need to be able to repeat the “Down” option about 10 times to turn off the fireplace from its max setting, I’d love to be able to create that somewhere (even in Bond Home) exported to Alexa so I can say “Alexa, turn {command} the {device}” and when {command} is “Off” it’ll send those 10 “Down” commands to the fireplace.

Since I can do a lot of customization in ST, that seems like an obvious place, especially since I have other inputs I can wire into that logic (temp sensors, presence, schedules, etc), but I’d be content with the Bond App for now. As it is, the device isn’t particularly useful to me, but I’ll keep an eye out for future improvements!

Right, that’s where it gets tricky. Perhaps we could make some customizable “mode” export with user-provided strings. :thinking:

What you can do right now is, add a “Generic” device with a different name like “Fireplace Special Mode” and then you can say “Alexa, turn on Fireplace Special Mode” and it will work.

What you can do right now is, add a “Generic” device with a different name like “Fireplace Special Mode” and then you can say “Alexa, turn on Fireplace Special Mode” and it will work.

It will work such that I can create a customized option to run the “Down” command several times in repetition with a single “Off” command?

There’s a field you could use for this, reps (documented here). When you’re recording a raw signal (as opposed to getting a fully-built result from our remotes database), this field defaults to 1, but you could increase it to 10. This’d basically replicate you tapping the button 10 times in quick succession. This has worked for other users with similar issues.

You’d want to record your “Down” signal as an “Off” (of course, you can keep the plain “Down” as well), then modify its reps so that it sends a repeated signal.

The curl for this would look like:

curl -i -H "BOND-Token: <your Bond's token>" http://<Your Bond's serial>.local/v2/devices/<device_id>/commands/<command_id>/signal -X PATCH -d '{"reps": 10}'

There’s a lot to unpack there, we definitely need to get an in-app way to modify this! The token can be found in the Bond’s settings, the device ID can be found in the device’s settings, the command ID I guess you’d have to “discover” by requesting the commands list as follows:

curl -i -H "BOND-Token: <your Bond's token>" http://<Your Bond's serial>.local/v2/devices/<device_id>/commands

You’ll get a list of IDs which you could individually query with

curl -i -H "BOND-Token: <your Bond's token>" http://<Your Bond's serial>.local/v2/devices/<device_id>/commands/<command_id>

until you find the one you’re looking for.

If this all seems really intimidating, PM me your Bond ID and the name of the fireplace and I could either find the command ID for you, or just directly tweak the reps for you.

1 Like

Thanks Jacob! I’m comfortable with curl and APIs. I’ll review it and reach back out if I need help. Thanks for the info!

Hey Jacob, I tried this just now and I get a 404 from the Bond. I tried a few examples from your message, as well as a few from the API docs (including the “GET” example using JSON), and all return a 404. I confirmed my Bond Token is accurate as well. I have firmware version 2.10.8

curl -i -H “BOND-Token: {MASKED}” http://{MASKED}.local/v2/devices

HTTP/1.1 404 Not Found
Content-Type: text/html
Server: Microsoft-IIS/8.5
X-Powered-By: ASP.NET
Date: Tue, 14 Jan 2020 20:45:04 GMT
Content-Length: 1245

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "">
<html xmlns="">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<title>404 - File or directory not found.</title>
<style type="text/css">
body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
fieldset{padding:0 15px 10px 15px;} 
h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;} 
#header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
#content{margin:0 0 0 2%;position:relative;}
<div id="header"><h1>Server Error</h1></div>
<div id="content">
 <div class="content-container"><fieldset>
  <h2>404 - File or directory not found.</h2>
  <h3>The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.</h3>

Looks to me like a Windows server is responding to your request, rather than the Bond. Perhaps something’s going wrong with mDNS. To get around this, instead of http://<Bond serial>.local you could try http://<Bond IP address>.

You can find the IP address in the Bond’s settings in-app, or with ping <Bond serial>.local.

A quick and easy endpoint to check if you’re reaching the Bond: the root URL should return some HTML for the web GUI, no token required:

curl http://<Bond IP address>

1 Like

Ok, I got it… for some reason I was thinking Bond had an embedded IIS server and was pretty baffled, but it turns out my VPN was routing the 192 traffic outside. Turned that off and it’s working. Sorry for the confusion, and glad you’re not using an embedded IIS server :stuck_out_tongue:


Ok, I got it “working.” However, I set it for 25, but it only executes 13 times. Here is the response when I configured the reps. I’m not really able to decipher the hex.

I don’t know if it’s another option, but I can hold the “Low Flame” button down for 10 seconds to turn it off as well. Bond recognizes this as a single command when I record the button, not a sequence of commands in a single press (not sure if that makes sense). Not sure if that’s a better/configurable way to make this work as well.

How do you know that it transmits the buffer only 13 times?

It’s just a raw buffer of the 0.6 sec of RF that the Bond Bridge recorded from your remote. That is the signal which is repeated the 25 times (should be 15 seconds total).

How do you know that it transmits the buffer only 13 times?

My fireplace beeps 13 times when I trigger the command, lowering the flame each time (has a small actuator that I hear adjusting). After 13 it just stops. Stops at 13 consistently. From the max flame setting, it takes 20 reps to turn off completely (I pad 5 just to be safe).

We are currently testing a SmartThings Edge driver that runs locally on the hub. Please check it out if you want control without a cloud connection: