Smartthings - removed buttons keep reappearing


I recently purchased a Bond Bridge to use with two of my ceiling fans.

I’ve added the fans and they both are working fine. Both fans had a ‘Winter Mode’ button that I removed from the Bond app as this is controlled with a physical switch on the fan itself. They also both had light buttons that I removed from one of the fans as it does not have a light.

When I added the fans to my Smartthings, they still showed up with winter mode buttons as well as light controls for both fans. I’ve tried removing these buttons from Smartthings, but they keep showing up again.

Is there any way to prevent them from reappearing? I really don’t need the additional clutter in Smartthings.



Hmm… these should only be repopulating when you remove and re-add your Bond account, or force a discovery by visiting the Bond “connected devices” screen. Is it safe to assume you’re doing neither of these?


Sorry, not entirely sure what you mean by the ‘connected devices’ screen.

So I removed Bond form Smartthings and re-added it. When I do so, it adds the winter mode for both fans, lights etc.

I’ve removed the winter modes and one of the lights using the Smartthings IDE.

We’ll see what happens, but previously they will show up again…

I’ll see what it looks like tomorrow.



They’re back in Smartthings this morning…

Ouch, okay, I thought SmartThings’s discovery requests were only user-triggered. Hmm… yeah that sounds annoying, but I shouldn’t just remove it as some users are using this feature.

What we need is a way to configure on our side what gets exposed to integrations… Something where you could say “I don’t want reverse (Winter Mode) exposed” “I do want top/bottom light exposed”. We’ve discussed this before but we need to do some work here.

OK, thanks for the update.

I’m guessing I could get around this by manually adding the fan?

Correct me if I’m wrong, but I can’t get dimming controls if I do this (which would be fine for the fan with no light).



Yes, but if you’re fine with losing direction control in the app as well as in ST then there’s an easier solution: you can go to edit commands and delete the reverse command. (This option wasn’t available in the apps for a while, so make sure you’re on the latest version of the app)

Hey @brianl. Looks like I didn’t notice that you’d already tried this! Sorry about that. I got another report of this issue and finally realized the root cause of this issue. We’ve got it fixed up now in firmware version v2.10.21, currently available via the beta app, which you could sign up for here.

If you’ve got some time to try out this version, we’d love to hear whether or not this works for you.