SmartThings, Device Handler Required?

I’m trying to debug an issue where I can’t see Bond devices in ST ap for iPhone 8. The support team has worked with me to debug with no success. (They tried QUITE hard!! Thank you!)
I’m now using the ST web interface to view/manage the ST configuration. I do see the Bond devices but they are listed with PLACEHOLDER instead of a Device Handler for Type. To me, all devices need either a standard or custom Device Handler. I’ve had to manually add one for another unique device. Since I’ve been working on this for days, I’m sure I’ve messed something up and wondered if I could manually add a Device Handler, it might just fix things.
Thanks for the assistance!
Jim
screenshot1

Here is more ST web configuration detail for a different fan. The highlighted entries look like they were template driven updates to ST but they are missing required detail. I would expect to see the Bond ID, Device ID and Local Token information included for each fan. When I had added 3 fans, the info for each fan was Identical outside of it’s name.
Thanks again for any thoughts/help!

In an attempt to start “fresh”, I changed the email address on my original account and created a new account using my previous email. I then added the wiped Bond Bridge and one fan to the account. I manually added the OFF, 1, 2, 3 speeds as I saw a post that this forces data local Vs cloud. I then went into ST ap and added the Bond controlled fan. As before, in ST Web, I see the configuration update (previous posts) but question it’s validity. No Bond devices appeared on my ST ap desktop. I guess I have no recourse at this point other than to wait for a response to my post.
Thanks again!! SORRY to be a pest!!
Jim

1 Like

To those who have a successful SmartThings integration:
It would be an amazing help to see how your fans are listed in the ST IDE tool at the link below. Just log in with your Samsung credentials and then click My Devices at the top, scan down the list for a Bond controlled fan and then click the name on the left to show the details. If you can upload a screen shot like the highlighted one above, it would help all of us better understand what valid values look like.
Thanks for your help!!!
Jim

https://graph-na02-useast1.api.smartthings.com/

Hey Jim, sorry for the delay in responding here!

I’ve got a working SmartThings setup and I see nothing on this dashboard. How did you go about setting this up? You’re using the “new” SmartThings app, right? I made a little demo a while back: SmartThings demo. If you were to follow along in this demo, what happens after you log in? It should tell first tell you a list of devices imported from our side, then they should appear on the dashboard. Do you at least see the list of devices?

It’s Christmas!!! You need to be with your family!! Still need help!!

I’ve posted in the forum screenshots of my current test setup (not working) in the forum. Yes, using new Bond Home & Smartthings ap. Bond Home works as expected. In Smarthings, I see the fan in the IDE but not in the iPhone ap. :frowning: I’ll be online again in 12 hours and hope we can move further forward!

Hi Jacob, When installed the first 2 fans, everything worked PERFECTLY, including the SmartThings integration. I had complete control of the devices with Bond Home, SmartThings & Alexa! Skip forward 2 months and I added a 3rd fan. That’s when the problems started. I can get all three devices working perfectly in Bond Home. So at this point I removed Alexa and Bond Home from ST, I wiped the Bond Bridge and reset it to factory settings. Leaving Alexa out, I added Bond Home to ST per your video. It appears to, log in & I see the list of devices returned, I don’t see the Bond Devices on the home screen of ST (see extract from your video) below. Per previous posts, the ST IDE shows the Bond devices but I don’t think they are correct as they don’t have device addresses and no associated device handler. Thanks for your help!!

Another tidbit: I think the Alexa integration caused some corruption of my configuration. As I worked through adding the third fan, i repeatedly removed and added back the Bond service. When I couldn’t get it to work, I went into the SmartThings IDE tool to look at how the Bond Home devices were defined. I found around 10-15 entries for my 3 fans. In each, was a reference to Alexa. So I think the Alexa integration prevented the proper removal of devices. I had to manually delete all the Bond devices from ST IDE. I then removed the Alexa integration from ST. At that point, adding/removing Bond service seemed to properly add/remove devices from the ST IDE. Bottom line, in debugging Bond Home-SmartThings, temporarily remove the Alexa integration to prevent conflicts.

Sounds about right. If you remove the Bond Alexa skill, the associated devices are not deleted! This has been a big headache for us, but yes, it totally lines up with what you’re saying.

Okay, so it seems that there’s something wrong with the 3rd fan you added. Could you let me know the in-app name of this fan? I’ll take a deeper look.

It seems that starting from Dec 21st, the “push” side of our integration (that is, Bond->SmartThings direction) was not working properly. I just made some changes, and it’s working properly for me now, could you see if maybe that was the cause of your problem?

1 Like

Well the original & desired configurations are history at the moment. I’m trying to start from scratch with a simple single fan. I figure what I learn will apply to the target configuration of 3 fans and maybe new ones I add later. I also hope this helps others.

Below are iPhone 8 screen captures of the Bond Home ap and SmartThings ap. Following that is an image from the ST IDE. As previously indicated, Ceiling Fan does not show up as an icon on the ST ap.

This should give you a view of all aspects of the issue. Again, Thanks for your help! Oh… and HAPPY NEW YEAR!!! :wink:

IMG_5891

I deleted the service from SmartThings ap, cleared Safari cache, rebooted the iPhone, verified it’s deleted in the ST IDE and then added the service back in the ST ap. The Ceiling Fan was in the response from the process, as above. Unfortunately still no fan in ST ap. I went to the ST IDE and verified that there was a new entry for Ceiling Fan. It looked exactly the same as in last post.

Just confirming that Ceiling Fan works PERFECTLY in the Bond Home ap. BTW, I used the fan remote to program off/1/2/3 as I read that forces local. I didn’t use a template from the Bond DB. I note that the ST IDE entry shows Execution in the Cloud. If the ST integration is working for you Jacob, I’d really like to see how it’s entered in the ST IDE tool. It could be that minor manual tweaks will make the difference. I know that there probably is more work to bulletproof the integration process, but at this point my smarthome is limping along and my wife is giving me that look! :wink:

2 Likes

In a holding pattern until the cavalry arrives. SmartThings ap version 1.6.42, Bond ap version 2.17.3, Bond Bridge firmware version 2.10.8. iPhone 8 with iOS 13.3. No change in environment/status from December. Thanks!

Hey @JimBlackNC55 I am seeing the same issue as you. I just bought bond and haven’t had any luck seeing my fans in the new SmartThings app, however I can see the fans in the classic app

If you use the SmartThings IDE, Do you see the “placeholder” entries for the fan or something different? If different, please share! Thanks!

https://graph-na02-useast1.api.smartthings.com/

I just see the placeholder entries as well, same as you.

Thanks Sunny! I think we’re figuring out that the Alexa integration is disruptive. I’ve removed the service until we figure out how make Bond work. Currently, once it’s corrupted, I can’t figure out how to get it working again. Know that, when the Bond <> SmartThings integration works… it’s amazing! I had it connected to temperature monitors and the fans were going on/off as needed. ST control of the fan lights worked. Alexa worked. I couldn’t get Alexa to control the fan lights, but was able to control the speed of the fans with a few words. Bond was able to control fans on the first and second floor.

Sorry, I’ve been away sick.

I do see my devices on that “IDE” dashboard now, also with the “placeholder” entries. Here I’ve cleaned up my setup and just have a single ceiling fan.

Since this fan is working for me, I assume that this ‘placeholder’ is how SmartThings classic populates devices imported from the “New” SmartThings. I think your theory about Alexa Bond devices causing the issues is pretty likely, have you tried deleting the Alexa-imported Bond devices? They should be duplicates anyways.

Thanks so much Jacob!! Sorry that you’ve been under the weather!! So all three of us now have similar entries in the SmartThings Integrated Development Environment web tool. I also moved from the Classic ST ap to the New one. I’d previously deleted the Bond integration from Alexa. I no longer see Alexa references in the Bond entries with the ST IDE. By “working for me” I infer you can see the devices in ST as per your video. Not sure why Sunny, who I think is a new user, and myself can’t see the icons in the New ST ap. I just went through the delete Bond service from ST, clear Safari, reboot iphone, reinstall Bond service. It looked successful but still no bond devices/icons.