Skytech 3001 K9L3001TX

I have 2 milivolt gas fireplaces that are separately controlled by Skytech 3301 remote transmitters/receivers (further refered to as TR). Both TR’s have identical FCC ID #'s. The only difference in the two is one TR is 5 years older than the other one. Both work perfectly. The newer TR paired as a Ceiling Fan prior to being accepted in the beta program. Once accepted to the beta program I was able to pair it as an Electric Fireplace. The older TR would not pair as a Ceiling Fan or an Electric Fireplace. The Bond will blink blue slowly and turn solid green as if it were pairing successfully, but when testing, will not activate the Fireplace. I then attempted to enter the transmitter frequency in the advanced section, but when trying to pair, the blue light flashes very rapidly and turns green instantly when the transmitter button is pressed. Sometimes it will error out and the light will turn orange.

IC 2439-3301 TX
FCC ID - K9L3301 TX

IC - 2439 102 760A
FCC ID - K9L3001 RX

It seems that these are actually two different models of remotes:

The newer one is FCCID K9L3301TX (filed 2005), while the older one that you report difficulty with is FCCID K9L3001TX (filed 1997).

From looking at logs of the RF signal, it seems that the older transmitter’s transmit frequency is rather unstable, and so the BOND is only seeing part of the signal as the frequency moves in and out of the BOND’s RF “field of view” (bandwidth). We have seen this in another remote at the lab, and are working on a way to allow the BOND to record these unstable remotes.

I have a test firmware (v1.113-1-g3685989) which may allow the older Fireplace remote to be recorded. Do I have your permission to push it to your BOND? If so, just say “Yes” and I will push the update and let you know when it’s completed.

Looking forward to getting this working for you!

By the way, it turns out we have this K9L3001TX remote in the lab. We are observing a frequency of 303.972 MHz, and recording with the current published firmware only works when the remote is held <1ft from the BOND. New firmware should improve this.

So, you could also try inputting 303.972 for frequency in advanced settings and holding the remote very close.

Advanced settings only allows numerical entries in the hundredths to the right of the decimal point, so I would only be able to enter 303.97. And I have always held the remote within about 3" of the Bond. Also, is the rapidly flashing blue light normal? Yes, you can push the test firmware to my Bond.

OK, your BOND is now on a test firmware that should be able to better record your K9L3001TX remote. Do let us know how it goes!

Version details:
{"bondVersion": "1.0.0", "mcuVersion": "x1.112-bw400", "firmwareVersion": "v1.113-1-g3685989 BUILT Mon Mar 12 17:44:29 UTC 2018"}

Still does not wor using the test firmware. The Bond blinks blue slowly and turns a solid green as if it recorded, but nothing happens when I test. Tried inputting the frequency 303.872 as you suggested but the Bond blinks blue very very rapidly and then either turns orange or green, and still does nothing when testing. As I previously said, when inputting the frequency, I can input 303.872, but it only shows as 303.87.

Thanks for giving it a try. I’ll have our remotes expert take a look. We should be able to figure out what is going on. — We did just receive this exact remote in our lab, so we are trying to reproduce here.

I decided to give it another try and lo and behold I got it to work. It took multiple tries with using varying distances between the remote and the Bond. The pairing worked best with the remote about a foot from the Bond. I had been placing the remote about 2-3 inches from the Bond, because that’s the distance I used when pairing my other fireplace and ceiling fans, but at that distance it wouldn’t pair.

It seems that both Skytech remotes I have (3001 & 3301) communicate with their receivers every few minutes. So if I turn on the fireplaces via the Bond, or by voice using Amazon Echo, within approx. 5 minutes the fireplaces automatically will turn off, I’m assuming because even though the fireplaces are on, the remote is in the OFF state when communicating with the receivers. So I tried leaving the remote in the ON state and turning the fireplaces on/off using the Bond and Amazon Echo. This time while the fireplaces were on, they stayed on until I turned them off via the Bond or Amazon Echo, but they would automatically turn back on a few minutes later, again I’m assuming because even though the fireplaces were off, the remotes were still in the ON state when communicating with the receivers.

@merck

Were you aware that the Skytech remotes had this auto-off feature? It makes using the Bond to control the fireplace pointless. If there is no work around for this, what fireplace remotes does Bond recommend?

Thanks for the info. We opted to bring Fireplace support to BETA early to get feedback. Many fireplaces work fine (in fact, users have been adding fireplaces as ceiling fans for some time). However, while still in BETA, we are still working on improving the experience including dealing with the timeout feature in some fireplace receivers.