Pet trainer RF remote

I just got an RF based pet trainer for my dog. It communicates with a device on the collar that vibrates or beeps. We use it to correct her as she can be quite aggressive. It does not use a shock. I noticed that it was 433 MHz.

For fun I tried learning it as a remote so I could buzz her from my desk when working and she sees something outside that is worth barking at. Bond found it every time and showed several frequencies ~ 433.7XX each time I tried to learn it. But when I tried sending the commands it did not work. Any advice on how I might get this working? Thanks.

If you can find an FCC ID (or even just a model number if you cannot find an FCC ID) on the original remote, or in the battery compartment, it might give us insight if it is a rolling code or something that isn’t expected to work.

There is nothing on the unit. It just says FCC certified. I searched for the company and found some other models they make and found this FCC ID - This unit is 433.92.

Here is the unit I purchased -

Not sure if any of this helps? Thanks.

The best I was able to find was the image below which the manufacturer uploaded to Alibaba (and it is noted that all the PD-520s are the same despite different ending letters), but the company does not appear to have an FCC ID on file for the model you have.

The company does list a PD 526 model with the FCC, but doesn’t really help us too much with your PD-520.

Thanks, out of curiosity if we had found the FCC ID what would that have told us that would help in getting the Bond to learn the commands?

Looking at the filing, we may have been able to see details about the modulation and/or rolling code is or is not used, etc.

The Bond staff typically asks us for the FCC ID in any troubleshooting when they come through, too, so it was just an attempt to have all the data here for them if they stop by this thread.

Very interesting use case!

Can you try to set the scanning frequency to 433.92 to see if you get better results?
If you need help on setting the frequency for the scanning, let me know!

422.92 didn’t work. I did try repeatedly recording the same button (there are only two buttons that transmit) and I got:


And then it just seems to repeat through these frequencies in the limited testing I have done so far. I don’t know if this is helpful at all? Thanks.