No longer able to change fan speed - Google/SmartThings

Hi everyone,

I have three identical ceiling fans connected through a Bond Bridge that I got months and months ago.

I’ve always been able to change fan speed by voice, within the Google Home application and on various Nest Hubs. However, this stopped working all of a sudden recently, maybe around a couple weeks ago.

Now I can only turn the fan on and off. The speed controls have disappeared from the Google Home application and the Nest Hubs. The voice commands also no longer work, for example 'change fan speed to 2"

The fans are connected to Google using the SmartThings connector but if I remove them and add them directly with the Bond Home connector, the problem remains.

The speed controls are available and work fine from within the Bond Home app and the SmartThings app.

I suspect it’s because the Device Type in Google is shown as a “Fan (Switch)” but I’m not certain. I’ve tried changing it to something else like “Outlet” or “Air Conditioner” and back to Fan but it doesn’t change anything.

I also have access to Alexa and the situation is similar there. If connecting the fans with the SmartThings skill, there is no speed control available. But as opposed to Google, if connecting directly with the Bond Home skill here the speed controls work as expected.

Note that with Alexa when speed controls work (using Bond skill) the device type is “Fan”. When it doesn’t work (with SmartThings skills), the device type is “Switch” and can only be changed to “Light”.

Something must have changed recently to break the device types.

Any ideas what happened to cause this problem or anything else I can try to bring back the speed controls?

Running Bond Bridge firmware 2.17.4-1 on a ZZ model (also tried BETA firmware, no change) and Bond Home v.2.32 on Android 11.

Confirming same issue with direct first party Bond <–> Google Home integration (unable to test Alexa).

Devices appear as “Fan” type but only expose power toggle, not speeds (in Google Home app as well as voice queries / commands).

Type: Fan

Exposed control: power toggle

Thanks for checking and confirming that I’m not going crazy :slight_smile:

I also opened a support ticket to let the team know.

1 Like

I also lost the Google Home and Smartthings integration since last week. Now I can only control the devices on the Bond app. I have power cycle the Bond bridge and unlink/relink many times and still could not get it back to work.

@billcsho - do you do your Google Home integration directly to Bond (as in, you add Bond to Google Home and you also add SmartThings to Google Home / Bond to SmartThings), or do you use Bond to SmartThings and then SmartThings is what you integrate with Google Home?

I forgot what was my original integration setting as that has been a long time since I set it up. However, I have tried both ways to relink it this week and neither works. Only Alexa integration is still showing as connected in the Bond app. On Google Home after attempting to relink, it keeps showing offline for each device control.

Like Bill I have also tried both methods. I deleted ALL my integrations of ALL my devices in Google Home so that I have no devices at all.

Then I added only the Bond Home integration. My fans then get added but only the power on/off controls are seen by Google, no fan speed controls like there used to be.

I then tested by removing the Bond integration from Google Home and added the SmartThings integration. The result is the same, Google Home only sees the power on/off controls, no fan speed controls.

The SmartThings app itself sees the fan speed controls and they work fine.

Also tested the same way with Alexa starting from scratch. In this case, using the SmartThings skill also shows no fan speed control BUT using the Bond Home skill still has working fan speed controls.

When Google Home removed the Speed Controls in their app, that’s on Google’s side (as I have confirmed the device is still seen as a Fan type, above).

@merck / @endy / @natan - any updates you’ve gotten about Google integration? Their documentation still seems to indicate that Fan type devices should have speed parameters…

EDIT: The more I think about it, I believe that in my personal experience, my Google Home app may not ever have had speed commands on screen, but my Google (voice) Assistant has handled speed voice commands.


This is accurate AFAIK.

I’d recommend giving Google Assistant team feedback that you want this. If they see their users asking for it, they might prioritize it.


Guys, I’ve been using on-screen fan speed controls in both the Google Home Android app and on multiple Nest Hubs since day one after I bought my Bond hub and my fans. We’re talking like 8 months ago. I only wish I took screenshots at this point.

In any case, it’s irrelevant because the voice controls are also not working anymore. All the following speed related commands now result in “Sorry I don’t know how to help with that”.

Support for Ceiling Fans

  • "Turn on/off "
  • “Set to speed #”
  • “Set to low/medium/high”
  • "Set speed to "
  • “Set to 0-100 percent”
  • "Increase "
  • “Increase speed”
  • "Decrease "
  • “Decrease speed”
  • “Increase by 15%”
  • “Decrease by 50%”

Only the first command to turn on/off the fan work as it should.

Granted, it’s possible that Google broke it last week or something, God knows it wouldn’t be the first time they mess up something that used to work perfectly fine. It’s what they do best :slight_smile:

1 Like

I believe that you shouldn’t be able to change the Type in first-party Bond → Google Home integration, and that it should say “Fan” like mine does.
If you can change the device type in the Bond → SmartThings → Google Home … but you don’t have a “Fan” type (only have a “Fan (Switch)” type) that’s a smoking gun of a sort.

The fact that you’ve had on screen controls and now you don’t is something I also cannot go back in time to help you prove. I don’t typically use Bond → Google Home first party integration but I’m jumping back into it now, only to find the ON/OFF control behavior on screen. Is it possible that your Bond → SmartThings → Google Home integration had speeds on screen, but that a Bond → Google Home integration never did??

Finally I got my problem solved after chatting with Bond Home support. Basically, I need to reset the Bond with paper clip and then add the Bond Hub again to my account. All devices still there are the reset and now I have my Bond integrated with Google Home again.


Thanks for the update, @billcsho ?
Good to hear you’re back to normal.

Hi there, when you reset it were you able to change fan speed settings in the Google Home app? Or was that just to get voice control working again?

I know, it really seems like you should be able to change the speeds visually inside the Google Home app. However, this has (to my knowledge) never been available from Google. Rather, you have to use voice either via the app’s microphone icon thinggy or via a smart speaker.

1 Like