MinkaAire Dimmer button

Not sure how this has happened, but I have been using bond with three identical MinkaAire fans in my home. Two of them are showing a dimmer button in the app and the third is not. I tried editing and adding it, but doesn’t show up as an option, tried setting it up as a new device and the same thing happened, no dimmer in the options. Any suggestions on how to get the dimmer button back for the third fan or explanation as to why the discrepancy?

I’m not sure why one of your fan lacks a dimmer where the others don’t, but I can provide an explanation as to why dimmer is not “recordable”, and a way to get a dimmer:

We don’t present a recording option for “Dimmer” buttons because getting a working dimmer button is a bit more complicated than any of the other buttons. The recording has to be sliced at just the right place to be able to be replayed as a “continuous” signal, and this is normally handled by the same service that gives you results when recording a new remote.

So I’d recommend you add a new remote, record any button, and take a look through the results that our database search gives you. These results will have the dimmer button(s).