Master Flame API/Home Assistant

I have a “Master Flame” remote. FCC ID EPK 9575TX

When I pair it with Bond, it auto-suggests “RFP21” - The “High” and “Low” functions on this remote work pretty well [except I’d like them to end after ~10 seconds instead of tapping again]

  1. This remote seems to auto-save to the cloud, so I can’t interact with it locally via api (I’ve had success with this)

  2. I’ve tried programming the two buttons, but they don’t work as well as the RFP21 functions. How can I recreate them locally?

  3. I want to actually remap these to ‘Fireplace On’ and ‘Fireplace Off’ so they’ll be compatible with “Home Assistant” (and eventually Homekit via scenes).

I’ve tried messing around with the “Signal” in the API, but it just doesn’t work as well as that cloud remote.


Welcome to the forums, @rselover!

I am thrilled to read about your attempts so far recreating locally - though I’m disappointed “raw recording” without database matching (to intentionally force the local device) isn’t leading to as stable outcomes as the cloud RFP21.

Thanks for documenting your thoughts and attempts so far, and for using the API to poke around.

I don’t have any insight into what remotes remain to be moved from cloud to local by the Bond team; hopefully one of them will stop by the forums sometime in the near future and can look into it.
(It’s seemingly the same basic issue from this thread: Device Missing from API)