Bridge firmware v2.8.1 beta release

Hey all,

Some quick notes for v2.8.1, which I just pushed to beta:

  • Add local versions of the following remotes: RCF98v2, RCF84, RCF104, RCF124, RCF118

These are the 5 most common types of stateful remotes. To give a clearer picture of where we’re at in support of local control, this brings our coverage to about 95% of remote instances of our V1 userbase. They should now all work over the Local API and through SmartThings.

If you find any unexpected behavior, please let me know! Also, if your remote is not yet supported but you’d like to use the local API for whatever reason, please let me know and I’ll try to prioritize your remote.


I’m guessing that FCC ID: H2WCASA7T is still not supported local? This is captured as RCF132. I’d really like to use that one! :slight_smile:

Make: Casablanca
Remote Model: W62

Never mind. It works under firmware 2.8.1-beta! Thanks!

1 Like

OK, sorry; my mistake. I’ve tried several times, but it keeps getting captured as a cloud device. I can record it as a local device, but it doesn’t work automatically.

Okay, I’ll prioritize RCF132!


Awesome, thanks! This remote is stateful, which makes manual programming of commands very difficult. Every time a button is pressed, it sends a different command. Really difficult to send the same command repeatedly! :face_with_symbols_over_mouth:

However, the database (cloud) version of RCF132 works perfectly!

You know what would be great? A place where I can plugin the FCC ID and see if my device is available in BOND. I’ve had to try to program my fireplace remote manually and it’s been painful. Would be nice to know when it’s added to your DB!


Yeah, we’ve put some work into this as an internal tool. It’s definitely on the roadmap after all these cloud devices get migrated down.


I can’t log into the beta app any more. Google keeps updating me to the app store version but the keeps trying to roll back my firmware. Today the beta won’t take my login and says it doesn’t know my email. I can’t install this firmware because of that.

Edit: I found the email address is case sensitive and my autocomplete was adding caps where they didn’t belong.

To James’s point about Google and Beta fighting:
I have Beta / Early Access to the Bond Home app through the Google Play Store (from a toggle I did there at some point in time?). Because of that, often my Google Play Store app auto-updates try to overwrite what I’ve just done for the Bond app via Beta by Crashlytics.

See tonight, for example.
Google Play Store:

Beta by Crashlytics:

1 Like

I have a remote that I have programmed several times now with the new version and it will not work. When I record, it is detected as an RCF84 and all the features work in the test, but once I say Use this remote, it no longer works when added to the main screen. Not sure what is happening.

Okay I’ll try to reproduce this here.

@jacob Would love support for CHQ7225T. I have three fans that use that remote in the house. Would be great to be able to control them!

Locally right? Or are you having trouble controlling them at all?

If you mean local control: Try recording them in the newest firmware (v2.8+), the app should give you a local version now. Check the device settings page for a “Local Token” field, if it’s there, you should have local control!

If you mean you can’t control them at all, we’ll need to investigate the signals… I’m pretty sure we have a working remote definition for this one.

I can control the fans in the app but not through local API. I’m running “fw_ver”: “v2.8.1-beta”, and there are no devices returned from GET /v2/devices. Do I need to remove and re-add the fans to the hub?

Try re-recording your fan, you should get a local version. Make sure everything works as expected, then you can delete the cloud version! (since v2.8.0)

Hi @jacob. Just checking in on RCF132. Thanks for the update!

Hey, this one’s ready. It’ll be available with the next firmware release, v2.9.1, should be pretty soon.

Once you get this version, just re-record and you’ll get a local version of your RCF132 remote.

1 Like