IR blaster not working on 2.16.2-beta

There’s something wrong with the newest beta firmware that is causing the IR blaster to not send commands. The blue light still flashes, but no IR signal seems to be sent. After downgrading to the current non-beta (2.15.8), the IR works normally again.

Thanks for reporting it! In the next FW release (v2.17.x) we will fix IR transmissions issues.

I still seem to also be having this issue with the latest 2.17.3 beta. Near my bond unit I have a couple of devices sending simple power on / off IR commands to 2 devices. They did stop working when the 2.16.x beta came out, & I back stepped it & it worked. I left it be for a while, since I use them. I can confirm I just tried the 2.17.3 beta today 03/15/21 & they still do not work. Back stepping to 2.15.8 they work. RMM

1 Like

Hi Randy @RMM can you please share the first two digits of your Bond ID (Serial Number)? We’ve got this fixed in v2.17.4, due out tomorrow for ZZ units. A/B units (Snowbird) will take another ~week to resolve an outstanding issue there.

Mine does start with ZZ.

I’ll check & test when it releases.


Ok, firmware released to production yesterday. ZZ units can now upgrade to v2.17.4 via the App/Play Store apps.

Can I ask quickly, as I do see this showing up in the production version of the app, & not only just the beta version.

How can I Backstep the firmware if the problem is not resolved since it is appearing in the production release & not only the beta app?



The IR issue should be resolved. Does it work again for you on v2.17.4 (or v2.17.4.1) firmware?

How can I Backstep the firmware

That’s not supported atm via the app. However you can use the bond-cli to do this from your PC. (The latest PR was actually for rollbacks! GitHub - bondhome/bond-cli: Bond Command Line Interface)

Well I had not tried it yet because I did not see a way to Backstep since it showed up in the production app and not just the beta app (I had been running the production app on my iPhone and the data app on my iPad which gave me a quick way to swap back-and-forth between the firmware versions). That’s why I was asking if there’s a way to Backstep in case it’s not resolved, since now that is showing up in the production app and not just the beta app.

I will give it a test, but I am curious if there’s a way to Backstep since I can no longer do it between the production versus beta app?

Thanks in advance


We really don’t recommend downgrading because we don’t test the downgrades. It adds a LOT more complexity and restrictions in development if we must be forwards compatible, and not just backwards compatible. Worst case you might have to reset your unit (losing devices) if it crashes. That’s pretty unlikely, but theoretically possible.

That said, yes you can use the bond-cli to get whatever version you want, even old ones. But do so at your own risk :). See link in my last post.