Home Assistant Integration - Just Broke?

Hey all. This maybe is common, but after a year happily using Bond with HA, last night the integration simply stopped.

  1. I have tried to reset the bond bridge and reconnect to HA. I enter IP and Local Token and get unexpected error.

I have tried this now 3 times but it hasn’t worked. I have done a workout around for now with Smartthings, so it’s not the end of the world, but just wondered if there was a fix as ideally I’d like to be direct from bond to HA.

Thanks and great product and support :slight_smile:

Dave

@daveando can you share firmware version of Bridge and any relevant HA / HA plugin version?

@marcio Did you figure out what went wrong with your HA integration in Floripa?

@merck - not really, we were having 10 to 15m delays on sending commands, but I’ve just rebooted the bond bridge and it didn’t happen again.

@daveando I don’t think that the Bond integration had any changes on 2022.8.x - but if you are not on the latest firmware, try upgrading it

hi,

I believe the integration randomly broke on the old firmware. I had complete control of the blinds in the bond app, it was simply the bond integration into home assistant that is broken. Could it be related to the local token? I upgraded to the v3.3.13 and still have the same issues. I will try again now.

Happy to help resolve. It’s slow via Smartthings (blinds take 5-10 secs to respond) so it’s much better prior.

Dave

I have tried to set it up again and i get ‘unexpected error’. I have gone directly to the IP of the bond bridge, and followed the prompts on the page to add the pin, and then my account password (even though it was already connected to the cloud). I added wifi details and it says connected. Tried to connect again via Home Assistant and same error ‘unexpected error’. Tried 3 times, once it gave me ‘incorrect authentication’.

Hope this helps. If I can help troubleshoot please let me know.