Google home and Bond not working

My bond hub is working fine (I can control all fans using the Bond app, or through my Hubitat hub with no problems at all).

Problem appears to be with Google. I’ve removed Bond and reinstalled the app. The Google app connects to the Bond (all fans and lights show up in the Google home), but I cannot do anything with them; neither via a tablet or voice control.

Each fan constantly toggles between “Not responding” and “Connecting…” forever.

Anyone with any ideas? I’ve rebooted the Bond hub countless times…no change in behavior. Again, everything works “outside” of Google.

I just tried all my Bond controlled fans, etc through Google Home and not having any issues… Have you refreshed Google home or cleared the cache in the app? Force stop the app, clear cache, open Google Home and refresh?

Appreciate the thought…tried that with no change. Also removed Bond from a linked service, forced stop, cleared cache, relinked Bond.

All fans show up, with the appropriate lights, but it keeps toggling (when clicking on a fan) between “Not responding” and “Connecting…”

Have you reached out to Support through the in-app chat, or through ?

(since it doesn’t seem widespread, it may be something unique to your device / account / etc)

Update: not sure what has happened, but the Google home and Bond seem to be talking with each other. Nothing changed on my end (except one last power cycle of the Bond hub). Noticed that in the afternoon, I could control the fans via voice through Google.



I think I’ve found the condition that creates this problem (and my solution works, but seems like there should be a better one).

The problem (creation): if my ISP has some issue where I lose internet service for a bit (minutes at least), then the Bond does something where I see the wireless network of the hub on the available list of networks (like when first setting up the device). However, the Bond works from the Bond app, and also from other devices like my Hubitat.

Solution (wonky): after internet service is restored, if I unplug the Bond (for at least one minute), then simply plug it back in, it connects, and the wireless “Bond” network disappears. I need to then resync the Google home, and then Google and Bond work in harmony.

Seems like the Bond should not need this rebooting. I’m on the latest beta firmware, but this problem was in existence prior to using the beta release.

Any ideas why this would be happening?

If Bond cannot reach the internet, it does assume something is wrong and turns the the setup access point back on; however, it should see when the ISP issue is resolved and automatically return to a normal state, I thought.

The fact your Google Home takes manual resynchronization is another unexpected wrinkle, at least from what I think I’ve gathered to be the normal expectation.

Thank you for sharing these specific details - hopefully someone from the Bond team can explain further what is expected vs unexpected.

residualimages, yes, you clearly understand exactly what is happening. And I would agree that I hope someone from the Bond team can explain further.