Elite Screens (EPV) Projector Screen

The remote for the projector screen has three buttons: Up, Stop, Down.

I added it as a shade, learned the buttons (the frequency was detected), the Bond Bridge Pro turns green, but none of the three buttons will move the projector.

What am I missing here?

Hey @BostonAutomations - did you manually record each of the 3 commands, or did it match to a template?

I personally don’t have any shades (or projector screens), but I’ve got a couple tricks I’ve learned for custom devices.

I just followed the instructions in the app and hit the button until Bond Pro turned green and the app showed me a frequency, which was the same for all three buttons.

It is this kit

Interesting - that page lists both an IR and an RF remote.
You’re using the RF one I assume (since Shade device types are only RF in the Bond app).

Since I don’t have Shades to try, can you tell me if you have a Template assigned when looking at the Settings of your screen device in the Bond app?
For instance, on one of my ceiling fans, I have this “A1a” template assigned after setting it up:

Update:

I think I’ve found the FCC listing of it here, via the Elite Screens website.
It mentions FSK modulation, which is not supported by the Bond Bridge (or Pro), at least not at this time.

I do not see anything in the app referring to templates and do not know what screen you are sharing from your app.

Also worth noting that my Bond Pro is on Wi-Fi on my dedicated 2.4 GHz network used only for Control4 devices that hate 5 GHz.

My device needs to be updated from 2.17.2 to 2.17.4.2 and the firmware update sits at 0% then spits out a communication error. Not a great out of the box experience and I’m not sure if it is user error or product error.

Here is the screen I see under my projector screen which is set up as a shade.

The screenshot I sent is what you would see if you tap the three dot overflow menu at the top right of that screen you shared, and hit Settings.

However, my second post last night shows that while the Bond Bridge (or Pro) can “see” the RF signal partially, it is not capable, at least currently, of replicating that FSK-modulated signal to send commands.

As far as the firmware upgrade issue, I might suggest contacting Bond support through official channels (customerservice@olibra.io or https://olibra.zendesk.com/hc/en-us).
The forum here is a handy resource for us in the community, but Bond staff are only able to come through so often and their help here may be a bit delayed.

This is what I see when I hit the three dot menu on “Theater Screen” and hit “Device Settings”

When I navigate to the device integrations screen and click on SmartThings I am redirected to Samsung.com and that’s it. There is no way to initiate the integration.
It seems to me that we are purchasing a beta product that isn’t production ready. As a dealer, I would not be comfortable selling this product to my clients.

Is there documentation or video instructions that I’m missing?

I believe integration pairing is done from the SmartThings side.

The screenshot does not show any template, thanks. You can delete the screenshot in order to protect your local token / ID.

The Bond Pro is early access, as far as I know (unless I missed the official retail launch), so our feedback to Bond early on is helpful. The consumer version (non-Pro BD-1000) has been used by a number of professional integrators successfully; it does depend on the usage case and devices wanting to be controlled as far as the efficacy of the Bond Pro (or non-Pro).

The Bond Pro website page is showing that it is available for purchase and shipping in March, which has passed, so I’m assuming that all Pro orders are being shipped. :man_shrugging:

I guess it’s been ~1 month since @merck said this, so maybe even with pandemic delays they have been able to start shipping, or will be able to do so soon.

Hey Adam, sorry for the inconvenience here. Indeed the FW update is not so reliable on v2.17.2, and we fixed this once you get to v2.17.4+. It seems that sometimes the initial FW update during the setup flow fails, but you should be able to get a subsequent update to work via the app. Tap on the Bond Bridge Pro icon, go to Settings, then Firmware Update. If it fails the first time, please try it again. — Once you are on v2.17.4+, future updates should be smooth.

We did ship a number of units with v2.17.2 firmware, but are now upgrading them prior to shipment to avoid this hassle for others.

I have tried the firmware update over 20 times and nothing happens. I have also unplugged and plugged it back in many times. I still get the same error every time, “There was a communication issue (error 107) Looks like your device is still on the previous version. Please try again.”

Out of curiosity (I see Merck is about to respond as well) - are you powering over USB or PoE?

Hmm. I see from our dashboard that you’re using Wi-Fi w/o PoE. You might try switching to Ethernet connection (and disabling Wi-Fi). Shoudn’t make a difference if it’s PoE or USB for power.

The problem has to do with flash erasure taking too long, so it’s effected by subtle things like the network settings or perhaps the type of Wi-Fi network you’re on.

EDIT: I’m working on a backup plan where you could reflash the unit via USB from a Windows computer… Unclear whether that will work. Experimenting here. EDIT2: Didn’t go so well. We’d need to develop our own utility for this… would be faster to do an exchange.

I am connected with Wi-Fi and powered with USB. I have a custom “Control4” 2.4 GHz network at my home that is dedicated for these IoT devices.

I will try hardwiring to see what happens.

Ok, great. Do a “green reset” (hold reset button until light goes green) of the Bond Bridge Pro first. Then plug into the Ethernet, set up via the app again. This way just Ethernet will be used, Wi-Fi will remain disabled.

EDIT: or you can do “Forget Wi-Fi” via Network Info > Advanced in the ap. This option only appears after you’ve set up Ethernet to avoid leaving you without any net connection.

The green reset worked however the firmware upgrade still stays at 0% and fails.

Please email me directly so we can take this off the forum and process an RMA.

Sure, we can exchange this for you. Just contact our customer support (Submit a request – BOND Home) or use the Chat feature in the app for live support.