Discourse app/API access?

I tried to add this site to the Discourse iOS app, but I’m told I don’t have the required trust level.
Is this available at a higher user level? Or is it disabled site wide?
Thanks for any help.

Hey I had the same error in the Android app, but if I clicked on the BOND icon above the error message, it took me straight into the site within the app.

Not sure if this site / version is fully mobile app compatible but I’m posting from within the app right now.

Yeah OK. That worked for me too. Though I have to do that every time I enter the forum. Strange. At least there’s a workaround for now.

@fracai Try it again, see if it’s any better…

At least in Android app, same issue, same workaround. Even after removing and re-adding site.

Apparently it’s an overzealous anti-spam default. I changed trust level required for User API from TL2 to TL1.

Works now (after hitting the newly appearing “Authorize” button), including notification and quick links to replies etc

1 Like

Yep. Authorize button and now everything is great. Thanks!

I’m getting the same message on my iPad (I just signed up):

Authorize application access

Sorry, you do not have the required trust level to access the user API

@timmo Welcome! Elevated to TL1, API should work now.

1 Like